Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 139527 - x11-libs/libXcomposite-0.3.0 emerge fails
Summary: x11-libs/libXcomposite-0.3.0 emerge fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Other
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-07-07 00:56 UTC by Chris Bruner
Modified: 2006-07-07 12:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

config.log of failed ebuild (config.log,35.63 KB, text/plain)
2006-07-07 01:01 UTC, Chris Bruner

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Bruner 2006-07-07 00:56:58 UTC
From a fresh install, emerge xorg-x11

checking for XCOMPOSITE... configure: error: Package requirements (compositeproto >=0.3 x11 xfixes xest fixesproto) were not met:

Package 'compositeproto' has no Name: field
Comment 1 Chris Bruner 2006-07-07 01:01:09 UTC
Created attachment 91101 [details]
config.log of failed ebuild
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-07-07 02:11:55 UTC
Re-emerge compositeproto and try again...
Comment 3 Chris Bruner 2006-07-07 12:23:23 UTC
Tried emerging compositeproto, but I'm getting errors
File "/usr/lib/portage/pym/", line 4551, in aux_get
  if os.access(myfn,os.R_OK):
TypeError: access() argument 1 must be (encoded string without NULL bytes), not str

I've tried reinstalling the /usr/lib/portage directory, re-syncing, and many other things, but I can't seem to get around it. 

My system may have gotten pouched during a wireless config hardlock and I had to do a manual reset, as another system with same version of portage seems to work just fine.

Any clues would be appreciated.