Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 138238 - media-gfx/sane-pixma-0.11.3 (new ebuild)
Summary: media-gfx/sane-pixma-0.11.3 (new ebuild)
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://home.arcor.de/wittawat/pixma/
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2006-06-27 10:59 UTC by Colin Kiegel
Modified: 2011-05-29 07:23 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-gfx/sane-pixma/sane-pixma-0.11.3.ebuild (sane-pixma-0.11.3.ebuild,1.51 KB, text/plain)
2006-06-27 11:00 UTC, Colin Kiegel
Details
media-gfx/sane-pixma/sane-pixma-0.13.1.ebuild (sane-pixma-0.13.1.ebuild,1.51 KB, text/plain)
2007-09-10 00:00 UTC, Geert Vanhaute
Details
New ebuild for sane-pixma 0.13.1 (sane-pixma-0.13.1.ebuild,1.50 KB, text/plain)
2008-02-12 04:27 UTC, John Whitlock
Details
New ebuild for sane-pixma 0.14.4 (sane-pixma-0.14.4.ebuild,1.51 KB, text/plain)
2008-06-05 20:50 UTC, nonas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Kiegel 2006-06-27 10:59:16 UTC
Scanner utility and SANE backend for Canon PIXMA MP series

(This backend is part of sane-cvs)

I've just tested it with my Canon MP780 - although I was able to communicate with my scanner - any attempt to scan timed out. :-/

But maybe someone else wants to try it out.
Comment 1 Colin Kiegel 2006-06-27 11:00:13 UTC
Created attachment 90297 [details]
media-gfx/sane-pixma/sane-pixma-0.11.3.ebuild
Comment 2 Colin Kiegel 2006-06-27 11:36:05 UTC
Scanning works now.

I had to choose a resolution of 600 dpi or greater. 75, 150, and 300 dpi didn't work.
Comment 3 Geert Vanhaute 2007-09-10 00:00:49 UTC
Created attachment 130449 [details]
media-gfx/sane-pixma/sane-pixma-0.13.1.ebuild

Ebuild for new version: 0.13.1
Tested with Pixma 160 and works!
Comment 4 Geert Vanhaute 2008-01-27 20:41:56 UTC
it stopped working ;-(
Now media-gfx/sane-pixma-0.13.1 fails to compile

# emerge media-gfx/sane-pixma
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) media-gfx/sane-pixma-0.13.1 to /
 * mp150-0.13.1.tar.bz2 MD5 RMD160 SHA1 SHA256 size ;-) ...                                                                                  [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                       [ ok ]
 * checking mp150-0.13.1.tar.bz2 ;-) ...                                                                                                     [ ok ]
>>> Unpacking source...
>>> Unpacking mp150-0.13.1.tar.bz2 to /var/tmp/portage/media-gfx/sane-pixma-0.13.1/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1 ...
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -DWITH_TIFF   -c -o scan.o scan.c
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic   -c -o usb.o usb.c
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic   -c -o pixma_io.o pixma_io.c
usb.c: In function 'usbSendControlMsg':
usb.c:710: warning: unused parameter 'ep'
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic   -c -o pixma_common.o pixma_common.c
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic   -c -o pixma_mp150.o pixma_mp150.c
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic   -c -o pixma_mp730.o pixma_mp730.c
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic   -c -o pixma_mp750.o pixma_mp750.c
cc -march=nocona -mtune=generic -O2 -pipe -fomit-frame-pointer -Wall -W -DWITHOUT_SANEI -DHAVE_FCNTL_H -DHAVE_STDINT_H -g -O -fPIC -pedantic    -c -o pixma_sane.o pixma_sane.c
cc -Wl,--as-needed -lm -g -O -ltiff  scan.o usb.o pixma_io.o pixma_common.o pixma_mp150.o pixma_mp730.o pixma_mp750.o   -o scan
cc -Wl,--as-needed -lm -g -O -fPIC -shared -Wl,--version-script=libsane-pixma.def -o libsane-pixma.so pixma_sane.o usb.o pixma_io.o pixma_common.o pixma_mp150.o pixma_mp730.o pixma_mp750.o
scan.o: In function `TIFF_writePage':
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:546: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:547: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:548: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:549: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:552: undefined reference to `TIFFSetField'
scan.o:/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:553: more undefined references to `TIFFSetField' follow
scan.o: In function `TIFF_writePage':
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:574: undefined reference to `TIFFDefaultStripSize'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:574: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:582: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:583: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:588: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:589: undefined reference to `TIFFDefaultStripSize'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:589: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:595: undefined reference to `TIFFDefaultStripSize'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:595: undefined reference to `TIFFSetField'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:607: undefined reference to `TIFFWriteScanline'
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:609: undefined reference to `TIFFWriteDirectory'
scan.o: In function `TIFF_close':
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:530: undefined reference to `TIFFClose'
scan.o: In function `TIFF_open':
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/scan.c:522: undefined reference to `TIFFOpen'
pixma_common.o: In function `pixma_fill_gamma_table':
/var/tmp/portage/media-gfx/sane-pixma-0.13.1/work/sane-pixma-0.13.1/pixma_common.c:740: undefined reference to `pow'
collect2: ld returned 1 exit status
make: *** [scan] Error 1
make: *** Waiting for unfinished jobs....
 * 
 * ERROR: media-gfx/sane-pixma-0.13.1 failed.
 * Call stack:
 *               ebuild.sh, line   46:  Called src_compile
 *             environment, line 2393:  Called die
 * The specific snippet of code:
 *       emake || diefunc "$FUNCNAME" "$LINENO" "$?"
 *  The die message:
 *   (no error message)
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-gfx/sane-pixma-0.13.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/sane-pixma-0.13.1/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
Comment 5 John Whitlock 2008-02-12 04:27:08 UTC
Created attachment 143285 [details]
New ebuild for sane-pixma 0.13.1

0.13.1 requires media-libs/tiff to compile.  I've added this to the ebuild.  Another issue is that collision-protect will prevent adding sane-backends and sane-pixma at the same time, if the pixma backend is included in sane-backends.  This means you need a line like:

SANE_BACKENDS="canon"

to prevent the pixma backend from being built. "canon" isn't the only value that will work - it can't be empty or missing, and it can't include 'pixma'.
Comment 6 Geert Vanhaute 2008-02-12 20:54:35 UTC
I don't get it:
media-libs/tiff is installed
[ebuild   R   ] media-libs/tiff-3.8.2-r3  USE="jbig jpeg zlib -nocxx" 0 kB

I still get the same error when compiling
fyi I'm on ~amd64
Comment 7 nonas 2008-06-05 20:50:11 UTC
Created attachment 155647 [details]
New ebuild for sane-pixma 0.14.4

New ebuild matching files found here : http://sourceforge.net/project/showfiles.php?group_id=210977

Nicolos (the author of these files) says that the pixma driver is in sane CVS though (but I am far from being capable of writing a CVS ebuild)

You can check mp610.blogspot.com for more information.
Comment 8 Mike 2008-07-08 06:27:28 UTC
This ebuild helped me to get my Canon Pixma MP210 to scan correctly.  Thank you for the ebuild!
Comment 9 Zeger 2009-02-09 18:49:04 UTC
I got my Canon MP520 scanner end working with the sane-pixma 0.14.4.ebuild! 
Still have to fix a few things but it produced a good scan of a text file.
Good job!
Comment 10 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-09 13:02:38 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq