Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 138078 - portage does not notice new binary packages during merge
Summary: portage does not notice new binary packages during merge
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-26 10:27 UTC by Marcin Kowalski
Modified: 2006-06-26 10:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kowalski 2006-06-26 10:27:24 UTC
it's hard to explain it in short topic.

okay, assume you're building a separate system via 
ROOT=/some/dir emerge something

as we know portage respects two types of dependencies RDEPs - runtime dependencies and DEPs - compilation time dependencies. if you use ROOT=/some/dir  DEPs don't get installed there, which slims down the system. 

now imagine this situation
----------------------------------------
yOSHi / # ROOT=/home/system emerge -pv mozilla-firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-apps/xdpyinfo-1.0.1  USE="-debug" 0 kB 
[ebuild  N    ] www-client/mozilla-launcher-1.51  0 kB 
[ebuild  N    ] dev-libs/libIDL-0.8.6  USE="-debug -static" 0 kB 
[ebuild  N    ] dev-libs/nspr-4.6.2  USE="ipv6" 0 kB 
[ebuild  N    ] app-arch/zip-2.31-r1  USE="crypt" 0 kB 
[ebuild  N    ] dev-libs/nss-3.11.1-r1  0 kB 
[ebuild  N    ] app-arch/unzip-5.52-r1  0 kB 
[ebuild  N    ] x11-apps/xdpyinfo-1.0.1 to /home/system/ USE="-debug" 0 kB 
[ebuild  N    ] www-client/mozilla-launcher-1.51 to /home/system/ 0 kB 
[ebuild  N    ] dev-libs/libIDL-0.8.6 to /home/system/ USE="-debug -static" 0 kB 
[ebuild  N    ] dev-libs/nspr-4.6.2 to /home/system/ USE="ipv6" 0 kB 
[ebuild  N    ] app-arch/zip-2.31-r1 to /home/system/ USE="crypt" 0 kB 
[ebuild  N    ] dev-libs/nss-3.11.1-r1 to /home/system/ 0 kB 
[ebuild  N    ] sys-devel/binutils-config-1.8-r7 to /home/system/ 0 kB 
[ebuild  N    ] sys-devel/binutils-2.16.1-r2 to /home/system/ USE="nls -multislot -multitarget -test -vanilla" 0 kB 
[ebuild  N    ] app-arch/unzip-5.52-r1 to /home/system/ 0 kB 
[ebuild  N    ] www-client/mozilla-firefox-1.5.0.4 to /home/system/ USE="ipv6 -debug -gnome -java -mozdevelop -xinerama -xprint" 0 kB 
-----------------------------------------------------
as you can see some libraries get installed into main system AND into system in ROOT variable. so, in order to prevent certain packages being built twice (with exactly the same cflags etc) , i tried: 

FEATURES="buildpkg" ROOT=/home/system emerge -k mozilla-firefox

so that portage would build binary packages and then reuse them in the second compile.

but portage does not notice the packages it created until you interrupt the merge and rerun the command again. that's where portage notices that some binary packages are available and uses them, skipping their compilation.

there could be some kind of environment check after each package when portage builds a string of packages.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-26 10:43:37 UTC

*** This bug has been marked as a duplicate of 1343 ***