Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 137728 - media-libs/libnjb should install udev rules
Summary: media-libs/libnjb should install udev rules
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: udev-meta
  Show dependency tree
 
Reported: 2006-06-23 06:43 UTC by Francois Chenier
Modified: 2008-02-10 10:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
udev rules to avoid using gnomad as root (99-nomad.rules,1.71 KB, text/plain)
2006-06-23 06:47 UTC, Francois Chenier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Chenier 2006-06-23 06:43:55 UTC
With (so no) recent change from devfs to udev, gnomead requires root previleges to access Nomad / Zen mp3 players through USB port.

The problem is that with the switch to udev, the device (now under /dev/bus/usb/) is not set with either the correct group or the correct permission to match the model that was used before. The udev config appears to indicate that the nomadjukebox should be run for the device, but it isn't. I don't see any indication that udevd has received an event from the kernel when the nomad was plugged in. And even if it did receive the event and run the script, it won't work because the script expects the device file to be a regular file (which it was under /proc/bus/usb/) rather than a character file (which it is under /dev/bus/usb/).

To fix this issue can you had the included attachement to the package.
Comment 1 Francois Chenier 2006-06-23 06:47:25 UTC
Created attachment 89909 [details]
udev rules to avoid using gnomad as root

File to save in /etc/udev/rules.d directory ...
Comment 2 Francois Chenier 2006-06-23 07:07:09 UTC
After a little brainstorming any package using libnjb may have this problem (neutrino, etc) Can you include the fix to this library instead ?
Comment 3 Matthias Schwarzott gentoo-dev 2007-03-17 15:23:03 UTC
First:

change
SUBSYSTEM!="usb_device", ACTION!="add", GOTO="libnjb_rules_end"
to
SUBSYSTEM!="usb_device", GOTO="libnjb_rules_end"
ACTION!="add", GOTO="libnjb_rules_end"

Second:
change SYSFS to ATTRS.
Comment 4 Jeff Mitchell 2007-04-25 17:21:50 UTC
Actually, libnjb includes udev rules in their 2.2.5 release.

For whatever reason, the ebuild isn't installing them, instead installing the hotplug files.

Fixing the ebuild to install the libnjb-provided udev rules shouldn't be too difficult and should fix this problem.
Comment 5 Samuli Suominen gentoo-dev 2007-08-10 11:50:34 UTC
Added udev rules to 2.2.5-r1, modified like Comment #3 suggested. I don't have hardware to test, so report back if it fails..
Comment 6 Will Saxon 2008-02-10 06:47:41 UTC
This should probably use the nomad.rules file from the libnjb source distribution, and not the rules file in the attachment. They are somewhat different.
Comment 7 Samuli Suominen gentoo-dev 2008-02-10 10:31:56 UTC
(In reply to comment #6)
> This should probably use the nomad.rules file from the libnjb source
> distribution, and not the rules file in the attachment. They are somewhat
> different.
> 

Different in sense that ones in sources are invalid for our udev version..