Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 137354 - nntpcache (new ebuild)
Summary: nntpcache (new ebuild)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://iq.org/~proff/nntpcache.org/
Whiteboard:
Keywords: EBUILD
: 137312 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-06-20 03:32 UTC by Alessandro Di Marco
Modified: 2013-07-06 13:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuilds for nntpcache 3.0.2 (nntpcache-3.0.2.ebuild,1.55 KB, text/plain)
2006-06-20 03:38 UTC, Alessandro Di Marco
Details
init.d file needed to start/stop the nntpd server (nntpcache.initd,310 bytes, text/plain)
2006-06-20 03:40 UTC, Alessandro Di Marco
Details
ebuild for nntpcache 3.0.2 (nntpcache-3.0.2.ebuild,1.74 KB, text/plain)
2006-06-23 16:27 UTC, Alessandro Di Marco
Details
silly bugfix (nntpcache-3.0.2-srvauth.patch,876 bytes, text/plain)
2006-06-23 16:31 UTC, Alessandro Di Marco
Details
nasty bugfix producing page faults on amd64 architectures (nntpcache-3.0.2-argfix.patch,1.74 KB, text/plain)
2006-06-23 16:46 UTC, Alessandro Di Marco
Details
ebuild for nntpcache 3.0.2 (nntpcache-3.0.2.ebuild,1.81 KB, text/plain)
2006-07-11 08:45 UTC, Alessandro Di Marco
Details
nntpcache stealth mode (nntpcache-3.0.2-post.patch,955 bytes, text/plain)
2006-07-11 08:48 UTC, Alessandro Di Marco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Di Marco 2006-06-20 03:32:51 UTC
Hi all,
please find in attachment the ebuilds for the 3.0.1 and 3.0.2 version of
NNTPCache. The vanilla distros won't compile due to a bunch of sandbox
violations, successfully solved thanks to a patch-script contained in the
ebuild itself. Probably these scripts diverge from the usual gentoo patching
way, but I found them really effective.

Best,

NNTPCache (efficiently) executes on the localhost pretending to be an NNRP news
reading server. In fact, what it does is pass certain NNTP commands through to
real (remote and possibly local) news-servers based on various pattern matching
rules. NNTPCache then takes the output from those servers and caches & indexes
it in funky ways (much case specific magic goes into this). The next time such
information is asked for, or other information which can be logically inferred
from the previously collated information, it is sent directly from the cache,
without consulting the remote servers...
Comment 1 Alessandro Di Marco 2006-06-20 03:38:52 UTC
Created attachment 89620 [details]
ebuilds for nntpcache 3.0.2

works well also for the previous versions, simply rename it
Comment 2 Alessandro Di Marco 2006-06-20 03:40:04 UTC
Created attachment 89621 [details]
init.d file needed to start/stop the nntpd server
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-06-20 04:22:59 UTC
*** Bug 137312 has been marked as a duplicate of this bug. ***
Comment 4 Alessandro Di Marco 2006-06-23 16:27:17 UTC
Created attachment 89963 [details]
ebuild for nntpcache 3.0.2

Improved ebuild version; it now depends on two patches, one of them fixing a nasty bug that prevented the correct execution on amd64 (see the attached files for details). IMHO now it is quite stable on this architecture.
Comment 5 Alessandro Di Marco 2006-06-23 16:31:11 UTC
Created attachment 89964 [details]
silly bugfix

Fixes a bug preventing the adoption of password-protected nntpservers.
Comment 6 Alessandro Di Marco 2006-06-23 16:46:05 UTC
Created attachment 89965 [details]
nasty bugfix producing page faults on amd64 architectures

I've searched hard on the web about a patch like this, but nothing, nietz, nicht, nada. So I have developed it by myself. Now I'm pretty sure that this is actually the only way to get nntpcache running on amd64 and beyond (the nntpcache mailing list closed-down earlier in 2003), so take care of it. Probably nntpcache won't be very useful at most, but is a very good piece of code with characteristics making it really unique.
Comment 7 Alessandro Di Marco 2006-07-11 08:45:16 UTC
Created attachment 91472 [details]
ebuild for nntpcache 3.0.2

Now supports the stealth mode (see nntpcache-3.0.2-post.patch)
Comment 8 Alessandro Di Marco 2006-07-11 08:48:59 UTC
Created attachment 91473 [details]
nntpcache stealth mode

Blocks nntpcache sending out headers that could harm your privacy ;-)
Comment 9 Pavlos Ratis (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2013-07-06 13:09:41 UTC
Project seems dead. Homepage, SRC_URI down.