Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 137207 - FILECOLLISION sys-apps/man-pages && net-mta/netqmail-1.05-r8: /usr/share/man/man3/error.3
Summary: FILECOLLISION sys-apps/man-pages && net-mta/netqmail-1.05-r8: /usr/share/man/...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Qmail Team (OBSOLETE)
URL:
Whiteboard:
Keywords: QAcanfix
: 132167 155729 166228 211890 222885 234365 253608 258520 263463 264302 266629 290196 291372 (view as bug list)
Depends on: 253453 333915
Blocks:
  Show dependency tree
 
Reported: 2006-06-18 14:36 UTC by Peter Gantner (a.k.a. nephros)
Modified: 2013-05-28 05:39 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Gantner (a.k.a. nephros) 2006-06-18 14:36:33 UTC
+++ This bug was initially created as a clone of Bug #127005 +++

* checking 3175 files for package collisions
existing file /usr/share/man/man3/error.3.gz is not owned by this package
1000 files checked ...
2000 files checked ...
3000 files checked ...
* spent 5.34093999863 seconds checking for file collisions
* This package is blocked because it wants to overwrite
* files belonging to other packages (see messages above).
* If you have no clue what this is all about report it
* as a bug for this package on http://bugs.gentoo.org

package sys-apps/man-pages-2.33 NOT merged

No package files given... Grabbing a set.
# equery b /usr/share/man/man3/error.3.gz
[ Searching for file(s) /usr/share/man/man3/error.3.gz in *... ]
mail-mta/qmail-1.03-r16 (/usr/share/man/man3/error.3.gz)
Comment 1 Peter Gantner (a.k.a. nephros) 2006-07-19 22:55:27 UTC
bump.
I didn't dare to propose a fix as the qmail ebuild is a bit scary, but as there's a similar hack already in there I think it's as simple as

--- /usr/portage/mail-mta/qmail/qmail-1.03-r16.ebuild   2006-07-01 21:39:01.000000000 +0200
+++ qmail-1.03-r16.ebuild       2006-07-20 07:46:18.000000000 +0200
@@ -365,6 +365,8 @@
 
        # Don't install this one, it's provided by ucspi-tcp, bug #127005
        rm tcp-environ.5
+       # This is provided by man-pages. bug #137207
+       rm error.3
 
        into /usr
        einfo "Installing manpages"

I am not sure wether the pages describe the same thing though, so probably a rename would be better instead.
Comment 2 Anders Hellgren gentoo-dev 2006-07-20 09:18:33 UTC
(In reply to comment #1)
> I am not sure wether the pages describe the same thing though, so probably a
> rename would be better instead.
> 
Both refer to error.h in the synopsis, but the qmail one does not match /usr/include/error.h.
Comment 3 Peter Gantner (a.k.a. nephros) 2006-07-20 11:04:27 UTC
Yes, I looked them up and the qmail one looks very basic on comparison.

Looks like all the *.3 pages are documentation for the header files. Since they all use names very similar to general linux syscalls, headerfiles or utilities, perhaps they shouldn't be installed by the ebuild at all, or at least under a different name?

coe.3       error.3       fd_move.3    now.3        wait.3
alloc.3  datetime.3  error_str.3   fifo_make.3  sgetopt.3
case.3   direntry.3  error_temp.3  getln.3      stralloc.3
cdb.3    env.3       fd_copy.3     getln2.3     subgetopt.3
Comment 4 Allen Brooker (AllenJB) 2007-02-06 20:20:00 UTC
6 months on... Is this bug waiting on something inparticular?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-02-10 17:31:33 UTC
*** Bug 166228 has been marked as a duplicate of this bug. ***
Comment 6 Peter Gantner (a.k.a. nephros) 2007-02-10 23:07:02 UTC
AFAIK mail-mta/qmail has been deprecated in favour of netqmail.
So in case netqmail does not have that problem I suggest to close this bug.

Otherwise, just do not install the *.3 man pages - they are only be interesting to qmail developers, not to normal qmail users.
Comment 7 Hans de Graaff gentoo-dev 2007-02-11 08:28:36 UTC
I just migrated from qmail to netqmail and ran into this issue, so the problem is not solved for netqmail.
Comment 8 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2007-02-11 19:02:36 UTC
*** Bug 155729 has been marked as a duplicate of this bug. ***
Comment 9 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2007-02-11 19:16:47 UTC
*** Bug 132167 has been marked as a duplicate of this bug. ***
Comment 10 Peter Gantner (a.k.a. nephros) 2007-04-11 22:32:53 UTC
Bump for this bug.

man-pages just got updated to 2.44 and still collide with mail-mta/(net)qmail.

Suggest a review of line 186 of the netqmail ebuild:
186 doman *.[1-8]

*.3 man pages are definitely not relevant to users and should not be installed into $MANDIR because of collisions with man-pages.

some of the *.1 man pages also look suspicious (e.g., except.1) but do not collide with anything ATM.
Comment 11 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2007-04-12 06:54:18 UTC
(In reply to comment #10)
> *.3 man pages are definitely not relevant to users and should not be installed
> into $MANDIR because of collisions with man-pages.

Where should they be installed instead?

> some of the *.1 man pages also look suspicious (e.g., except.1) but do not
> collide with anything ATM.

These are valid programs which are used in dot-qmail files (~/.qmail*, etc.).
Comment 12 Peter Gantner (a.k.a. nephros) 2007-04-12 08:38:00 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > *.3 man pages are definitely not relevant to users and should not be installed
> > into $MANDIR because of collisions with man-pages.
> 
> Where should they be installed instead?

AFAICS either:

1) Not at all, not relevant to users.
2) Somewhere in /usr/share/doc/netqmail-XX for those who really need them (but qmail *developers* can be expected to be working with the source tree anyway)
3) Rename them to e.g. qmail-error.3 and install to $MANDIR/man3 as usual.

I like 3 but its your choice.

--- netqmail-1.05-r7.ebuild_    2007-04-12 10:35:02.000000000 +0200
+++ netqmail-1.05-r7.ebuild     2007-04-12 10:35:05.000000000 +0200
@@ -182,6 +182,10 @@
                qreceipt qsmhook sendmail tcp-env
 
        einfo "Installing manpages"
+       for f in *.3
+       do
+               mv $f qmail-${f}
+       done
        into /usr
        doman *.[1-8]

Comment 13 Peter Gantner (a.k.a. nephros) 2007-04-30 14:00:46 UTC
bump. Issue remains for newly-released -r8.

It keeps two arguably important packages from being installed for a really trivial reason - repeating comment #4 what is this bug waiting for in particular?
Comment 14 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2007-04-30 20:12:33 UTC
(In reply to comment #13)
> bump. Issue remains for newly-released -r8.

Had you checked ChangeLog, you'd known it hasn't been fixed.

> what is this bug waiting for in particular?

A solution. Renaming or even leaving out manpages isn't one because it would alter the upstream packaged (net)qmail too much.

How about introducing our own man section? X also has its own.
Comment 15 Peter Gantner (a.k.a. nephros) 2007-05-03 18:59:34 UTC
(In reply to comment #14)
> A solution. Renaming or even leaving out manpages isn't one because it would
> alter the upstream packaged (net)qmail too much.

I don't buy this argument, still... 
> How about introducing our own man section? X also has its own.
sounds like a good idea, so let's try that:

--- netqmail-1.05-r8.ebuild_    2007-04-30 15:51:07.000000000 +0200
+++ netqmail-1.05-r8.ebuild     2007-05-03 20:49:33.000000000 +0200
@@ -179,8 +179,17 @@
                qreceipt qsmhook sendmail tcp-env
 
        einfo "Installing manpages"
+       MY_MAN_EXTRADIR="/usr/share/man/man3q"
+       diropts -o root -g root -m 755
+       dodir $MY_MAN_EXTRADIR
+       insinto $MY_MAN_EXTRADIR
+       insopts -o root -g root -m 755
+       for f in *.3; do
+               mv $f ${f:-1:1}q
+       done
+       doins *.3q
        into /usr
-       doman *.[1-8]
+       doman *.[1-2,4-8]
 
        dodoc BLURB* CHANGES FAQ INSTALL* PIC* README* REMOVE* SECURITY \
                SENDMAIL SYSDEPS TARGETS TEST* THANKS* THOUGHTS TODO* \

(requires some ugly messing around with insopts and friends because there doesn't appear to be something like manopts or mandir, but it does the trick.)

Unfortunately this approach requires the addition of the "man3q" section to /etc/man.conf like so:
-MANSECT                1:1p:8:2:3:3p:4:5:6:7:9:0p:tcl:n:l:p:o:1x:2x:3x:4x:5x:6x:7x:8x
+MANSECT                1:1p:8:2:3:3p:4:5:6:7:9:0p:tcl:n:l:p:o:3q:1x:2x:3x:4x:5x:6x:7x:8x
                                       ^^^
as well as probably the adaptation of the several shell auto-completion configs, e.g. /etc/profile.d/tcsh-complete and friends.

Seems overkill to me personally but if it does get this thing over with...
Comment 16 Peter Gantner (a.k.a. nephros) 2007-05-03 19:43:50 UTC
Just realized we might get away with the much simpler

--- netqmail-1.05-r8.ebuild_    2007-04-30 15:51:07.000000000 +0200
+++ netqmail-1.05-r8.ebuild     2007-05-03 21:14:17.000000000 +0200
@@ -179,8 +179,11 @@
                qreceipt qsmhook sendmail tcp-env
 
        einfo "Installing manpages"
+       for f in *.3; do
+               mv $f ${f:-1:1}q
+       done
        into /usr
-       doman *.[1-8]
+       doman *.[1-2,3q,4-8]
 
        dodoc BLURB* CHANGES FAQ INSTALL* PIC* README* REMOVE* SECURITY \
                SENDMAIL SYSDEPS TARGETS TEST* THANKS* THOUGHTS TODO* \

Pages still end up in ${MANDIR}/man3 instead of man3q but man itself doesn't seem to bother much, even with unaltered man.conf.
Only side-effect is that "man error" (etc.) will find qmails error page before the one from man-pages - not sure how to fix that.

This is undesireable because most of those pages LOOK like they are documenting linux/libc header files (most make no mention of qmail anywhere) but contain information which is outright WRONG for linux/libc headers.

In addition, the qmail headers they do document are not even installed by the ebuild -- so installing their man pages to $MANPATH makes even less sense.

I repeat my suggestion to not install those pages, or install them somewhere where they do not mask useful information, e.g. $DOCDIR.
Comment 17 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2007-05-07 19:52:32 UTC
I had to mark 1.05-r8 stable today because of a serious problem with OpenSSL 0.9.8e. However, I'll address the man pages issue in -r9.
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2008-03-01 10:12:30 UTC
*** Bug 211890 has been marked as a duplicate of this bug. ***
Comment 19 Mark Loeser (RETIRED) gentoo-dev 2008-04-06 02:36:57 UTC
qmail team:  What do you want to do with this bug?  If there is no comment in the next few days, I'll just have netqmail not install the man pages that collide with sys-apps/man-pages.
Comment 20 Benedikt Böhm (RETIRED) gentoo-dev 2008-04-06 17:17:01 UTC
fixed in 1.06
Comment 21 Benedikt Böhm (RETIRED) gentoo-dev 2008-05-23 04:40:51 UTC
*** Bug 222885 has been marked as a duplicate of this bug. ***
Comment 22 Benedikt Böhm (RETIRED) gentoo-dev 2008-08-11 21:18:32 UTC
*** Bug 234365 has been marked as a duplicate of this bug. ***
Comment 23 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-01-03 22:19:54 UTC
*** Bug 253608 has been marked as a duplicate of this bug. ***
Comment 24 Joao Rodrigues 2009-01-25 19:24:53 UTC
(In reply to comment #20)
> fixed in 1.06
> 

Well, I would suggest 1.06 to be marked as stable so that people dont constantly run into this problem.
I guess that will probably not take long anyway, but just letting you know I ran again into this problem.
Comment 25 Jeremy Koppel 2009-02-05 17:45:04 UTC
I'm sorry if I didn't understand from the other posts, but I have just run into this on one of my servers, and I see that this is several years old, and set as resolved, but what is the fix for this?  I see that mail-mta/netqmail-1.06 is still hard masked, and even 5 of the dependencies it says it needs are masked:

=sys-apps/ucspi-ssl-0.70-r1 ~amd64
=net-mail/dot-forward-0.71-r3 ~amd64
=sys-process/daemontools-0.76-r6 ~amd64
=virtual/checkpassword-0 ~amd64
=sys-apps/ucspi-tcp-0.88-r17 ~amd64

That's an awful lot of warning signs _not_ to do this upgrade...
Comment 26 Benedikt Böhm (RETIRED) gentoo-dev 2009-02-07 16:31:25 UTC
(In reply to comment #25)
> I'm sorry if I didn't understand from the other posts, but I have just run into
> this on one of my servers, and I see that this is several years old, and set as
> resolved, but what is the fix for this?  I see that mail-mta/netqmail-1.06 is
> still hard masked, and even 5 of the dependencies it says it needs are masked:

netqmail-1.06 will be unmasked as soon as ucspi-ssl is keyworded for the required archs, but i have no ETA for a stable request yet. anyway, i'm using these ebuilds for a long time now, and they have done a great job.
Comment 27 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-02-11 06:34:32 UTC
*** Bug 258520 has been marked as a duplicate of this bug. ***
Comment 28 Benedikt Böhm (RETIRED) gentoo-dev 2009-03-23 21:33:31 UTC
*** Bug 263463 has been marked as a duplicate of this bug. ***
Comment 29 Benedikt Böhm (RETIRED) gentoo-dev 2009-04-01 09:12:58 UTC
*** Bug 264302 has been marked as a duplicate of this bug. ***
Comment 30 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-19 15:18:09 UTC
*** Bug 266629 has been marked as a duplicate of this bug. ***
Comment 31 Patrick ALLAERT 2009-10-21 10:12:48 UTC
This problem still exist using current (unkeyworded) packages.
Still not fixed for me as using keyworded packages is not an option on this box.
Comment 32 Brett Procter 2009-10-23 02:34:47 UTC
*** Bug 290196 has been marked as a duplicate of this bug. ***
Comment 33 Benedikt Böhm (RETIRED) gentoo-dev 2009-11-01 08:55:09 UTC
*** Bug 291372 has been marked as a duplicate of this bug. ***
Comment 34 Benoit Izac 2009-11-01 12:26:35 UTC
(In reply to comment #33)
> *** Bug 291372 has been marked as a duplicate of this bug. ***
> 

This bug still not resolved for me, and I do not understand why the status is RESOLVED FIXED. Start with latest stage3-amd64 and emerge qmail, it will fail!

Please add a revision 9 with fix or mark 1.06 as stable.
Comment 35 Torsten Veller (RETIRED) gentoo-dev 2009-12-01 06:22:52 UTC
What's stopping netqmail-1.0.6 from being stabilized?

The arches missing in bug 253453 (m68k,mips) will probably never keyword ucspi-ssl.

Please don't close this bug as long as it isn't fixed for stable users.
Comment 36 Markos Chandras (RETIRED) gentoo-dev 2010-02-24 16:31:50 UTC
Blocks bug 285213 as well. Please add arches if you think that 1.06 should go stable. Thanks
Comment 37 Martin Mokrejš 2010-04-27 18:32:47 UTC
(In reply to comment #35)
> What's stopping netqmail-1.0.6 from being stabilized?
> 
> The arches missing in bug 253453 (m68k,mips) will probably never keyword
> ucspi-ssl.

After 2 months later, still am hitting this issue on stable amd64 with mail-mta/netqmail-1.05-r8 having file collision with:

sys-apps/man-pages-3.23 (/usr/share/man/man3/error.3.bz2)

Comment 38 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2013-05-27 00:33:29 UTC
This is already fixed in 1.06, which IS stable.