Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 136578 - USE-level dependancy checking
Summary: USE-level dependancy checking
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-12 13:51 UTC by Ben Davis
Modified: 2006-06-12 13:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Davis 2006-06-12 13:51:09 UTC
Portage desparately needs USE-level dependancy checking.  For instance,  pgadmin3 is dependant on wxGTK, but will not compile unless wxGTK is compiled with the "unicode" USE flag. However,  if I emerge pgadmin,  it proceeds to compile wxGTK _without_ unicode support, then when it gets to pgadmin, it tells me I need to re-emerge wxGTK with the "unicode" use flag enabled.

It would be very time-saving to the user if the portage would check dependancies on the USE level, and recompile any apps requiring a change in USE flags.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-12 13:58:53 UTC

*** This bug has been marked as a duplicate of 2272 ***