Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 136033 - Baselayout 1.12.1 and broken runlevel entry
Summary: Baselayout 1.12.1 and broken runlevel entry
Status: RESOLVED DUPLICATE of bug 103275
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-08 02:02 UTC by paapaa125
Modified: 2006-06-08 03:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paapaa125 2006-06-08 02:02:29 UTC
I updated to baselayout 1.12.1 (from the stable 1.11.14-r8). I also updated all the config files with etc-update. My computer boots fine but when I run "rc-update -s", I get this:

 * Broken runlevel entry: /etc/runlevels/default/local
 * Broken runlevel entry: /etc/runlevels/boot/localmount
 * Broken runlevel entry: /etc/runlevels/boot/urandom
 * Broken runlevel entry: /etc/runlevels/boot/clock
 * Broken runlevel entry: /etc/runlevels/boot/keymaps
 * Broken runlevel entry: /etc/runlevels/boot/hostname
 * Broken runlevel entry: /etc/runlevels/boot/checkroot
 * Broken runlevel entry: /etc/runlevels/boot/rmnologin
 * Broken runlevel entry: /etc/runlevels/boot/net.lo
 * Broken runlevel entry: /etc/runlevels/boot/checkfs
 * Broken runlevel entry: /etc/runlevels/boot/bootmisc
 * Broken runlevel entry: /etc/runlevels/nonetwork/local
           alsasound | boot                          
            bootmisc | boot                          
             checkfs | boot                          
           checkroot | boot                          
               clock | boot                          
               cupsd |      default                  
            hostname | boot                          
             keymaps | boot                          
               local |      default nonetwork        
          localmount | boot                          
             modules | boot                          
            net.eth0 |      default                  
              net.lo | boot                          
          ntp-client |      default                  
           rmnologin | boot                          
             urandom | boot

And when I look at /etc/runlevels/boot/ I see this kind of entries:

lrwxrwxrwx 1 root root 36 2006-05-03 00:08 bootmisc -> /tmp/stage1root//etc/init.d/bootmisc

The link is obviously incorrect.
Comment 1 SpanKY gentoo-dev 2006-06-08 03:36:36 UTC

*** This bug has been marked as a duplicate of 103275 ***