Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135844 - x11-wm/fluxbox-0.9.15.1 failed
Summary: x11-wm/fluxbox-0.9.15.1 failed
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Diego Elio Pettenò (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-06 19:44 UTC by matthew.cline
Modified: 2006-07-28 00:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matthew.cline 2006-06-06 19:44:10 UTC
After adding "confcache" to FEATURES, whenever I try to emerge any ebuild, I get this error (using fluxbox as an example, but all ebuilds fail like this):

Calculating dependencies... done!
>>> Emerging (1 of 1) x11-wm/fluxbox-0.9.15.1 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking fluxbox-0.9.15.1.tar.bz2 ;-)
>>> Unpacking source...
>>> Unpacking fluxbox-0.9.15.1.tar.bz2 to /var/tmp/portage/fluxbox-0.9.15.1/work
 * Applying fluxbox-0.9.13-our-styles-go-over-here.patch ...                                      [ ok ]
 * Applying 129065-fix-doubleclick-64bit.patch ...                                                [ ok ]
 * Fixing backgrounds... ...                                                                      [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/fluxbox-0.9.15.1/work/fluxbox-0.9.15.1 ...
 * econf: updating fluxbox-0.9.15.1/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating fluxbox-0.9.15.1/config.sub with /usr/share/gnuconfig/config.sub
/usr/bin/confcache --confcache-ignore /var/tmp/ccache:/var/tmp/portage/.distcc distccmon-gui --confcache-dir /var/tmp/confcache ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls --disable-xinerama --enable-xft --disable-kde --enable-gnome --enable-imlib2 --enable-slit --sysconfdir=/etc/X11/fluxbox --with-style=/usr/share/fluxbox/styles/Emerge --build=i686-pc-linux-gnu --quiet
no cache
exception caught executing distccmon-gui: [Errno 2] No such file or directory
!!! ERROR: x11-wm/fluxbox-0.9.15.1 failed.
Call stack:
  ebuild.sh, line 1531:   Called dyn_compile
  ebuild.sh, line 931:   Called src_compile
  fluxbox-0.9.15.1.ebuild, line 91:   Called econf '--enable-nls' '--disable-xinerama' '--enable-xft' '--disable-kde' '--enable-gnome' '--enable-imlib2' '--enable-slit' '--sysconfdir=/etc/X11/fluxbox' '--with-style=/usr/share/fluxbox/styles/Emerge'
  ebuild.sh, line 533:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 matthew.cline 2006-06-06 19:46:03 UTC
I forgot the emerge --info. Also, I do have distccmon-gui installed in /usr/bin


Portage 2.1_rc2-r3 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r8 i686)
=================================================================
System uname: 2.6.16-gentoo-r8 i686 AMD Athlon(tm) XP
Gentoo Base System version 1.12.0
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -mtune=athlon-xp -pipe -fomit-frame-pointer -w"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -mtune=athlon-xp -pipe -fomit-frame-pointer -w"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache confcache distlocks metadata-transfer parallel-fetch prelink sandbox sfperms strict"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.chem.wisc.edu/gentoo/ http://mirror.datapipe.net/gentoo http://gentoo.mirrors.tds.net/gentoo"
MAKEOPTS=" -s"
PKGDIR="/usr/local/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/my_overlay /usr/local/portage/layman/portage-xgl /usr/local/portage/layman/fluidportage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acpi alsa apache2 apm avi bash-completion bitmap-fonts bzip2 bzlib cairo ccache cddb cdr cli crypt cups dbus dlloader doc dri eds emboss encode esd examples firefox flac foomaticdb fortran gif glitz gnome gpm gstreamer gtk gtk2 hal hbci imlib innodb isdnlog ithreads java jpeg jpeg2k kqemu libg++ libwww mad mikmod mmx mmxext motif mp3 mpeg ncurses nls nptl nptlonly nvidia offensive ofx ogg opengl oss pam pcre pdflib perl pic png pppd pthreads python qt quicktime quotes readline real reflection ruby sdl session snmp source spell spl sse ssl svg tcltk tcpd theora tiff truetype truetype-fonts type1-fonts udev vcd vim-with-x vorbis win32codecs x86 xine xml xorg xprint xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia video_cards_nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 matthew.cline 2006-06-06 19:50:43 UTC
As per bug #13445, here is the tail bit of genlop -l:

Tue Jun  6 13:00:28 2006 >>> app-office/openoffice-2.0.2-r2
Tue Jun  6 21:50:05 2006 >>> dev-perl/Algorithm-Diff-1.1901
Tue Jun  6 21:50:11 2006 >>> app-portage/pfs-0.1.0
Tue Jun  6 22:21:07 2006 >>> dev-libs/apr-util-0.9.12
Tue Jun  6 22:24:42 2006 >>> dev-util/confcache-0.4.2-r1


I could not find a config.log in the leftovers in /var/tmp/portage, nor could I find a file called /var/tmp/confcache/config.cache
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 00:58:44 UTC
Attach all the info requested in Bug 134454, Comment #0 and reopen then.
Comment 4 matthew.cline 2006-06-07 06:59:50 UTC
I thought that I did this is comment #2?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 07:02:42 UTC
(In reply to comment #4)
> I thought that I did this is comment #2?

No, you didn't. Reopen once you've attached required info.

Comment 6 matthew.cline 2006-06-07 08:01:46 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > I thought that I did this is comment #2?
> 
> No, you didn't. Reopen once you've attached required info.
> 
Actually, I did.

bug #13445 asks for:

"/var/tmp/confcache/config.cache file
config.log file from failed ebuild
genlop -l output, cut at the point where the failure happened (showing the
previously built packages)"

As I said in comment #2:

- there is no file called "/var/tmp/confcache/config.cache" on my system, so how do I post a non-existant file?
- there is no file called "/var/tmp/portage/fluxbox-0.9.15.1/work/config.log" on my system. How do I post a non-existant file?
- I included the output of genlop -l, cut at the point the failure happened, that shows the five previously built packages.

Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 08:07:22 UTC
Well, then don't blame confcache for this. If you have no cache, it's not used. Disable the distccmon-gui thing or what's that and try again.
Comment 8 matthew.cline 2006-06-07 09:12:43 UTC
The reason I reported this as a bug with confcache is because:

1) no confcache in "FEATURES": I can emerge stuff
2) confcache in "FEATURES": I can't emerge stuff

If you look at the error message in my initial bug report:

"/usr/bin/confcache --confcache-ignore /var/tmp/ccache:/var/tmp/portage/.distcc
distccmon-gui --confcache-dir /var/tmp/confcache ./configure --prefix=/usr
--host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info
--datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls
--disable-xinerama --enable-xft --disable-kde --enable-gnome --enable-imlib2
--enable-slit --sysconfdir=/etc/X11/fluxbox
--with-style=/usr/share/fluxbox/styles/Emerge --build=i686-pc-linux-gnu --quiet"

It is confcache that is trying to reference distccmon-gui. Since that is part of distcc, and I don't have distcc added to "FEATURES", I don't know why confcache would want to reference it.

So why is confcache trying to call distccmon-gui?
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 09:14:23 UTC
Sigh...
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 09:14:55 UTC
Away from bug-wranglers, Flameeyes enjoy...
Comment 11 matthew.cline 2006-06-07 09:22:09 UTC
(In reply to comment #9)
> Sigh...
> 

Please don't treat me like an idiot.

I am having a problem using a feature of portage. I am trying to understand why it is not working and to find a way to fix it.

I am sorry that you feel that I am wasting your time. I'll close this bug and stop trying to use confcache.
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-06-07 09:29:10 UTC
Err no, Jakub just said that it's my turn to take care of the bug as I'm the one taking care of confcache feature :)
Comment 13 Gilles Dartiguelongue gentoo-dev 2006-06-07 21:12:18 UTC
isn't it because of perms problems ? I saw an einfo about this last time I updated confcache. Maybe it is related
Comment 14 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-07-28 00:08:39 UTC
I unfortunately know what this is now :/ autoconf versions mismatch breaks confcache.

Waiting for upstream to update confcache now, but won't count on it.