Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135420 - mozilla-firefox fails to compile cause of parallel build issues
Summary: mozilla-firefox fails to compile cause of parallel build issues
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
: 131727 136632 152905 162782 163449 (view as bug list)
Depends on:
Reported: 2006-06-03 11:44 UTC by Björn Ruberg
Modified: 2007-08-09 11:03 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

log of the compile (buildlog,12.47 KB, text/plain)
2006-06-03 11:47 UTC, Björn Ruberg

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Ruberg 2006-06-03 11:44:30 UTC

today I had to discover that the new firefox-1.5 version doesn't want to compile for me.
I'm using gcc-4.1.1 and hadn't such a problem with previous versions.
Here is what goes wrong:

I put the compile log in an attachment.

Here my system info:

Portage 2.0.54-r2 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.3.6-r3, 2.6.16-gentoo-r7 i686)
System uname: 2.6.16-gentoo-r7 i686 AMD Athlon(tm) XP 2800+
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -ftracer -fweb -frename-registers -fno-ident -fno-align-labels -fno-align-loops"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -ftracer -fweb -frename-registers -fno-ident -fno-align-labels -fno-align-loops  -fvisibility-inlines-hidden"
FEATURES="autoconfig distlocks prelink sandbox sfperms"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
USE="x86 3dnow 3dnowext X acpi alsa apache2 arts audiofile avi bash-completion berkdb bitmap-fonts bzip2 bzlib cdr cgi cli crypt ctype cups curl dba dbus dga divx4linux dri dvd dvdr dvdread emboss encode esd ethereal exif expat fam ffmpeg foomaticdb gd gdbm gif gimp glut gmp gphoto2 gpm gstreamer gtk gtk2 hal idn imagemagick imlib imlib2 insecure-drivers ipv6 isdnlog java jpeg junit kde kdeenablefinal lcms lib++ libg++ libwww linguas_de live logitech-mouse lzw-tiff mad mhash mikmod mmx mmxext mng modplug mp3 mpeg mpeg4 mplayer mysql ncurses nls nptl nsplugin ogg openal opengl openssh oss pam pcre pdf pdflib perl php pic pixusip3100 png pppd python qt quicktime readline real reflection samba sdl session speex spell spl sse ssl svg svga tcltk tcpd tetex tiff truetype truetype-fonts type1 type1-fonts udev unicode usb userlocales videos visualization vorbis win32codecs wma xine xml xml2 xmms xorg xv xvid xvmc zlib userland_GNU kernel_linux elibc_glibc"
Comment 1 Björn Ruberg 2006-06-03 11:47:28 UTC
Created attachment 88288 [details]
log of the compile
Comment 2 Jory A. Pratt 2006-06-03 12:14:04 UTC
please run MAKEOPTS="-j1" emerge -u mozilla-firefox I will dig into the parrallel build problems later.
Comment 3 Björn Ruberg 2006-06-03 12:35:49 UTC
I tried again and this time it worked, even without changing my MAKEOPTS. 
Comment 4 Jory A. Pratt 2006-06-03 12:47:47 UTC
Please leave bug open so I can fix parrallel build issue
Comment 5 Dave Jones 2006-06-05 02:02:47 UTC
Changing MAKEOPTS from j2 to j1 fixed the compilation problem for me.
Comment 6 Jory A. Pratt 2006-06-06 14:52:21 UTC
*** Bug 131727 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-06-13 03:33:05 UTC
*** Bug 136632 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-11-11 13:59:10 UTC
 11 Nov 2006; Bryan 
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-11-11 13:59:10 UTC
 11 Nov 2006; Bryan Østergaard <>
  mozilla-firefox-, mozilla-firefox-,
  Restrict parallel builds until upstream can solve the problem properly.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-11-11 13:59:51 UTC
*** Bug 152905 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-01-19 12:37:27 UTC
*** Bug 162782 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2007-01-23 20:29:24 UTC
*** Bug 163449 has been marked as a duplicate of this bug. ***
Comment 13 John R. Graham gentoo-dev 2007-08-03 11:35:03 UTC
Shouldn't the forced MAKEOPTS=-j1 be removed from the ebuilds before this bug is closed?
Comment 14 Kevin Lyles 2007-08-08 22:10:15 UTC
Making a copy of the ebuild into an overlay and removing the forced -j1 (resulting in my -j3 being used) compiles and runs without apparent issues on my system (and compiles significantly faster).  Do we still need the forced -j1?  I can post more information if needed.
Comment 15 Raúl Porcel (RETIRED) gentoo-dev 2007-08-09 11:03:06 UTC
Now you can put WANT_MP="true" in your /etc/make.conf and ff will build with your MAKEOPTS.

Thanks to Alex Maclean for the idea.