Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135073 - /bin/login missing after update system (sys-apps/shadow related)
Summary: /bin/login missing after update system (sys-apps/shadow related)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-05-31 13:51 UTC by Phillip Berndt
Modified: 2006-05-31 14:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Phillip Berndt 2006-05-31 13:51:51 UTC
As suggested in Bug #125014 I unmerged pam-login. The merging process worked. But after upgrading, /bin/login was missing.

I don't know if this is related to this line from the sys-apps/shadow ebuild:
>                 "login")
>                    # We do no longer install this one, as its from
>                    # pam-login now.
>                    ;;

Anyway, I think you'll agree that this is actually /critical/.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 14:01:32 UTC
Erm... You've been advised to unmerge pam-login *and* then update shadow, read Bug 126014, Comment #1 couple more times.

Sorry, PEBKAC is not a (Gentoo) bug.
Comment 2 Phillip Berndt 2006-05-31 14:10:08 UTC
Of course I DID remerge shadow -.-"
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 14:11:11 UTC
(In reply to comment #2)
> Of course I DID remerge shadow -.-"

re-emerge != update, please really read what you've been told. 

Comment 4 Phillip Berndt 2006-05-31 14:23:29 UTC
Ok, got it. I think I rsync'ed at the wrong time or something. After another rsync, the shadow package 4.0.15 was no longer masked and this one worked.. So never mind. *sneaking away* *blush*
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 14:29:13 UTC
So, I hope it works for you now and this one can be closed... :=)