Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 134944 - X11 leaks (a lot of) memory
Summary: X11 leaks (a lot of) memory
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-30 11:37 UTC by Rickard Närström
Modified: 2007-08-02 04:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
X11 Configuration file (xorg.conf,2.85 KB, text/plain)
2006-05-30 11:39 UTC, Rickard Närström
Details
X11 log file (Xorg.0.log,43.50 KB, text/plain)
2006-05-30 11:40 UTC, Rickard Närström
Details
pmap output (pmap.out,8.99 KB, text/plain)
2006-06-06 17:15 UTC, Rickard Närström
Details
pmap output for X (X.pmap,11.33 KB, text/plain)
2006-08-19 14:28 UTC, Rickard Närström
Details
xorg.conf - X11 configuration file (xorg.conf,3.31 KB, text/plain)
2006-08-19 14:29 UTC, Rickard Närström
Details
Xorg.0.log - X11 logfile (Xorg.0.log.old,73.08 KB, text/plain)
2006-08-19 14:31 UTC, Rickard Närström
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rickard Närström 2006-05-30 11:37:56 UTC
X11 sometimes leaks memory and the VM for X can grows to over 800,000 KiB(!) (it normally runs on about 100,000 KiB). This seams to be related to xv as it seem only to happen when I'm playing movies.

[I--] [ ~] x11-drivers/ati-drivers-8.25.18 (0)
[I--] [ ~] x11-base/xorg-x11-7.0-r1 (0)
[I--] [ ~] x11-libs/libXv-1.0.1 (0)


$ xvinfo
----
X-Video Extension version 2.2
screen #0
  Adaptor #0: "ATI Radeon Video Overlay"
    number of ports: 1
    port base: 67
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x23
      depth 24, visualID 0x24
      depth 24, visualID 0x25
      depth 24, visualID 0x26
      depth 24, visualID 0x27
      depth 24, visualID 0x28
      depth 24, visualID 0x29
      depth 24, visualID 0x2a
      depth 24, visualID 0x2b
      depth 24, visualID 0x2c
      depth 24, visualID 0x2d
      depth 24, visualID 0x2e
      depth 24, visualID 0x2f
      depth 24, visualID 0x30
      depth 24, visualID 0x31
      depth 24, visualID 0x32
    number of attributes: 12
      "XV_SET_DEFAULTS" (range 0 to 1)
              client settable attribute
      "XV_AUTOPAINT_COLORKEY" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
      "XV_COLORKEY" (range 0 to -1)
              client settable attribute
              client gettable attribute (current value is 30)
      "XV_DOUBLE_BUFFER" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
      "XV_BRIGHTNESS" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SATURATION" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_COLOR" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_HUE" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_RED_INTENSITY" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_GREEN_INTENSITY" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_BLUE_INTENSITY" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
----


$ emerge --info
----
Portage 2.1_rc3-r1 (default-linux/amd64/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-ck11 x86_64)
=================================================================
System uname: 2.6.16-ck11 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.0
ccache version 2.4 [enabled]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -fomit-frame-pointer -mfpmath=sse -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/init.d /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O3 -fomit-frame-pointer -mfpmath=sse -pipe -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://ftp.du.se/pub/os/gentoo http://mirror.uni-c.dk/pub/gentoo/ http://ds.thn.htu.se/linux/gentoo"
LANG="sv_SE.UTF-8"
LC_ALL="sv_SE.UTF-8"
LINGUAS="sv"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac acpi alsa anthy arts audiofile avi bitmap-fonts boundschecking browserplugin cdparanoia cdr cjk crypt css cups curl dbus dmi dri dvd dvdr dvdread eds emboss encode fam ffmpeg flac font-server foomaticdb ftp gd gif gpm hal iconv icq imagemagick imlib immqt insecure-drivers jabber java javascript jpeg kde lm_sensors mad matroska memlimit mikmod mod mono mp3 mp4 mpeg mpeg2 mpeg4 mplayer msdfs msn ncurses network nls no-old-linux no_wxgtk1 nptl nptlonly nsplugin offensive ogg oggvorbis opengl oscar pam pcre pdflib perl png posix python qt qt4 quicktime rar readline reiserfs samba sdl sockets spell ssl subtitles subversion sysfs syslog tcpd tetex theora threads tiff transcode truetype truetype-fonts type1 type1-fonts udev uim unicode usb userlocales utf8 vcd vim vnc vorbis x11vnc x264 xcomposite xfs xim xine xml xml2 xpm xrandr xscreensaver xv xvid zlib elibc_glibc input_devices_mouse input_devices_keyboard kernel_linux linguas_sv userland_GNU video_cards_ati video_cards_fglrx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
----
Comment 1 Rickard Närström 2006-05-30 11:39:07 UTC
Created attachment 87899 [details]
X11 Configuration file
Comment 2 Rickard Närström 2006-05-30 11:40:12 UTC
Created attachment 87900 [details]
X11 log file
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2006-05-30 12:56:52 UTC
It isn't necessarily a memory leak in X. It can be your movie player allocating lots of pixmaps etc. You can use the 'pmap' utility to get a better idea of how the memory is being used.
Comment 4 Rickard Närström 2006-06-06 17:15:12 UTC
Created attachment 88566 [details]
pmap output
Comment 5 Rickard Närström 2006-06-06 17:15:25 UTC
Upgrades and driver changes:
[I--] [ ~] x11-base/xorg-x11-7.1 (0)
[I--] [ ~] x11-drivers/xf86-video-ati-6.6.0 (0)
[I--] [ ~] x11-base/xorg-server-1.1.0 (0)

Will submit more information as available.
Comment 6 Rickard Närström 2006-06-06 17:40:28 UTC
Did just notice: after upgrading X takes 336,488 KiB just after start-up...
This seam to get worse....
Comment 7 Joshua Baergen (RETIRED) gentoo-dev 2006-06-11 09:28:41 UTC
What happens if you build portions of X (such as the drivers, xorg-server, libX11) with -O2 and without -mfpmath=sse?
Comment 8 Ian 2006-07-24 17:57:53 UTC
i get the same problem on amd64.  

symptoms:
when I first run startx, the memory footprint is very small.  after several days of use, it can get up to anywhere between 300 and 500 MB.  

possible causes:
memory accumulates faster when i am actually using the computer (typically firefox, thunderbird, mplayer, and wine/picasa) -- i notice a difference in how quickly my swap memory usage grows on weekends vs weekdays.  that makes sense.  however, when i close these programs, the memory that X is using does not decrease.

things that probably don't cause it:
i have had this problem with 2 different video cards: an ati radeon with the ATI binary driver, and a hercules dynamite TNT2 (nv driver).  i ran out of memory equally fast on both cards, so i would assume that the problem is not a driver.


is there a command i can run to make X free its unused memory?  when the memory usage passes a certain point, quitting X will cause the screen to lock and I can't get to the console.




$ emerge -pv xorg-x11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-x11-7.0-r1  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -magictouch -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="nv tdfx voodoo -apm -ark -chips -cirrus -cyrix -dummy -fbdev -fglrx -glint -i128 -i810 -mach64 -mga -neomagic -nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb -tga -trident -tseng -v4l -vesa -vga -via -vmware" 0 kB




$ emerge --info
Portage 2.1-r1 (default-linux/amd64/2005.1, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe -mmmx -msse -msse2 -m3dnow -ftracer -funit-at-a-time -funswitch-loops "
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O3 -pipe -mmmx -msse -msse2 -m3dnow -ftracer -funit-at-a-time -funswitch-loops "
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://mirrors.acm.cs.rpi.edu/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common "
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X aalib acpi alsa apache2 avi bash-completion berkdb bitmap-fonts cdr cli crypt cups curl curlwrappers dga directfb divx4linux dlloader dri dts dvd dvdr dvdread emacs emacs-w3 emboss encode esd exif flac foomaticdb fortran ftp gd gif glut gpm gstreamer gtk gtk2 imagemagick imlib ipv6 isdnlog jpeg jpeg2k lm_sensors lzw lzw-tiff mad matroska mp3 mpeg mysql mysqli mythtv ncurses nls ocaml offensive ogg opengl pam pcre pdflib pear-db perl php png postgres pppd python qt qt3 qt4 quicktime readline reflection samba sdl session shorten spell spl ssl svg tcpd theora tiff truetype truetype-fonts type1-fonts unicode usb voodoo1 voodoo2 vorbis xml xorg xpm xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux userland_GNU video_cards_nv video_cards_voodoo video_cards_tdfx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 9 Joshua Baergen (RETIRED) gentoo-dev 2006-07-25 18:48:43 UTC
Ian, you should give xorg-x11 7.1 a try.  Add x11-base/xorg-x11, x11-base/xorg-server, media-libs/mesa, x11-apps/mesa-progs, and whatever drivers you use to /etc/portage/package.keywords.
Comment 10 Ian 2006-07-25 20:38:05 UTC
i am compiling this now, i'll let you know how it turns out.  if this doesn't fix it, i will try recompiling with -O2 and whatever other compiler flags you can recommend.


FYI:

relevant portion of my package.keywords:
x11-base/xorg-x11 ~amd64
x11-base/xorg-server ~amd64
media-libs/mesa ~amd64
x11-apps/mesa-progs ~amd64
x11-drivers/xf86-input-evdev ~amd64
x11-drivers/xf86-input-mouse ~amd64
x11-drivers/xf86-video-nv ~amd64
x11-drivers/xf86-video-voodoo ~amd64
x11-drivers/xf86-input-keyboard ~amd64
x11-drivers/xf86-video-tdfx ~amd64


# emerge -pv x11-base/xorg-x11 x11-base/xorg-server media-libs/mesa x11-apps/mesa-progs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-apps/mesa-progs-6.5 [6.4.2] 3,794 kB 
[ebuild     U ] media-libs/mesa-6.5-r3 [6.4.2-r2] USE="-debug -doc% -hardened -motif -nptl%" VIDEO_CARDS="tdfx -i810 -mach64 -mga -none -r128 -radeon -s3virge -savage -sis -trident -via" 0 kB 
[ebuild     U ] x11-base/xorg-server-1.1.1 [1.0.2-r7] USE="dri ipv6 sdl% xorg% -debug -dmx% -kdrive% -minimal -nptl% -xprint" INPUT_DEVICES="evdev% keyboard% mouse% -acecad% -aiptek% -calcomp% -citron% -digitaledge% -dmc% -dynapro% -elo2300% -elographics% -fpit% -hyperpen% -jamstudio% -joystick% -magellan% -microtouch% -mutouch% -palmax% -penmount% -spaceorb% -summa% -synaptics% -tek4957% -ur98% -vmmouse% -void% -wacom%" VIDEO_CARDS="nv% tdfx% voodoo% -apm% -ark% -chips% -cirrus% -cyrix% -dummy% -epson% -fbdev% -glint% -i128% -i810% -mach64% -mga% -neomagic% -r128% -radeon% -rendition% -s3% -s3virge% -savage% -siliconmotion% -sis% -sisusb% -tga% -trident% -tseng% -v4l% -vesa% -vga% -via% -vmware%" 6,105 kB
[ebuild     U ] x11-base/xorg-x11-7.1 [7.0-r1] 0 kB
[ebuild     U ] x11-drivers/xf86-input-evdev-1.1.2-r1 [1.0.0.5] USE="-debug" 220 kB
[ebuild     U ] x11-drivers/xf86-input-mouse-1.1.1 [1.0.4] USE="-debug" 261 kB
[ebuild     U ] x11-drivers/xf86-video-nv-1.2.0 [1.0.2.0] USE="-debug" 279 kB
[ebuild     U ] x11-drivers/xf86-video-voodoo-1.1.0 [1.0.0.5] USE="-debug" 238 kB
[ebuild     U ] x11-drivers/xf86-input-keyboard-1.1.0 [1.0.1.3] USE="-debug" 226 kB
[ebuild     U ] x11-drivers/xf86-video-tdfx-1.2.1-r1 [1.1.1.3] USE="dri -debug" 263 kB
Comment 11 Rickard Närström 2006-07-28 04:49:37 UTC
I haven't seen this sence I updated to X11R7.1 and changed drivers to the sourcecode "radeon" driver.
Comment 12 Donnie Berkholz (RETIRED) gentoo-dev 2006-08-02 22:52:50 UTC
Considering it fixed then.
Comment 13 Ian 2006-08-04 23:27:20 UTC
still not working for me.

i'm using the nv driver in xorg-x11 7.1, both built from source.  i still get the following huge X usage after a few days of web+email.  please note the output from top, after i closed all graphical programs excepting xterms and xosview.  can we reopen this bug or should i open a new one for just the nv driver?

also, Rickard, are you using -O2 when compiling X?  i could try that next.


top - 21:24:16 up 17 days, 17:57,  4 users,  load average: 0.45, 0.65, 0.78
Tasks:  57 total,   1 running,  56 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.7% us,  0.3% sy,  0.0% ni, 99.0% id,  0.0% wa,  0.0% hi, 0.0% si
Mem:   1028160k total,   717056k used,   311104k free,    31224k buffers
Swap:   996020k total,   201828k used,   794192k free,   283912k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                    
16343 root      15   0  455m 331m 2492 S  0.7 33.0 101:19.28 X                          
16363 ikatz     16   0 69020 9268  648 S  0.0  0.9   1:55.63 wmifs                      
 1556 ikatz     15   0 32804 6160 2624 S  0.0  0.6   0:20.98 xterm                      
21730 ikatz     16   0 32908 5300 2040 S  0.0  0.5   0:31.35 xterm                      
21761 ikatz     16   0 30808 3136 1976 S  0.0  0.3   0:06.40 xterm                      
 1560 ikatz     16   0 11592 1924 1440 S  0.0  0.2   0:00.04 bash                       
21763 ikatz     17   0 11724 1728 1352 S  0.0  0.2   0:00.18 bash                       
16368 ikatz     16   0 13212 1688  832 S  0.0  0.2   0:01.04 wmimenu                    
21690 ikatz     15   0 16824 1668 1396 S  0.0  0.2   0:29.07 xosview                    
21732 ikatz     16   0 11596 1552 1324 S  0.0  0.2   0:00.02 bash                       
16359 ikatz     15   0 12852 1384  896 S  0.0  0.1   0:18.75 wmiiwm                     
16347 ikatz     16   0  7160 1296 1104 S  0.0  0.1   4:37.45 wmii                       
20224 ikatz     16   0 10520 1244  932 R  0.3  0.1   0:00.04 top                        
 7276 ikatz     17   0 11580 1204 1204 S  0.0  0.1   0:00.02 bash                       
16326 ikatz     21   0  7156 1112 1112 S  0.0  0.1   0:00.00 startx                     
14885 root      16   0 10932 1100  796 S  0.0  0.1   0:00.00 mount.smbfs                
15050 root      16   0 13060 1096  796 S  0.0  0.1   0:00.01 mount.smbfs                
 7124 root      16   0 11004 1044  736 S  0.0  0.1   0:00.00 mount.smbfs                
 7137 root      16   0 13060 1040  760 S  0.0  0.1   0:00.01 mount.smbfs                
16364 ikatz     16   0 12552  908  752 S  0.0  0.1   0:00.22 wmikeys                    
 7244 root      17   0 26960  724  724 S  0.0  0.1   0:00.01 login                      
 6420 root      16   0  4996  656  488 S  0.0  0.1   0:05.85 syslog-ng                  
16342 ikatz     17   0  7836  600  600 S  0.0  0.1   0:00.00 xinit                      
 7192 root      16   0 17208  596  484 S  0.0  0.1   0:09.03 sshd                       
 7228 root      16   0  8976  576  524 S  0.0  0.1   0:00.22 cron                       
 7131 root      16   0 10936  568  568 S  0.0  0.1   0:00.00 mount.smbfs                
 7146 root      16   0 10932  564  564 S  0.0  0.1   0:00.00 mount.smbfs                
 7245 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                     
 7246 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                     
 7247 root      16   0  3636  516  516 S  0.0  0.1   0:00.00 agetty                     
 7248 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                     
 7265 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                     
    1 root      16   0  2576  480  452 S  0.0  0.0   0:02.62 init                       
20236 ikatz     16   0  2560  428  356 S  0.0  0.0   0:00.00 sleep                      
 7128 root      16   0  9864  404  404 S  0.0  0.0   0:00.00 mount.smbfs                
 7140 root      16   0  9868  404  404 S  0.0  0.0   0:00.00 mount.smbfs                
 7143 root      16   0  9864  404  404 S  0.0  0.0   0:00.00 mount.smbfs                
 1060 root      13  -4  7020  316  316 S  0.0  0.0   0:00.27 udevd                      
 7069 root      16   0  5808  216  172 S  0.0  0.0   1:10.63 dhcpcd                     
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.01 ksoftirqd/0                
    3 root      10  -5     0    0    0 S  0.0  0.0   0:01.10 events/0                   
    4 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper                    
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kthread                    
    7 root      10  -5     0    0    0 S  0.0  0.0   0:00.56 kblockd/0                  
    8 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid                     
  186 root      15   0     0    0    0 S  0.0  0.0   0:08.47 pdflush                    
  188 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 aio/0                      
  773 root      10  -5     0    0    0 S  0.0  0.0   0:00.02 kseriod                    
  795 root      12  -5     0    0    0 S  0.0  0.0   0:00.00 kpsmoused                  
  187 root      15   0     0    0    0 S  0.0  0.0   0:11.25 kswapd0                    
  838 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 ata/0                      
  840 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_0                  
  841 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_1                  
  860 root      10  -5     0    0    0 S  0.0  0.0   0:01.19 reiserfs/0                 
 5421 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 khubd                      
 7126 root      15   0     0    0    0 S  0.0  0.0   0:27.09 smbiod                     
 2596 root      15   0     0    0    0 S  0.0  0.0   0:02.99 pdflush

Comment 14 Rickard Närström 2006-08-04 23:42:32 UTC
Yes, I'm useing -O2 for x11-base/xorg-server, x11-drivers/xf86-vidieo-ati and x11-libs/libX11 everything else is -O3
Comment 15 Ian 2006-08-05 11:57:02 UTC
ok i have rebuilt with -O2 and will post the results in a few days.
Comment 16 Ian 2006-08-11 19:33:58 UTC
still seeing huge memory usage, xorg-x11 7.1, compiled with -O2

top - 14:40:04 up 24 days, 11:13,  4 users,  load average: 0.40, 0.37, 0.15
Tasks:  57 total,   1 running,  56 sleeping,   0 stopped,   0 zombie
Cpu(s):  2.3% us,  0.0% sy,  0.0% ni, 97.7% id,  0.0% wa,  0.0% hi,  0.0% si
Mem:   1028160k total,   680188k used,   347972k free,    41804k buffers
Swap:   996020k total,   155468k used,   840552k free,   309092k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                            
22586 root      15   0  421m 246m 2040 S  0.0 24.5  90:45.36 X                                                                   
22609 ikatz     16   0 68376  11m  692 S  0.0  1.1   2:12.99 wmifs                                                               
23872 ikatz     16   0 32888 6252 2592 S  0.0  0.6   0:16.54 xterm                                                               
29469 ikatz     15   0 32804 6168 2632 S  0.0  0.6   0:00.92 xterm                                                               
28110 ikatz     16   0 30772 4060 2576 S  0.0  0.4   0:15.72 xterm                                                               
26104 ikatz     15   0 16828 2180 1768 S  0.0  0.2   3:20.91 xosview                                                             
22612 ikatz     16   0 13216 2012 1036 S  0.0  0.2   0:00.84 wmimenu                                                             
23917 ikatz     16   0 11596 1920 1436 S  0.0  0.2   0:00.01 bash                                                                
29471 ikatz     15   0 11596 1920 1436 S  0.0  0.2   0:00.02 bash                                                                
28112 ikatz     16   0 11592 1892 1412 S  0.0  0.2   0:00.01 bash                                                                
22603 ikatz     16   0 12608 1504 1096 S  0.0  0.1   0:06.22 wmiiwm                                                              
 7276 ikatz     16   0 11580 1492 1288 S  0.0  0.1   0:00.02 bash                                                                
22591 ikatz     16   0  7156 1416 1112 S  0.0  0.1   2:55.42 wmii                                                                
22568 ikatz     25   0  7160 1364 1120 S  0.0  0.1   0:00.00 startx                                                              
 5511 ikatz     15   0 10520 1252  936 R  2.3  0.1   0:00.02 top                                                                 
22610 ikatz     16   0 12420 1240  968 S  0.0  0.1   0:00.05 wmikeys                                                             
15050 root      16   0 13060 1096  796 S  0.0  0.1   0:00.01 mount.smbfs                                                         
14885 root      16   0 10932 1076  796 S  0.0  0.1   0:00.00 mount.smbfs                                                         
 7137 root      16   0 13060 1040  760 S  0.0  0.1   0:00.01 mount.smbfs                                                         
22585 ikatz     17   0  7836  804  660 S  0.0  0.1   0:00.00 xinit                                                               
 7124 root      16   0 11004  736  736 S  0.0  0.1   0:00.00 mount.smbfs                                                         
 7244 root      17   0 26960  724  724 S  0.0  0.1   0:00.01 login                                                               
 6420 root      15   0  4996  640  480 S  0.0  0.1   0:07.46 syslog-ng                                                           
 7228 root      16   0  8976  576  524 S  0.0  0.1   0:00.78 cron                                                                
 7131 root      16   0 10936  568  568 S  0.0  0.1   0:00.00 mount.smbfs                                                         
 7146 root      16   0 10932  564  564 S  0.0  0.1   0:00.00 mount.smbfs                                                         
 7245 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                                                              
 7246 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                                                              
 7247 root      16   0  3636  516  516 S  0.0  0.1   0:00.00 agetty                                                              
 7248 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                                                              
 7265 root      16   0  3632  516  516 S  0.0  0.1   0:00.00 agetty                                                              
    1 root      16   0  2576  480  452 S  0.0  0.0   0:06.73 init                                                                
 5525 ikatz     16   0  2560  428  356 S  0.0  0.0   0:00.00 sleep                                                               
 7128 root      16   0  9864  404  404 S  0.0  0.0   0:00.00 mount.smbfs                                                         
 7140 root      16   0  9868  404  404 S  0.0  0.0   0:00.00 mount.smbfs                                                         
 7143 root      16   0  9864  404  404 S  0.0  0.0   0:00.00 mount.smbfs                                                         
 7192 root      16   0 17208  404  404 S  0.0  0.0   0:11.80 sshd                                                                
 1060 root      14  -4  7020  344  316 S  0.0  0.0   0:00.28 udevd                                                               
 7069 root      15   0  5808  216  172 S  0.0  0.0   1:23.50 dhcpcd                                                              
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.01 ksoftirqd/0                                                         
    3 root      10  -5     0    0    0 S  0.0  0.0   0:01.36 events/0                                                            
    4 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper                                                             
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kthread                                                             
    7 root      10  -5     0    0    0 S  0.0  0.0   0:00.70 kblockd/0                                                           
    8 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid                                                              
  186 root      15   0     0    0    0 S  0.0  0.0   0:09.04 pdflush                                                             
  188 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 aio/0                                                               
  773 root      10  -5     0    0    0 S  0.0  0.0   0:00.02 kseriod                                                             
  795 root      12  -5     0    0    0 S  0.0  0.0   0:00.00 kpsmoused                                                           
  187 root      15   0     0    0    0 S  0.0  0.0   0:13.13 kswapd0                                                             
  838 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 ata/0                                                               
  840 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_0                                                           
  841 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_1                                                           
  860 root      10  -5     0    0    0 S  0.0  0.0   0:01.26 reiserfs/0                                                          
 5421 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 khubd                                                               
 7126 root      15   0     0    0    0 S  0.0  0.0   0:28.52 smbiod                                                              
32596 root      15   0     0    0    0 S  0.0  0.0   0:06.23 pdflush
Comment 17 Rickard Närström 2006-08-19 14:27:25 UTC
OK, I still have this problem, but only when I use:
net-client/mozilla-firefox-bin + x11-themes/gtk-engines-qt (I have tried other engines; w/o problems) + net-www/netscape-flash

My current setup:
[I--] [ -] www-client/mozilla-firefox-bin-1.5.0.5 (0)
[I--] [ ~] x11-themes/gtk-engines-qt-0.7 (2)
[I--] [  ] net-www/netscape-flash-7.0.63 (0)
[I--] [ ~] x11-base/xorg-x11-7.1 (0)
[I--] [ ~] x11-base/xorg-server-1.1.1 (0)
[I--] [ ~] x11-drivers/xf86-video-ati-6.6.1 (0)
[I--] [ ~] media-libs/mesa-6.5-r4 (0)

emerge --info
----
Portage 2.1.1_pre5-r2 (default-linux/amd64/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.17-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.4
Last Sync: Fri, 18 Aug 2006 18:50:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -fomit-frame-pointer -mfpmath=sse -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/init.d /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O3 -fomit-frame-pointer -mfpmath=sse -pipe -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache collision-protect distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.netnitco.net http://gentoo.kems.net ftp://gentoo.kems.net/mirrors/gentoo"
LANG="sv_SE.UTF-8"
LC_ALL="sv_SE.UTF-8"
LINGUAS="sv"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac acpi alsa anthy arts audiofile avi bitmap-fonts boundschecking browserplugin cdparanoia cdr cjk crypt css cups curl dbus dmi dri dvd dvdr dvdread eds elibc_glibc emboss encode fam ffmpeg flac font-server foomaticdb ft ftp gcc64 gd gif gpm hal history iconv icq imagemagick imlib immqt input_devices_evdev input_devices_keyboard input_devices_mouse insecure-drivers jabber java javascript jingle jpeg kde kernel_linux latex linguas_sv lm_sensors mad matroska memlimit mikmod mod mono mp3 mp4 mpeg mpeg2 mpeg4 mplayer msdfs msn ncurses network nls no-old-linux no_wxgtk1 nptl nptlonly nsplugin offensive ogg oggvorbis opengl oscar pam pcre pdflib perl physfs png posix python qt qt3 qt4 quicktime rar readline reiserfs samba sdl sockets speex spell ssl subtitles subversion svg sysfs syslog tcpd tetex theora threads tiff transcode truetype truetype-fonts type1 type1-fonts udev uim unicode usb userland_GNU userlocales utf8 vcd video_cards_radeon vim vnc vorbis x11vnc x264 xcomposite xfs xim xine xml xml2 xorg xpm xrandr xscreensaver xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
----
Comment 18 Rickard Närström 2006-08-19 14:28:10 UTC
Created attachment 94633 [details]
pmap output for X
Comment 19 Rickard Närström 2006-08-19 14:29:11 UTC
Created attachment 94634 [details]
xorg.conf - X11 configuration file
Comment 20 Rickard Närström 2006-08-19 14:31:20 UTC
Created attachment 94635 [details]
Xorg.0.log - X11 logfile
Comment 21 Anton Kuzmin 2006-10-07 15:10:42 UTC
Hey. I am also suffering from leaks. Please see my bug http://bugs.gentoo.org/show_bug.cgi?id=150348 and try to reproduce.
Comment 22 Donnie Berkholz (RETIRED) gentoo-dev 2007-08-02 04:50:48 UTC
I just added some patches to xorg-server 1.3 tonight. Try syncing and rebuilding.