Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 134505 - openldap-2.3.21-r1 can not be reemerged
Summary: openldap-2.3.21-r1 can not be reemerged
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-27 04:25 UTC by Andrei Slavoiu
Modified: 2006-06-18 06:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Slavoiu 2006-05-27 04:25:12 UTC
Reproduce steps:
1. Install / upgrade to openldap-2.3.21-r1
2. Try to reemerge openldap (in my case part of emerge -e system)

Expected result:
Being the same version there is no special upgrade procedure required.

Actual result:
emerge dies with:

 *
 * A (possible old) installation of OpenLDAP was detected,
 * installation will not proceed for now.
 *
 * As major version upgrades can corrupt your database,
 * you need to dump your database and re-create it afterwards.

This is because /var/lib/openldap-data/.version-tag stores the version including the revision, so the ebuild will only find "-r1" as the installed version.
Manualy changing .version-tag to say OLDPF='openldap-2.3.21' fixed it.
Comment 1 Markus Ullmann (RETIRED) gentoo-dev 2006-05-30 14:07:41 UTC
Fixed in 2.3.24, thanks for reporting :)
Comment 2 Andrei Slavoiu 2006-06-18 06:35:18 UTC
Closed