Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 134339 - x11-drivers/ati-drivers - kernel 2.6.16-gentoo-r8 breaks many things
Summary: x11-drivers/ati-drivers - kernel 2.6.16-gentoo-r8 breaks many things
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: X11 External Driver Maintainers
Depends on:
Reported: 2006-05-25 08:53 UTC by Arne-Kolja Bachstein
Modified: 2007-10-26 19:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Arne-Kolja Bachstein 2006-05-25 08:53:29 UTC
I recently upgraded my kernel from 2.6.15-r5 (2006.0 genkernel) to 2.6.16-gentoo-r8 and since then many problems with my ati adapter and the prorietary ati-drivers (fglrx) occur. The problem is, like it seems, well known, but never definitely said to be an issue of 2.6.16, what it seems to be here, since it worked very well before upgrading.

That is broken:

- Generally every shootdown of the X server ( 7.0 as well as Xgl [xgl-testing]) causes the system to either hardlock or dont switch back to a usable screen mode, so one has to work "blind".

- Same with resuming from S3 (suspend-to-ram), which worked perfectly before. I got only one time that the system wake up after suspending, but then the X session was destroyed and I got back to kdm without any running sessions. Starting a new one was possible, but as i said: only one time for now.

- Same with restarting a session manually. Screen is distorted or black.

- Xgl (I know, unsupported, but for completion I tell about it) won't start at all any more. I'm getting a blank X screen (blank = ugly cross cursor with black-white-pattern) and when shooting down the X server -> see above: hardlock and/or unusable screen.

What I tested/what I have done:

- Setting several options in xorg.conf like told many times in many threads.
- Upgrading/remerging/everything fglrx (ati-drivers-8.24.8 and ati-drivers-8.25.18)
- Using intel-agp instead of ati-agp kernel module and forcing it to load before fglrx.
- Enabling/disabling of special tty video modes.
- Kernel is built with the exact same options like the perfectly running 2.6.15-gentoo-r5 using make oldconfig and setting the new options all to their given default values.

Other issues I noticed:

Nothing, except for alsa needing to load/unload very long (but sound works just normal). The hibernation problem is clearly related to this fglrx incompatibility too, no second bug I think.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-26 10:58:44 UTC
Dead bug; if you have issues with something uptodate, file a new one, not mixing tons of issues into one bug preferably.