Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 134262 - mail-mta/courier - couriermlm can't deliver to addresses with equal sign
Summary: mail-mta/courier - couriermlm can't deliver to addresses with equal sign
Status: RESOLVED DUPLICATE of bug 135005
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: http://www.courier-mta.org/beta/patch...
Whiteboard:
Keywords:
: 134340 (view as bug list)
Depends on: 130957
Blocks:
  Show dependency tree
 
Reported: 2006-05-24 14:11 UTC by Daniel Faber
Modified: 2006-06-08 05:10 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Sam's patch (verp.patch.txt,628 bytes, patch)
2006-05-24 14:15 UTC, Daniel Faber
Details | Diff
courier-0.52.2-r1.ebuild (courier-0.52.2-r1.ebuild,11.23 KB, text/plain)
2006-05-25 09:20 UTC, Marcin Semeniuk
Details
verp.patch (verp.patch,628 bytes, patch)
2006-05-25 09:20 UTC, Marcin Semeniuk
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Faber 2006-05-24 14:11:19 UTC
couriermlm can't deliver mailing list messages to adresses
with an equal sign in the user part.  All versions up to courier-0.53.1 are affected.

Steps to reproduce:

* Create a test mailing list with
  couriermlm create <dir> ADDRESS=<address>
  and create the necessary .courier files

* Subscribe an address with an equal sign
  couriermlm sub <dir> foo=bar@somewhere.org
  and make sure you can receive mail with this address

* Subscribe another address without equal sign for tesing
  couriermlm sub <dir> foo-bar@somewhere.org

* Send a mail to this list

Result:

* foo-bar@somewhere.org receives the message, foo=bar@somewhere.org
  doesn't

* mailq lists the mail for foo=bar@somewhere.org

* top shows a courieresmtp process with 99% cpu usage (we also tried a
  local address with equal sign, in this case it's a courierlocal
  process)

* some minutes later the courierlocal process exits and the log shows
  err courierlocal: Error: stuck delivery, PID 1001, sending signal 15

I reported this bug to the courier-users mailing list and courier's author Sam Varshavchik wrote a patch that fixes it.
Comment 1 Daniel Faber 2006-05-24 14:15:58 UTC
Created attachment 87439 [details, diff]
Sam's patch

This patch from courier's author Sam Varshavchik fixes this bug.  Please add it to all courier versions in the portage tree.
Comment 2 Daniel Faber 2006-05-25 00:24:47 UTC
The bug is fixed in courier-0.53.2 (released yesterday).  From the release notes:

Security: Fix a bug in Courier that, under certain circumstances, may cause a number of processes to spin.  Backported patch for earlier versions of Courier: http://www.courier-mta.org/beta/patches/verp-fix/
Comment 3 Bernd Wurst 2006-05-25 01:05:48 UTC
I also ran into this problem, please supply this small patch...
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-05-25 09:16:14 UTC
*** Bug 134340 has been marked as a duplicate of this bug. ***
Comment 5 Marcin Semeniuk 2006-05-25 09:20:13 UTC
Created attachment 87494 [details]
courier-0.52.2-r1.ebuild
Comment 6 Marcin Semeniuk 2006-05-25 09:20:51 UTC
Created attachment 87495 [details, diff]
verp.patch
Comment 7 Sune Kloppenborg Jeppesen gentoo-dev 2006-06-08 05:10:22 UTC
Please continue this on bug #135005

*** This bug has been marked as a duplicate of 135005 ***