Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 13419 - Xemacs display weirdness
Summary: Xemacs display weirdness
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Lowest normal (vote)
Assignee: XEmacs team
Depends on:
Reported: 2003-01-07 09:45 UTC by Arcady Genkin (RETIRED)
Modified: 2006-05-29 18:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Xemacs window snapshot (snapshot1.png,19.52 KB, image/png)
2003-01-07 09:46 UTC, Arcady Genkin (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Arcady Genkin (RETIRED) gentoo-dev 2003-01-07 09:45:11 UTC
Xemacs, when launched in graphical mode (under X) displays light-grey holes (see
attached screenshot).  As you can see that I have changed the default colours
for the background and foreground.  Two things are of interest in the screenshot:

1. The huge grey stripe on the right.
2. Smaller grey strips along the left and bottom window borders.  I think
   that it's interesting that they are not continuous (i.e. they don't span
   the entire border).

I have been having this problem with Xemacs for a while, but it became a lot
less bearable lately: before I just used to have the small thin grey stripes
along the window borders, but now this monster one! ;^)  I wonder if this is
something that I'm doing wrong or a bug.

Currently I'm using 2.4.10-r2.  The output of emerge info is below:

Portage 2.0.46-r4 (default-1.0, gcc-2.95.3, glibc-2.2.5-r7)
System uname: 2.4.20 i686 Pentium III (Coppermine)
USE="x86 oss 3dnow apm crypt cups encode libg++ mikmod ncurses pdflib qtmt
quicktime xml2 xmms aalib berkdb cdr esd gdbm ggi gif gnome-libs gtk guile imlib
java libwww nls pam perl python qt readline scanner sdl slang ssl svga tcltk
tcpd tetex X dvd avi alsa mozilla oggvorbis png tiff truetype jpeg wmf xv xface
mpeg mmx opengl spell lucid mule -gpm kde -gnome -motif -arts -nas"
CFLAGS="-march=i686 -O -pipe"
CXXFLAGS="-march=i686 -O -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config
/usr/kde/2/share/config /usr/kde/3/share/config
CONFIG_PROTECT_MASK="/etc/init.d /etc/gconf /etc/env.d"
Comment 1 Arcady Genkin (RETIRED) gentoo-dev 2003-01-07 09:46:13 UTC
Created attachment 7046 [details]
Xemacs window snapshot
Comment 2 Rendhalver (RETIRED) gentoo-dev 2003-01-16 12:43:41 UTC
can you please test out the new xemacs-21.4.12 ebuild and see if it fixes your
Comment 3 Arcady Genkin (RETIRED) gentoo-dev 2003-02-04 17:01:00 UTC
I tried xemacs 21.4.12, and it still exhibits the same problem.
I have no idea whether this bug is specific to Gentoo.  Perhaps I should open a bug with the Xemacs project?
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-07-21 15:37:05 UTC
Mass re-assign of really stale bugs; xemacs herd, please verify the status and
close them if these issues no longer exist. 
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-05-29 18:24:32 UTC
Try w/ 21.4.17, reopen if it still doesn't work. 
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-05-29 18:24:50 UTC
Blah, wrong resolution.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-05-29 18:25:34 UTC
TEST-REQUEST that is...