Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133976 - emerge dev-python/matplotlib fails over ssh
Summary: emerge dev-python/matplotlib fails over ssh
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2006-05-21 13:05 UTC by iztok pizorn
Modified: 2006-11-30 14:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description iztok pizorn 2006-05-21 13:05:07 UTC
if i try to emerge dev-python/matplotlib
dev-python/matplotlib-0.80-r1  +doc +gtk
over ssh it fails giving this error:
>>> Unpacking matplotlib-0.80.tar.gz to /var/tmp/portage/matplotlib-0.80-r1/work>>> Source unpacked.
X11 connection rejected because of wrong authentication.
The application '' lost its connection to the display localhost:10.0;
most likely the X server was shut down or you killed/destroyed
the application.

!!! ERROR: dev-python/matplotlib-0.80-r1 failed.
!!! Function distutils_src_compile, Line 35, Exitcode 1

X11 forwarding is enabled, i can easily run any X application over ssh.

i should be able to emerge matplotlib over ssh. i emerged nearly the whole system over ssh with no complaints.

additional information:
had ~ # echo $DISPLAY
Comment 1 Marien Zwart (RETIRED) gentoo-dev 2006-11-28 16:59:54 UTC
I suspect this is fixed by the disabling of automagic dependencies in newer versions of matplotlib. Can you try with a ~arch matplotlib and report back if it works?
Comment 2 iztok pizorn 2006-11-30 14:13:04 UTC
(In reply to comment #1)
just tried reemerging matplotlib-0.80-r1. Now it worked! Tried with and w/o ForwardX11. 
tried matplotlib-0.87.7, it worked as well. 
i cannot reproduce the bug from 6 monts anymore. i consider the bug closed.