Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133892 - media-video/xine-ui segfaults (SIG33) by just running it
Summary: media-video/xine-ui segfaults (SIG33) by just running it
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-20 11:33 UTC by matt
Modified: 2006-05-20 12:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matt 2006-05-20 11:33:32 UTC
after i installed xine-ui i went to run the program only to find that it pops up on screen breifly and closes if i run it in terminal i get a short bit of info

xine
This is xine (X11 gui) - a free video player v0.99.4.
(c) 2000-2004 The xine Team.
xiTK received SIGSEGV signal, RIP.

thats all so i did a bt in gdb:

(gdb) r
Starting program: /usr/bin/xine
[Thread debugging using libthread_db enabled]
[New Thread 47132326879808 (LWP 12310)]
This is xine (X11 gui) - a free video player v0.99.4.
(c) 2000-2004 The xine Team.
[New Thread 1082132832 (LWP 12311)]
[New Thread 1090525536 (LWP 12312)]
[New Thread 1098918240 (LWP 12313)]
[New Thread 1107310944 (LWP 12314)]
[New Thread 1115703648 (LWP 12315)]
[New Thread 1124096352 (LWP 12316)]
[New Thread 1132489056 (LWP 12317)]
[New Thread 1140881760 (LWP 12318)]
[New Thread 1149274464 (LWP 12319)]
[New Thread 1157667168 (LWP 12320)]
[New Thread 1166059872 (LWP 12321)]
[New Thread 1174452576 (LWP 12322)]
[New Thread 1182845280 (LWP 12323)]

Program received signal SIG33, Real-time event 33.
[Switching to Thread 1182845280 (LWP 12323)]
0x00002addd8ed8a9a in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
(gdb) bt
#0  0x00002addd8ed8a9a in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
#1  0x00002addd89d6d60 in fifo_buffer_get () from /usr/lib/libxine.so.1
#2  0x00002addd89dc467 in video_decoder_loop () from /usr/lib/libxine.so.1
#3  0x00002addd8ed614a in start_thread () from /lib/tls/libpthread.so.0
#4  0x00002addd982c943 in clone () from /lib/tls/libc.so.6
#5  0x0000000000000000 in ?? ()
 i have tried this with all availble releases of xine-lib but all give the same results
here my system info:

emerge --info
Portage 2.0.54-r2 (default-linux/amd64/2006.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r7 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks nostrip sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac alsa arts audiofile avi berkdb bitmap-fonts browserplugin bzip2 cdparanoia cdr cli crypt cups dbus debug dga directfb doc dri dvd dvdr dvdread eds emboss encode exif expat fam ffmpeg foomaticdb fortran gd gif glut gpm gstreamer gtk gtk2 hal idn imagemagick imlib ipv6 isdnlog java jpeg kde lcms lzw lzw-tiff mad matroska mozilla mp3 mpeg ncurses nls nptl nsplugin ogg oggvorbis opengl oss pam pcre pdflib perl png pppd python qt quicktime readline reflection samba sdl session spell spl ssl tcpd tiff truetype truetype-fonts type1-fonts udev usb vorbis xine xml2 xmms xorg xpm xv xvid zlib video_cards_radeon userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTAGE_RSYNC_OPTS, PORTDIR_OVERLAY
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-05-20 11:52:47 UTC
Please read my backtraces guide http://www.gentoo.org/proj/en/qa/backtraces.xml : SIG33 _IS NOT A SEGFAULT_!
it's a real time signal used by pthreads.
Comment 2 Jose daLuz 2006-05-20 12:18:05 UTC
(In reply to comment #1)
> : SIG33 _IS NOT A SEGFAULT_!
> it's a real time signal used by pthreads.
> 
True, but in the reporter's comment:

xine
This is xine (X11 gui) - a free video player v0.99.4.
(c) 2000-2004 The xine Team.
xiTK received SIGSEGV signal, RIP.

So a better backtrace is needed but this is still segfaulting, right?
Comment 3 matt 2006-05-20 12:35:04 UTC
so i should rebuild world with a -ggdb in my cflags? 
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-05-20 12:44:07 UTC
I got a bug with something like 5 different reports of 5 different problems all aggregated in a bug#, as people got there looking for "SIG33" output of gdb.

I don't want bugs reported with this error, if it's still segfaulting for good, follow the guide, get the backtrace data and submit a *new* bug.

The guide should have all the data you need.