Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133566 - Blender-cvs and thoughts on plugins
Summary: Blender-cvs and thoughts on plugins
Status: RESOLVED DUPLICATE of bug 276338
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: blender.org
Whiteboard:
Keywords: EBUILD
: 38004 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-16 22:25 UTC by wayne tedder
Modified: 2009-08-15 15:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
blender live cvs ebuild (blender-cvs-040106.ebuild,3.65 KB, text/plain)
2006-05-17 07:07 UTC, wayne tedder
Details
.png icon for blender (blender-cvs.png,2.07 KB, image/png)
2006-05-17 07:28 UTC, wayne tedder
Details
blender-cvs.ebuild (with more flags: openal verse nls game-engine mp3 ffmpeg) (blender-cvs-060517.ebuild,4.06 KB, text/plain)
2006-09-04 21:48 UTC, Emanuel Greisen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wayne tedder 2006-05-16 22:25:03 UTC
I've created a cvs build here at http://deathguppie.com/extra/blender-cvs-040106.tar.gz

I know the CFLAGS is a bit of a kludge but I just haven't had time to fix it.  

One thing I want to bring up is the use of the plugins dir in the upcoming 2.4.2 release.  

I was going to create a patch for the source to get it to point to whatever dir but then was thinking about all of the user downloaded plugins that people have available for blender.  I was wondering why Gimp has a plugins dir in the users home directory and not blender?

Wouldn't it be easier to just fix the problem by creating a .blender/ dir in the users home directory so that they can simply add scripts to it like with gimp instead of having to do it as root?

I am going to correct my post install to create a symlink to the users home dir, but I think that a better solution would be to just cp the entire scripts dir to the users home directory, under .blender/  

I know this has been discussed before, but no one has offered a solution.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-17 00:14:34 UTC
Don't refer to external tarballs with ebuilds, please... Attach a plaintext ebuild here and reopen then.

http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=3#doc_chap2
Comment 2 wayne tedder 2006-05-17 07:07:56 UTC
Created attachment 86922 [details]
blender live cvs ebuild

This ebuild is intended as a technology preview for those who would like to try out upcoming features in blender.  This is a live CVS ebuild, and MUST be placed in /usr/local/media-gfx/blender-cvs/  OR IT WILL OVERWRITE YOUR EXISTING BLENDER INSTALL!!!
Comment 3 wayne tedder 2006-05-17 07:27:59 UTC
Attached ebuild.  However I cannot figure out how to attach the desktop launcher icon, so people will still need the tar ball, or to move the desktop icon from the old blender files dir and change the executable to point to blender-cvs.
Comment 4 wayne tedder 2006-05-17 07:28:55 UTC
Created attachment 86928 [details]
.png icon for blender
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 03:07:09 UTC
*** Bug 38004 has been marked as a duplicate of this bug. ***
Comment 6 Emanuel Greisen 2006-09-04 21:48:00 UTC
Created attachment 96031 [details]
blender-cvs.ebuild (with more flags: openal verse nls game-engine mp3 ffmpeg)

Here is an updated version of the CVS-ebuild file, it is more like the current ebuild file (blender-2.42a) because it lets you specify a lot of things to include/exclude (via use-flags). It also has the dependencies of blender-2.42a.
Comment 7 Toffanin 2009-08-15 15:11:56 UTC

*** This bug has been marked as a duplicate of bug 276338 ***