Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133250 - virtual/glut is blocking freeglut that isnt emerged
Summary: virtual/glut is blocking freeglut that isnt emerged
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL: ht
: 133251 (view as bug list)
Depends on:
Reported: 2006-05-13 18:05 UTC by Oskar Rittsel
Modified: 2006-05-14 03:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Oskar Rittsel 2006-05-13 18:05:44 UTC
When i try to emerge virtual/glut i get:

[blocks B    ] virtual/glut (is blocking media-libs/freeglut-2.2.0)

I dont even have freeglut installed and it's not going to be installed either.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-13 20:37:40 UTC
*** Bug 133251 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-05-13 20:52:04 UTC
Why are you trying to emerge virtual/glut? Virtuals are not meant to be emerged directly. Also, there's no block in the virtual at all. Please explain what are you trying to do and post the exact command you did run to get the above.

Comment 3 Boney McCracker 2006-05-13 20:55:12 UTC
Recommend change "hardware" to "all" -- I have same on ~ppc.  Details:

"emerge xorg.x11 -p" results in:

[blocks B ] virtual/glut (is blocking media-libs/freeglut-2.4.0)
. (near end of list)
[ebuild N ] virtual/glut-1.0 
Comment 4 Boney McCracker 2006-05-13 20:59:45 UTC
Regarding comment #2 (above).  Nobody is "trying to emerge virtual/glut".

To clarify this from the perspective of what I experienced (can't speak for the original reporter of the bug), the problem arose for me when trying to emerge the xorg.x11-7.0-r1 package.  So, it is apparently indicated as a dependency of the xorg.x11 package and in conflict with another xorg.x11 dependency (freeglut).
Comment 5 Oskar Rittsel 2006-05-14 03:15:09 UTC
I'm sorry, it was 4-5 in the morning when i wrote that. 

It's for x86 (someone wrote about ppc or something).
Yes it is when i tried to emerge xorg-x11-7.0.

I thought it maybe was for unmasking some packages so i tried without the unmasking and just with virtual/glut, that's why i wrote it as i did.

I did an emerge --sync today and it is fixed now.