Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133094 - ps2ascii from app-text/ghostscript-esp renders ps file as garbage
Summary: ps2ascii from app-text/ghostscript-esp renders ps file as garbage
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Printing Team
Depends on:
Reported: 2006-05-12 02:04 UTC by Toralf Förster
Modified: 2006-08-26 00:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

postscript file (output of lsmod) (,105.77 KB, text/plain)
2006-05-12 02:05 UTC, Toralf Förster

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2006-05-12 02:04:59 UTC
After an update of ghostscript today I tried to view a PS-file with gs, the file was printed from kate.
The command gs showed nothing - that's why I tried to have a look of the content of that file. I can see the content with "pg" or "more", but not with "less", it shows only crap.

Portage 2.0.54-r2 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r7 i686)
System uname: 2.6.16-gentoo-r7 i686 Intel(R) Pentium(R) M processor 1700MHz
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -pipe"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
LINGUAS="de en"
USE="x86 X aac acpi alsa apache2 arts audiofile avi berkdb bitmap-fonts bzip2 cdr cli crypt css cups curl dri dvd emboss encode exif expat fam ffmpeg font-server foomaticdb fortran gd gdbm gif glut gpm gstreamer gtk gtk2 idn imagemagick imlib ipv6 isdnlog jai java javascript jimi joystick jpeg junit kde lcms libg++ libwww live logrotate mad mbox mhash mikmod mmx mmxext mng motif mp3 mpeg mysql ncurses nls nptl nsplugin ogg opengl oss pam pcre pdflib perl php png pppd python qt quicktime readline real reflection rtc samba sdl session slp snmp spell spl sse sse2 ssl subversion tcltk tcpd tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vorbis win32codecs xine xml xml2 xorg xv xvid zlib video_cards_ati input_devices_keyboard input_devices_mouse linguas_de linguas_en userland_GNU kernel_linux elibc_glibc"
Comment 1 Toralf Förster gentoo-dev 2006-05-12 02:05:47 UTC
Created attachment 86636 [details]
postscript file (output of lsmod)
Comment 2 SpanKY gentoo-dev 2006-05-12 21:05:16 UTC
not less's fault

less uses `ps2ascii` which comes from app-text/ghostscript-esp which is what is making it look like poo

run `ps2ascii | less` and you'll get the same result
Comment 3 Toralf Förster gentoo-dev 2006-05-12 23:44:02 UTC
Ah, I updated ghostscript but never thought that this could be the reason:

Fri May 12 10:04:22 2006  >>> unmerge success: app-text/ghostscript-esp-7.07.1-r8
Fri May 12 10:04:22 2006  ::: completed emerge (1 of 1) app-text/ghostscript-esp-8.15.1_p20060430 to /
Comment 4 Toralf Förster gentoo-dev 2006-05-13 00:09:31 UTC
The old version 7.x was definitly better:

n22_uml ~ # ps2ascii /mnt/n22/home/tfoerste/ 

\Gamma Error: /rangecheck in --get--
Operand stack:
   --nostringval--   450   395   8059   1   --nostringval--   1
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   2   3   %oparray_pop   2   3   %oparray_pop   2   3   %oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   2   3   %oparray_pop   --nostringval--   5   3   %oparray_pop   (\000\002\000\003\000\004\000\005\000\003\000\002\000\004\000\004\000\006)   --nostringval--   %string_continue   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1105/1417(ro)(G)--   --dict:0/20(G)--   --dict:178/200(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 61625
ESP Ghostscript 7.07.1: Unrecoverable error, exit code 1

whereas the version 8.15.2 produces crappy output.
Comment 5 Toralf Förster gentoo-dev 2006-05-13 10:37:19 UTC
current less (sys-apps/less-394) shows now nothing instead crap :-)
Comment 6 Stefan Schweizer (RETIRED) gentoo-dev 2006-05-13 10:40:31 UTC
I think that is an upstream bug, please report it upstream to the espgs devs.

If you think I can do anything for this in the gentoo ebuild now, please reopen and tell me :)
Comment 7 Toralf Förster gentoo-dev 2006-08-26 00:48:18 UTC
From upstream:

[STR Closed w/o Resolution]

Sorry, we aren't going to fix this "problem".

Version: 8.15.1
Fix Version: Will Not Fix