Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 131930 - gcc-3.4 won't compile on stage3-i686
Summary: gcc-3.4 won't compile on stage3-i686
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2006-05-01 10:03 UTC by nowinter
Modified: 2006-05-03 17:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description nowinter 2006-05-01 10:03:26 UTC
Gentoo Base System version 1.6.14
Portage 2.0.54 (default-linux/x86/2006.0, gcc-3.4.4, glibc-2.3.6-r3, 2.6.11-co-0.6.3 i686)
System uname: 2.6.11-co-0.6.3 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
LINGUAS="en ru il he"
USE="x86 16bit X adsl alsa apache2 apm asf audiofile avi bash-completion berkdb bitmap-fonts bzip2 cdparanoia clamav clamd cli cpudetection crypt cups dhcp dio dri dvd dvdr dvdread eds emacs emboss encode esd expat foomaticdb fortran ftp gdbm gif gnome gpm gstreamer gtk gtk2 hal imlib ipv6 isdnlog jpeg justify kde kdeenablefinal kdexdeltas libg++ libwww live lj lm_sensors mad mikmod mime motif mp3 mp4 mp4live mpd-mad mpeg mplayer musepack musicbrainz ncurses network nfs nls nptl offensive ogg opengl openssh oss pam pcre pdf pdflib perl png pop pppd prelude python qt quicktime readline real reflection reiser4 reiserfs remote samba screen sdl search sendfile sensord session sharedmem shout skins smtp sndfile snmp spell spl ssl stats stlport stream subtitles syslog tcpd toolbar transcode truetype truetype-fonts type1 type1-fonts udev unicode userlocales vcd video_cards_s3 video_cards_savage visualization vorbis win32codecs winbind wma wxwindows xml xmms xorg xv xvid xvmc zlib input_devices_keyboard input_devices_mouse linguas_en linguas_ru linguas_il linguas_he userland_GNU kernel_linux elibc_glibc"

Dare to post this because of uncountable attempts to fix it / find a fix description. stage3-i686 comes in 2006.0 with gcc-3.4.5 that repeatedly fails in emerge -e system. Here the error:

make[2]: Entering directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make[2]: *** No rule to make target `', needed by `cstamp-h'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make: *** [profiledbootstrap] Error 2

!!! ERROR: sys-devel/gcc-3.4.5-r1 failed.
!!! Function gcc_do_make, Line 1340, Exitcode 2

The same with gcc-3.4.4-r1 in both sences (I fetched a binary to try).
Comment 1 SpanKY gentoo-dev 2006-05-02 17:58:03 UTC
you're using colinux huh ?

run `MAKEOPTS=-j1 emerge gcc >& log`
Comment 2 nowinter 2006-05-03 10:32:00 UTC
(In reply to comment #1)
> you're using colinux huh ?

Yip, emerge --info is from coLinux. It does absolutely NO MATTER )). I tried compiling gcc from standalone 2.6.15 kernel, too. 
> run `MAKEOPTS=-j1 emerge gcc >& log`
Hm. No change. What do you want me to do? Post the log? It's too long. Be sure it ends the same.

 Calculating dependencies    ...done!
>>> emerge (1 of 1) sys-devel/gcc-3.4.5-r1 to /
>>> md5 files   ;-) gcc-3.3.6.ebuild
>>> md5 files   ;-) gcc-4.1.0.ebuild
>>> md5 files   ;-) gcc-3.4.4-r1.ebuild
>>> md5 files   ;-) gcc-3.2.3-r4.ebuild
>>> md5 files   ;-) gcc-3.4.5-r1.ebuild
>>> md5 files   ;-) gcc-
>>> md5 files   ;-) gcc-4.2.0_alpha20060429.ebuild
>>> md5 files   ;-) gcc-4.0.3.ebuild
>>> md5 files   ;-) gcc-3.4.5.ebuild
>>> md5 files   ;-) gcc-3.3.2-r7.ebuild
>>> md5 files   ;-) gcc-3.3.5-r1.ebuild
>>> md5 files   ;-) gcc-4.0.2-r3.ebuild
>>> md5 files   ;-) gcc-3.2.2.ebuild
>>> md5 files   ;-) gcc-3.1.1-r2.ebuild
>>> md5 files   ;-) gcc-2.95.3-r9.ebuild
>>> md5 files   ;-) gcc-3.4.6-r1.ebuild
>>> md5 files   ;-) gcc-3.3.6-r1.ebuild
>>> md5 files   ;-) gcc-3.4.1-r3.ebuild
>>> md5 files   ;-) gcc-3.4.6.ebuild
>>> md5 files   ;-) files/digest-gcc-3.4.5-r1
>>> md5 files   ;-) files/digest-gcc-3.4.5
>>> md5 files   ;-) files/digest-gcc-3.3.6
>>> md5 files   ;-) files/digest-gcc-2.95.3-r9
>>> md5 files   ;-) files/digest-gcc-3.4.6-r1
>>> md5 files   ;-) files/digest-gcc-3.4.6
>>> md5 files   ;-) files/mkinfodir
>>> md5 files   ;-) files/digest-gcc-3.3.6-r1
>>> md5 files   ;-) files/digest-gcc-4.0.3
>>> md5 files   ;-) files/digest-gcc-4.0.2-r3
>>> md5 files   ;-) files/digest-gcc-3.2.2
>>> md5 files   ;-) files/digest-gcc-3.3.2-r7
>>> md5 files   ;-) files/pro-police-docs.patch
>>> md5 files   ;-) files/digest-gcc-
>>> md5 files   ;-) files/digest-gcc-3.4.1-r3
>>> md5 files   ;-) files/digest-gcc-3.4.4-r1
>>> md5 files   ;-) files/gcc-spec-env.patch
>>> md5 files   ;-) files/digest-gcc-4.2.0_alpha20060429
>>> md5 files   ;-) files/digest-gcc-4.1.0
>>> md5 files   ;-) files/
>>> md5 files   ;-) files/gcc-configure-LANG.patch
>>> md5 files   ;-) files/digest-gcc-3.3.5-r1
>>> md5 files   ;-) files/
>>> md5 files   ;-) files/digest-gcc-3.2.3-r4
>>> md5 files   ;-) files/digest-gcc-3.1.1-r2
>>> md5 files   ;-) files/3.2.2/gcc322-ggc_page-speedup.patch
>>> md5 files   ;-) files/3.2.2/gcc32-pr7768.patch
>>> md5 files   ;-) files/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch
>>> md5 files   ;-) files/3.2.2/gcc32-pr8213.patch
>>> md5 files   ;-) files/3.2.2/gcc-3.2.2-cross-compile.patch
>>> md5 files   ;-) files/3.3.1/gcc331-pp-fixup.patch
>>> md5 files   ;-) files/awk/scanforssp.awk
>>> md5 files   ;-) files/awk/fixlafiles.awk
>>> md5 files   ;-) files/awk/fixlafiles.awk-no_gcc_la
>>> md5 files   ;-) files/3.4.1/gcc-3.4.1-mips-n32only.patch
>>> md5 files   ;-) files/3.4.1/gcc-3.4.1-r2-gentoo-branding.patch
>>> md5 files   ;-) files/3.4.1/gcc-3.4.1-mips-n64only.patch
>>> md5 files   ;-) files/3.4.1/gcc-3.4.1-glibc-is-native.patch
>>> md5 files   ;-) files/3.2.3/gcc323-hppa-default_assemble_visibility.patch
>>> md5 files   ;-) files/3.2.3/gcc-323-propolice-version.patch
>>> md5 files   ;-) files/3.2.3/gcc32-mklibgcc-serialize-crtfiles.patch
>>> md5 files   ;-) files/3.2.3/gcc32-c++-classfn-member-template.patch
>>> md5 files   ;-) files/3.2.3/gcc323-gentoo-branding.patch
>>> md5 files   ;-) files/3.2.3/gcc-3.2.3-move-propolice-into-glibc.patch
>>> md5 files   ;-) files/3.2.3/gcc-3.2.3-mergel-fix.patch
>>> md5 files   ;-) files/4.0.2/gcc-4.0.2-softfloat.patch
>>> md5 files   ;-) files/4.0.2/gcc-4.0.2-cross-compile.patch
>>> md5 files   ;-) files/3.3.2/gcc332-gentoo-branding.patch
>>> md5 files   ;-) files/3.3.2/gcc332-altivec-fix.patch
>>> md5 files   ;-) files/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch
>>> md5 files   ;-) files/3.3.5/gcc-3.3.5-no-COPYING-cross-compile.patch
>>> md5 files   ;-) files/3.4.2/gcc34-fix-sse2_pinsrw.patch
>>> md5 files   ;-) files/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v3-ip32r10k.patch
>>> md5 files   ;-) files/3.4.2/gcc34-m32-no-sse2.patch
>>> md5 files   ;-) files/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v2.patch
>>> md5 files   ;-) files/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v3.patch
>>> md5 files   ;-) files/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
>>> md5 files   ;-) files/3.4.2/810-arm-bigendian-uclibc.patch
>>> md5 fi>>> Unpacking source...
>>> Unpacking gcc-3.4.5.tar.bz2 to /var/tmp/portage/gcc-3.4.5-r1/work
>>> Unpacking gcc-3.4.5-patches-1.4.tar.bz2 to /var/tmp/portage/gcc-3.4.5-r1/work
>>> Unpacking gcc-3.4.5-uclibc-patches-1.1.tar.bz2 to /var/tmp/portage/gcc-3.4.5-r1/work
>>> Unpacking gcc-3.4.5-ssp-1.0.tar.bz2 to /var/tmp/portage/gcc-3.4.5-r1/work
>>> Unpacking gcc-3.4.5-piepatches-v8.7.9.tar.bz2 to /var/tmp/portage/gcc-3.4.5-r1/work
 [32;01m*[0m Done with patching
 [32;01m*[0m Replacing obsolete head/tail with POSIX compliant ones
 [32;01m*[0m  - fixed contrib/test_summary
 [32;01m*[0m  - fixed libstdc++-v3/scripts/
 [32;01m*[0m  - fixed boehm-gc/configure
 [32;01m*[0m  - fixed fastjar/configure
 [32;01m*[0m  - fixed gcc/configure
 [32;01m*[0m  - fixed intl/configure
 [32;01m*[0m  - fixed libf2c/configure
 [32;01m*[0m  - fixed libffi/configure
 [32;01m*[0m  - fixed libiberty/configure
 [32;01m*[0m  - fixed libjava/configure
 [32;01m*[0m  - fixed libobjc/configure
 [32;01m*[0m  - fixed libstdc++-v3/configure
 [32;01m*[0m  - fixed zlib/configure
 [32;01m*[0m  - fixed
 [32;01m*[0m  - fixed
 [32;01m*[0m  - fixed
 [32;01m*[0m  - fixed
 [32;01m*[0m  - fixed boehm-gc/
 [32;01m*[0m  - fixed fastjar/
 [32;01m*[0m  - fixed gcc/
 [32;01m*[0m  - fixed intl/
 [32;01m*[0m  - fixed libf2c/
 [32;01m*[0m  - fixed libffi/
 [32;01m*[0m  - fixed libiberty/
 [32;01m*[0m  - fixed libjava/
 [32;01m*[0m  - fixed libobjc/
 [32;01m*[0m  - fixed libstdc++-v3/
 [32;01m*[0m  - fixed zlib/
 [32;01m*[0m patching gcc version: 3.4.5 (Gentoo 3.4.5-r1, ssp-3.4.5-1.0, pie-8.7.9)
 [32;01m*[0m Running elibtoolize in: gcc-3.4.5
 [32;01m*[0m   Applying portage-1.5.10.patch ...
 [32;01m*[0m   Applying relink-1.4.0a-GCC3.0-2.patch ...
 [32;01m*[0m   Applying sed-1.5.6.patch ...
 [32;01m*[0m   Applying tmp-1.3.5.patch ...
 [32;01m*[0m Using GNU config files from /usr/share/libtool
 [32;01m*[0m   Updating boehm-gc/config.sub
 [32;01m*[0m Applying gcc-3.4.4-cross-compile.patch ...
[A[73G  [34;01m[ [32;01mok[34;01m ][0m
>>> Source unpacked.
 [32;01m*[0m CFLAGS="-O2 -march=i686 -pipe"
 [32;01m*[0m CXXFLAGS="-O2 -march=i686 -pipe"
 [32;01m*[0m Configuring gcc ...
 [32;01m*[0m running gcc-compiler-configure
 [32;01m*[0m configuring for GCC_LANG: c,c++,f77

 [32;01m*[0m PREFIX:          /usr
 [32;01m*[0m BINPATH:         /usr/i686-pc-linux-gnu/gcc-bin/3.4.5
 [32;01m*[0m LIBPATH:         /usr/lib/gcc/i686-pc-linux-gnu/3.4.5
 [32;01m*[0m DATAPATH:        /usr/share/gcc-data/i686-pc-linux-gnu/3.4.5
 [32;01m*[0m STDCXX_INCDIR:   /usr/lib/gcc/i686-pc-linux-gnu/3.4.5/include/g++-v3

 [32;01m*[0m Configuring GCC with:  		

creating cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... /bin/install -c
*** This configuration is not supported in the following subdirectories:
     target-libffi target-boehm-gc target-zlib target-libjava zlib fastjar target-libobjc
    (Any other directories should still work fine.)
checking for <omitted> 
updating cache ./config.cache
creating ./config.status
creating Makefile
 [32;01m*[0m Compiling gcc ...
<additional checks omitted>
updating cache ./config.cache
configure: creating ./config.status
config.status: creating Makefile
config.status: creating testsuite/Makefile
config.status: creating config.h
config.status: executing default commands
make[1]: Entering directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/libiberty'

<many make outputs omitted>
checking linker --as-needed support... yes
Using ggc-page for garbage collection.
checking whether to enable maintainer-specific portions of Makefiles... no
checking for the document directory.
Links are now set up to build a native compiler for i686-pc-linux-gnu.
updating cache ./config.cache
configure: creating ./config.status
config.status: creating Makefile
config.status: creating fixinc/Makefile
config.status: creating gccbug
config.status: creating mklibgcc
config.status: creating mkheaders
config.status: creating auto-host.h
config.status: executing default commands
Bootstrapping training compiler
make[1]: Entering directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make CC="gcc" libdir=/usr/lib LANGUAGES="c " \
	CFLAGS="-O" MAKEINFO="makeinfo --split-size=5000000" \
	OBJS-onestep="alias.o bb-reorder.o bitmap.o builtins.o caller-save.o calls.o cfg.o cfganal.o cfgbuild.o cfgcleanup.o cfglayout.o cfgloop.o cfgloopanal.o cfgloopmanip.o loop-init.o loop-unswitch.o loop-unroll.o cfgrtl.o combine.o conflict.o convert.o coverage.o cse.o cselib.o dbxout.o debug.o df.o diagnostic.o dojump.o doloop.o dominance.o dwarf2asm.o dwarf2out.o emit-rtl.o except.o explow.o expmed.o expr.o final.o flow.o fold-const.o function.o gcse.o genrtl.o ggc-common.o global.o graph.o gtype-desc.o haifa-sched.o hooks.o ifcvt.o insn-attrtab.o insn-emit.o insn-modes.o insn-extract.o insn-opinit.o insn-output.o insn-peep.o insn-recog.o integrate.o intl.o jump.o  langhooks.o lcm.o lists.o local-alloc.o loop.o optabs.o options.o opts.o params.o postreload.o predict.o print-rtl.o print-tree.o value-prof.o profile.o ra.o ra-build.o ra-colorize.o ra-debug.o ra-rewrite.o real.o recog.o reg-stack.o regclass.o regmove.o regrename.o reload.o reload1.o reorg.o resource.o rtl.o rtlanal.o rtl-error.o sbitmap.o sched-deps.o sched-ebb.o sched-rgn.o sched-vis.o sdbout.o sibcall.o simplify-rtx.o sreal.o stmt.o stor-layout.o stringpool.o targhooks.o timevar.o toplev.o tracer.o tree.o tree-dump.o unroll.o varasm.o varray.o version.o vmsdbgout.o xcoffout.o alloc-pool.o et-forest.o cfghooks.o bt-load.o pretty-print.o ggc-page.o web.o protector.o i386.o  host-linux.o hashtable.o tree-inline.o tree-optimize.o cgraph.o cgraphunit.o"
make[2]: Entering directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make[2]: *** No rule to make target `', needed by `cstamp-h'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.5-r1/work/build/gcc'
make: *** [profiledbootstrap] Error 2

!!! ERROR: sys-devel/gcc-3.4.5-r1 failed.
!!! Function gcc_do_make, Line 1340, Exitcode 2
!!! emake failed with profiledbootstrap
!!! If you need support, post the topmost build error, NOT this status message.

>>> md5 files   ;-) files/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
>>> md5 files   ;-) ......etc.

Comment 3 SpanKY gentoo-dev 2006-05-03 16:25:28 UTC
well colinux isnt officially supported ... and since i dont have any machines to test with, you're pretty much on your own ... your best chance is to hit up and see if someone can help you out
Comment 4 nowinter 2006-05-03 17:04:03 UTC
I understand now (quite unclearly, though) where the main reason for the bug is: stage3 contains gcc-3.4.4. Latest portage, however, contains gcc-3.4.5 as stable. Somewhere in the middle emerge -e system mixes between them, and fails on another package, perhaps udev. And then no gcc profile switching/configuring helps, and re-emerging will fail on gcc.  One should first of all upgrade gcc separately, with the guide accordance, and then emerge the system. At least I can say it worked that way when I re-installed. A bit sad, though. Installation guide says nothing about such stuff..

Credits to SirYes, a GOOD Tux's lil helper.

PS coLINUX has absolutely n_o_t_h_i_n_g to do with this.