Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 131811 - xf86-video-nv-1.1.2: patch failure: x11-driver-patches-1.tar.bz2
Summary: xf86-video-nv-1.1.2: patch failure: x11-driver-patches-1.tar.bz2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 132044 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-30 09:12 UTC by FieldySnuts
Modified: 2007-12-25 21:29 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
x11-driver-patches-1.tar.bz2-17907.out (x11-driver-patches-1.tar.bz2-17907.out,5.86 KB, text/plain)
2006-04-30 09:13 UTC, FieldySnuts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FieldySnuts 2006-04-30 09:12:26 UTC
xf86-video-nv-1.1.2 fails to merge because the application of x11-driver-patches-1.tar.bz2 fails.

>>> Unpacking x11-driver-patches-1.tar.bz2 to /var/tmp/portage/xf86-video-nv-1.1.2/work
 * Applying x11-driver-patches-1.tar.bz2 ...

 * Failed Patch: x11-driver-patches-1.tar.bz2 !
 *  ( /var/tmp/portage/xf86-video-nv-1.1.2/temp/17907.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/xf86-video-nv-1.1.2/temp/x11-driver-patches-1.tar.bz2-17907.out

I will attach that file.

Portage 2.1_pre10 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r3, 2.6.17-rc1-mm3 i686)
=================================================================
System uname: 2.6.17-rc1-mm3 i686 AMD Athlon(TM) XP 1800+
Gentoo Base System version 1.12.0_pre18
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.3
dev-util/ccache:     2.4-r1
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache collision-protect distcc distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 3dnow X alsa am apache2 apm avi berkdb bitmap-fonts bzip2 cdr chroot cli crypt dri dv dvd dvdr eds emboss encode foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal imlib isdnlog jpeg kde kdeenablefinal libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls nptl ogg oggvorbis opengl oss pam pcre pdflib perl png pppd pwdb python qt quicktime readline reflection sdl session spell spl sse ssl tiff truetype truetype-fonts type1-fonts udev vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 FieldySnuts 2006-04-30 09:13:55 UTC
Created attachment 85835 [details]
x11-driver-patches-1.tar.bz2-17907.out
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2006-04-30 18:38:27 UTC
Same problem.
it appears the problem lies in that the source file is of type tar.bz2 and it is only being unbzip2'ed , but not untared.

PIPE_COMMAND:  bzip2 -dc /var/tmp/portage/xf86-video-nv-1.1.2/distdir/x11-driver-patches-1.tar.bz2 > /var/tmp/portage/xf86-video-nv-1.1.2/temp/14924.patch

results in a corrupt patch file, whereas if i had simply 

tar -jxOf /var/tmp/portage/xf86-video-nv-1.1.2/distdir/x11-driver-patches-1.tar.bz2 > /var/tmp/portage/xf86-video-nv-1.1.2/temp/14924.patch

it renders a proper patch file.

Comment 3 Kent Fredric (IRC: kent\n) gentoo-dev 2006-04-30 19:02:25 UTC
Also, upon further interrogation, it appears the provided patch file wont work against the source anyway. 

@@ -9207,7 +9207,7 @@
 # LinuxDebian, not other Linuxes, so we leave it unchanged here
 if test x$DRIVER_MAN_SUFFIX = x    ; then
     case $host_os in
-#      linux*)         DRIVER_MAN_SUFFIX=4x ;;
+       linux*)         DRIVER_MAN_SUFFIX=4x ;;



that wont work, not only is the placement aparently wrong,  but all the lines refering to DRIVER_MAN_SUFFIX in that context, are all 

        linux* | k*bsd*-gnu) 

Instead.

If it were more clear how to fix this sort of change in the ebuild I'd have an attempt at it myself. But as its not, I'll do the best I can to explain it to save future devs a little work.
Comment 4 Kent Fredric (IRC: kent\n) gentoo-dev 2006-04-30 19:12:27 UTC
I believe this is the replacement that may be needed.

--- configure   2006-04-26 10:02:43.000000000 +1200
+++ configure   2006-05-01 14:10:12.000000000 +1200
@@ -20332,7 +20332,7 @@
 # LinuxDebian, not other Linuxes, so we leave it unchanged here
 if test x$DRIVER_MAN_SUFFIX = x    ; then
     case $host_os in
-#      linux* | k*bsd*-gnu)            DRIVER_MAN_SUFFIX=4x ;;
+       linux* | k*bsd*-gnu)            DRIVER_MAN_SUFFIX=4x ;;
        solaris*)       DRIVER_MAN_SUFFIX=7  ;;
        *)              DRIVER_MAN_SUFFIX=4  ;;
     esac
Comment 5 hiyuh 2006-04-30 21:52:52 UTC
I have same problem, too.

IIRC, x11-driver-patches-1.tar.bz2 has only driver-man-suffix.patch, ATM.
But, this patch tar ball is used by many packages in x11-drivers category.
And then, I'm on PPC, though.
So, majorities which are x86 users use nvidia proprietary diriver didn't
see this issue, I think...
Comment 6 Peter Humphrey 2006-05-01 08:56:21 UTC
I have the same problem with patch failing.

# emerge --info
>>> cfg-update-1.8.0-r3 : No new packages have been emerged, checksum index OK...
Portage 2.1_pre10-r2 (default-linux/amd64/2005.1, gcc-3.4.6, glibc-2.4-r1, 2.6.16-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r3 x86_64 AMD Opteron(tm) Processor 246
Gentoo Base System version 1.12.0_pre18
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.3
dev-util/ccache:     2.4-r1
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="no"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=opteron -mtune=opteron -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/X11/xdm/Xservers /etc/eselect/compiler /etc/fonts /etc/gconf /etc/init.d /etc/rc.d /etc/revdep-rebuild /etc/rsync /etc/terminfo /etc/wget /etc/env.d"
CXXFLAGS="-O2 -march=opteron -mtune=opteron -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks metadata-transfer sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk                 http://distfiles.gentoo.org                 http://ftp.easynet.nl/mirror/gentoo                 http://ftp.uni-erlangen.de/pub/mirrors/gentoo                 ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo                 http://trumpetti.atm.tut.fi/gentoo/                 http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_GB.ISO-8859-15"
LC_ALL="en_GB.ISO-8859-15"
LINGUAS="en_GB"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages/packages.xfce"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/vmware"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi bash-completion berkdb bitmap-fonts bzip2 cdr cli crypt cups directfb dri dvd eds emboss encode fbcon foomaticdb fortran gif gimp gimpprint gphoto2 gpm gstreamer gtk gtk2 imlib ipv6 isdnlog ithreads javascript jpeg libcaca lzw lzw-tiff mp3 mpeg ncurses nls nptl nptlonly nsplugin nvidia ogg opengl
pam pcre pdflib perl png ppds pppd python qt quicktime readline reflection scanner sdl session spell spl ssl tcpd tiff truetype truetype-fonts type1-fonts unicode usb userlocales vorbis wmf xorg xpm xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en_GB userland_GNU video_cards_nv video_cards_nvidia"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS
Comment 7 Donnie Berkholz (RETIRED) gentoo-dev 2006-05-01 09:47:11 UTC
Please stop adding "same problem" comments. They are not constructive or helpful in any way at this point, because we already know it's a valid bug.
Comment 8 Peter Humphrey 2006-05-02 00:44:54 UTC
Sorry. I wouldn't AOL as a rule, but I didn't get any sense of activity here. My mistake.
Comment 9 Joshua Baergen (RETIRED) gentoo-dev 2006-05-02 07:44:56 UTC
My apologies for taking so long on such a simple fix.  For those of you who don't want to wait 30-60mins for rsync, the fix is:

--- xf86-video-nv-1.1.2.ebuild  29 Apr 2006 16:51:18 -0000      1.1
+++ xf86-video-nv-1.1.2.ebuild  2 May 2006 14:40:05 -0000
@@ -4,6 +4,7 @@

 # Must be before x-modular eclass is inherited
 #SNAPSHOT="yes"
+XDPVER=2

 inherit x-modular
Comment 10 Donnie Berkholz (RETIRED) gentoo-dev 2006-05-02 12:52:02 UTC
*** Bug 132044 has been marked as a duplicate of this bug. ***