Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 131268 - sleuthkit and dstat collision in /usr/bin/dstat
Summary: sleuthkit and dstat collision in /usr/bin/dstat
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Forensics Herd [disbanded]
URL:
Whiteboard:
Keywords:
: 197259 248317 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-25 14:19 UTC by simon
Modified: 2012-01-02 14:05 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simon 2006-04-25 14:19:54 UTC
app-forensics/sleuthkit-1.73-r2 and 
sys-apps/dstat-0.6.0-r1 
both current stable x86

equery b /usr/bin/dstat
[ Searching for file(s) /usr/bin/dstat in *... ]
app-forensics/sleuthkit-1.73-r2 (/usr/bin/dstat)
sys-apps/dstat-0.6.0-r1 (/usr/bin/dstat)

so only the last installed one can be used.

emerge --info
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r3 i686)
=================================================================
System uname: 2.6.16-gentoo-r3 i686 AMD Athlon(tm) XP 2200+
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/mnt/nfs_portage/distfiles"
FEATURES="autoconfig ccache distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="en_US"
LC_ALL="en_US"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/mnt/nfs_portage/packages"
PORTAGE_TMPDIR="/var/tmp/portage"
PORTDIR="/mnt/nfs_portage"
PORTDIR_OVERLAY="/usr/local/overlays/local"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X aac aalib acl alsa apm arts audiofile avi berkdb bitmap-fonts bonobo bzip2 cddb cdparanoia cdr cjk cli crypt cups curl directfb dri dts dvd dvdr eds emboss encode ethereal exif expat f77 fam ffmpeg flac foomaticdb fortran gd gdbm ggi gif glut gmp gpm gtk2 gtkhtml guile idn imagemagick imlib ipv6 isdnlog java jpeg kde lcms libg++ libwww mad matroska md5sum mhash mikmod mmx mmxext mng motif mp3 mpeg musepack mysql nas ncurses nls nptl nptlonly odbc ogg oggvorbis openal opengl oss pam pcre pdflib perl plotutils png postgres pppd python qt quicktime readline recode reflection ruby samba sdl session slang spell spl sqlite sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev usb vorbis win32codecs xine xml xml2 xmms xorg xv xvid zlib linguas_en userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LDFLAGS
Comment 1 Wolfram Schlich (RETIRED) gentoo-dev 2006-11-21 13:19:31 UTC
Any suggestion?
Rename dstat from sleuthkit to dstat-tsk (official abbr. for "The Sleuth Kit")
and add an 'ewarn' to the sleuthkit ebuild?
Comment 2 Raphael Marichez (Falco) (RETIRED) gentoo-dev 2007-04-11 22:24:11 UTC
FWI, i added a !rdep agains dstat in sleuthkit-2.08. sys-apps/dstat only provides /usr/bin/dstat, so i guess you can drop sys-apps/dstat if you have app-forensics/sleuthkit.
Comment 3 simon 2007-05-15 19:56:44 UTC
that would be an option if the dstat bin would provide  the same functionality.
But dstat in sleuthkit is to "Display details of a data structure" while
dstat in dstat is a "versatile tool for generating system resource statistics".
Comment 4 Raphael Marichez (Falco) (RETIRED) gentoo-dev 2007-08-29 14:50:00 UTC
(In reply to comment #1)
> Any suggestion?
> Rename dstat from sleuthkit to dstat-tsk (official abbr. for "The Sleuth Kit")
> and add an 'ewarn' to the sleuthkit ebuild?
> 

sleuthkit-0.9 bumped.

i have followed your advice if has_version sys-apps/dstat. I guess we can not do better.
Comment 5 Wolfram Schlich (RETIRED) gentoo-dev 2008-04-18 21:14:04 UTC
Still has a collision on /usr/share/man/man1/dstat.1.bz2 :)
Comment 6 RB 2008-09-15 18:52:29 UTC
I would like to humbly suggest closing in favor of #203773.  I've submitted an ebuild for sleuthkit-2.52 that blocks sys-apps/dstat.  Version 3.x of sleuthkit (currently in beta) is reportedly naming the d* functions to blk*, following discussion on the upstream list.
Comment 7 RB 2009-03-03 19:22:34 UTC
Still needs to be closed, sleuthkit-3.0.0 is in-tree and working well.
Comment 8 Samuli Suominen gentoo-dev 2009-12-31 23:50:07 UTC
*** Bug 248317 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen gentoo-dev 2009-12-31 23:51:18 UTC
*** Bug 197259 has been marked as a duplicate of this bug. ***
Comment 10 Samuli Suominen gentoo-dev 2009-12-31 23:53:23 UTC
I've duped 2 bugs here, it's dstat executable or dstat.1 manpage colliding. 

Someone should take latest of these apps stable, and remove the older colliding ones...
Comment 11 Justin Lecher gentoo-dev 2012-01-02 14:05:27 UTC
seems to be fixed