Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 131156 - dev-libs/libcdio-0.73 doesn't compile with cddb use flag
Summary: dev-libs/libcdio-0.73 doesn't compile with cddb use flag
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 139334 139847 141778 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-24 15:11 UTC by Devang M
Modified: 2006-10-30 15:29 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Results from emerge of libcdio (automake-29741.out,2.97 KB, text/plain)
2006-10-30 15:29 UTC, Fred Krogh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Devang M 2006-04-24 15:11:31 UTC
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../lib/driver -I../include/        -O3 -pipe -Wall -Wchar-subscripts -Wmissing-prototypes -Wmissing-declarations -Wunused -Wpointer-arith -Wwrite-strings -Wnested-externs -Wno-sign-compare -c cddb.c
cddb.c: In function `init_cddb':
cddb.c:120: error: dereferencing pointer to incomplete type
cddb.c:124: error: dereferencing pointer to incomplete type
make[3]: *** [cddb.o] Error 1
make[3]: Leaving directory `/tmp/portage/libcdio-0.73/work/libcdio-0.73/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/portage/libcdio-0.73/work/libcdio-0.73/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/portage/libcdio-0.73/work/libcdio-0.73'
make: *** [all] Error 2

!!! ERROR: dev-libs/libcdio-0.73 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_compile
  ebuild.sh, line 929:   Called src_compile
  libcdio-0.73.ebuild, line 39:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

emerge --info
Portage 2.1_pre7-r5 (default-linux/amd64/2005.0, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.15-gentoo-r4 x86_64 AMD Opteron(tm) Processor 242
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/env.d"
CXXFLAGS="-O3 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="autoconfig ccache distlocks fixpackages metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.ccccom.com http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 3dnowex X a52 aac acl akode alsa amr apache2 arts asf audiofile avahi avi berkdb bitmap-fonts bookmarks browserplugin bzip2 cairo cddb cdparanoia cdr chroot cli crypt cups curl daap dga divx4linux dri dts dv dvb dvd dvdr dvdread eds emacs emboss encode esd exif expat exscalibar faad fame ffmpeg fftw finger firefox flac foomaticdb fortran fpx ftp gd gdbm gif gimpprint glitz gmp gnutls gopher gphoto2 gpm graphviz gs gstreamer gtk gtk2 gtkhtml howl-compat i8x0 ieee1394 imagemagick imlib innodb isdnlog jack java javamail javascript jpeg jpeg2k kde kdeenablefinal latex lcms ldap libcaca live lm_sensors lua lzo lzw lzw-tiff mad math matroska md5sum mdnsresponder-compat mhash mikmod mjpeg mmap mng modplug mono mozcalendar mozdevelop mozilla moznocompose moznoirc moznomail mozxmlterm mp3 mp4 mpeg mplayer mysql nas ncurses network nls nntp nptl nptlonly nsplugin ogg oggvorbis openexr opengl pam pcre pda pdf pdflib perl php physfs plotutils png povray pppd python qt quicktime rar readline reflection rtc ruby samba scanner sdk sdl session shout skins sockets speex spell spl ssl subtitles svg swat tcltk tcpd theora tiff truetype truetype-fonts type1-fonts usb v4l v4l2 vcd visualization vorbis vorbis-psy wifi wmf wxwindows x264 xemacs xine xinetd xml xml2 xmms xpm xv xvid xvmc zeroconf zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_ati video_cards_fglrx video_cards_vga video_cards_vesa video_cards_radeon"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-04-24 18:08:40 UTC
Which libcddb version are you using?
Comment 2 Devang M 2006-04-24 18:21:36 UTC
libcddb-1.2.1

I did emerge -uD --newuse vlc after changing some vlc use flags, and it didn't touch libcddb. 
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-04-24 18:32:23 UTC
You're mixing stable and unstable packages it seems. Unfortunately portage doesn't handle up-down cycles well, so I can't really change the deps ranges. Please use the ~arch version of libcdio.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-07-05 09:49:33 UTC
*** Bug 139334 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-07-10 02:16:00 UTC
*** Bug 139847 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-07-27 15:48:43 UTC
*** Bug 141778 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Slack 2006-08-10 20:23:07 UTC
I had the same cddb error when emerging libcdio. I unemerged libcddb (emerge -C libcddb), and then emerged libcdio, which emerged libcddb. Now it works for me.
Comment 8 Fred Krogh 2006-10-30 15:29:16 UTC
Created attachment 100831 [details]
Results from emerge of libcdio

I am running an ~amd64 system and nothing suggested here works.  Contents of /var/tmp/portage/dev-libs/libcdio-0.77/temp/automake-2974.out are in the attachment.