Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 130730 - Impossible to add the deskbar applet (2.14.1.1)
Summary: Impossible to add the deskbar applet (2.14.1.1)
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 132671 134342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-21 07:10 UTC by Zak Peirce
Modified: 2007-06-14 22:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zak Peirce 2006-04-21 07:10:39 UTC
slacktop ~ # emerge --info
Portage 2.1_pre7-r4 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.4-r1, 2.6.15-archck4-r1 i686)
=================================================================
System uname: 2.6.15-archck4-r1 i686 Intel(R) Pentium(R) M processor 1.73GHz
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac acpi alsa apm avi berkdb bitmap-fonts cdparanoia cdr cdrw crypt cups directfb dri dts dvd dvdr dvdread emboss encode firefox flac foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal imlib ipv6 isdnlog ithreads java jpeg kde libg++ libwww lm_sensors mad mikmod motif mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl oss pam pdflib perl png pppd python qt quicktime readline real sdl sensord spell ssl tcpd truetype truetype-fonts type1-fonts ucs2 unicode vorbis wxGTK xml2 xmms xv xvid zlib elibc_glibc input_devices_keyboard input_devices_synaptics input_devices_kbd input_devices_evdev input_devices_mouse kernel_linux userland_GNU video_cards_fglrx"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS

slacktop ~ #

I always receive this in gnome when starting the deskbar applet.

The panel encountered a problem while loading "OAFIID:Deskbar_Applet".

I have wxGTK built with unicode so that bittornado works. 

slacktop ~ # emerge -pv deskbar-applet

These are the packages that would be merged, in order:
... done!
[ebuild   R   ] gnome-extra/deskbar-applet-2.14.0.1  USE="-debug -eds" 477 kB

Total size of downloads: 477 kB
slacktop ~ # emerge -pv wxGTK python

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/wxGTK-2.6.2-r1  USE="X gnome opengl sdl -debug -doc -joystick -odbc unicode" 0 kB
[ebuild   R   ] dev-lang/python-2.4.2-r1  USE="X berkdb gdbm ipv6 ncurses readline ssl ucs2 -bootstrap -build -doc -nocxx -tcltk" 0 kB

Total size of downloads: 0 kB
slacktop ~ #

Is this a known issue?  Do you folks have the same issue?
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2006-04-23 14:23:49 UTC
Deskbar-applet doesn't use wxgtk in any way that I can see, so what makes you think the use flags for wxgtk matter?
Comment 2 Christian Faulhammer (RETIRED) gentoo-dev 2006-05-08 22:15:15 UTC
I have the same problems without Unicode...and I don't think it has to do with wxGTK.  Maybe Zak should do the following call on his command line

# /usr/lib/deskbar-applet/deskbar-applet -w
-----------------
Traceback (most recent call last):
  File "/usr/lib/deskbar-applet/deskbar-applet", line 13, in ?
    import gtk, gnomeapplet
ImportError: No module named gnomeapplet
-----------------
Comment 3 Christian Faulhammer (RETIRED) gentoo-dev 2006-05-08 22:58:55 UTC
This bug may be related to #132671
Comment 4 John N. Laliberte (RETIRED) gentoo-dev 2006-05-11 14:33:45 UTC
*** Bug 132671 has been marked as a duplicate of this bug. ***
Comment 5 John N. Laliberte (RETIRED) gentoo-dev 2006-05-11 14:35:13 UTC
there seems to be a problem with your pygtk installation.

until you can do something like:

$ python
>>> from gtk import VBox

deskbar-applet will not work for you.
Comment 6 Zak Peirce 2006-05-12 07:08:33 UTC
zak@slacktop ~ $ python
Python 2.4.3 (#1, May  8 2006, 18:36:16)
[GCC 3.4.5 (Gentoo 3.4.5-r1, ssp-3.4.5-1.0, pie-8.7.9)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from gtk import VBox
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 33, in ?    import gobject as _gobject
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gobject.so: undefined symbol: PyUnicodeUCS2_FromUnicode
>>>

zak@slacktop ~ $ /usr/lib/deskbar-applet/deskbar-applet -w
Traceback (most recent call last):
  File "/usr/lib/deskbar-applet/deskbar-applet", line 10, in ?
    import gobject
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gobject.so: undefined symbol: PyUnicodeUCS2_FromUnicode
zak@slacktop ~ $
Comment 7 John N. Laliberte (RETIRED) gentoo-dev 2006-05-12 08:07:57 UTC
@Zak: after upgrading python to 2.4 did you run python-updater? have you tried recompiling pygtk?
Comment 8 Zak Peirce 2006-05-12 20:22:26 UTC
Yes I have recompiled pygtk many times and have also ran the python updater many times as well.

The problem that I have is that if I build python -UCS2 Superkaramba complains taht it needs Python built with UCS2.  If i build Python with UCS2 then the deskbar applet works but btdownloadgui.py complains that wxGTK is not installed.  SO my choice is to either beable to use btdownloadgui.py or to use deskbar applet.  quitefrankly it kinda sucks...
Comment 9 Simon Ruggier 2006-05-13 18:18:38 UTC
(In reply to comment #8)
> SO my choice is to either beable to use btdownloadgui.py or to use
> deskbar applet.

Sorta off topic, but there are many BT clients and only one deskbar, so IMO, the deskbar wins.
Comment 10 Zak Peirce 2006-05-14 20:26:46 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > SO my choice is to either beable to use btdownloadgui.py or to use
> > deskbar applet.
> 
> Sorta off topic, but there are many BT clients and only one deskbar, so IMO,
> the deskbar wins.
> 

I partially agree with that statement but i like bittornado plus dont you thinkt aht they shuold work together?
Comment 11 Steev Klimaszewski (RETIRED) gentoo-dev 2006-05-14 20:36:36 UTC
I would say that this is an upstream issue, based on all the various comments, perhaps you should take the issue up with them?
Comment 12 John N. Laliberte (RETIRED) gentoo-dev 2006-05-26 06:20:44 UTC
*** Bug 134342 has been marked as a duplicate of this bug. ***
Comment 13 Zak Peirce 2006-05-29 18:03:55 UTC
Finally i got this error fixed on my ~amd64 and ~x86 machines.  I had python 2.3.5 and 2.4.3-r1 installed.  I removed the older python then rebuilt 2.4.3-r1 -ucs2 and rebuilt wxGTK-2.6.2-r1 and wxpython-2.6.1.0 +unicode then rebuilt pygtk and all the python problems went away.

On my ~amd64 machine i was running x11-libs/wxGTK-2.6.3.2 and had to downgrade to 2.6.2-r1 seems like there is a problem with the newer stuff.
Comment 14 Christian Faulhammer (RETIRED) gentoo-dev 2006-06-16 13:31:37 UTC
In comment #2 I described my error message...it resulted from a missing gnomeapplet module (Python) which was available when compiling deskbar-applet, but got lost afterwards, I found out today.  Reemerging gnome-python-desktop (gnomeapplet.la belongs to this package) made the trick for me.
Comment 15 troll 2006-07-29 23:28:15 UTC
I had a similar problem and solved it adding following lines in
/usr/lib/deskbar-applet/deskbar-applet:

import pygtk
pygtk.require("2.0")

These had to be put before the "import gtk, ..."
statement!
I don't know if i made something wrong with the pygtk/gtk installation
because i reemerged them several times in different order to no prevail.
Under my ubuntu box i dont need those lines, despite there'r almost the same
libraries installed. Maybe someone could help us here!? It seems a genuine
error, because my gdesklets don't work either!


package        : version                :USE flags
---------------------------------------------------------------------------------------------------------------------
gnome          : 2.14.2                 : USE="cdr dvdr hal -accessibility"
deskbar-applet : 2.14.2                 : USE="eds -debug"
python         : 2.3.5-r2 and 2.4.3-r1  : USE="berkdb doc gdbm ipv6 ncurses\
                                              readline ssl tk ucs2\
                                              -bootstrap -build -nocxx"                                              
pygtk:         : 0.6.11-r1 and 2.8.6    : USE="doc opengl"
pygtkglext     : not installed
Comment 16 Rémi Cardona gentoo-dev 2007-06-14 22:03:32 UTC
Newer versions of the deskbar applet are now available. If this is still an issue, don't hesitate to reopen this, and open a bug in gnome's bugzilla (post the url here too).

Thanks