Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 130602 - error building mplayer-1.0.20060415
Summary: error building mplayer-1.0.20060415
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 132643 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-20 06:36 UTC by Ricardo
Modified: 2006-06-22 17:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo 2006-04-20 06:36:13 UTC
Right, so emerge fails when I try to upgrade to mplayer-1.0.20060415.  Here's the error:

cc -c -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -W -Wall -Wno-unused-parameter -O2 -march=i486 -mtune=i686 -g  -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE  -I.. -I../loader    -I../libavutil -I../libavcodec -I../libavformat    -I/usr/lib/live/liveMedia/include -I/usr/lib/live/UsageEnvironment/include -I/usr/lib/live/BasicUsageEnvironment/include -I/usr/lib/live/groupsock/include -o demux_rtp.o demux_rtp.cpp
In file included from stream.h:308,
                 from demux_rtp.h:8,
                 from demux_rtp.cpp:9:
/usr/include/dvdread/ifo_types.h:32:2: #error "Must include <inttypes.h> or <stdint.h> before any libdvdread header."
In file included from bswap.h:2,
                 from aviheader.h:5,
                 from stheader.h:4,
                 from demux_rtp.cpp:10:
../bswap.h: In function `uint64_t ByteSwap64(uint64_t)':
../bswap.h:53: warning: subscripting array declared `register'
../bswap.h:53: warning: subscripting array declared `register'
make[1]: *** [demux_rtp.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/mplayer-1.0.20060415/work/mplayer-1.0.20060415/libmpdemux'
make: *** [libmpdemux/libmpdemux.a] Error 2

!!! ERROR: media-video/mplayer-1.0.20060415 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_compile
  ebuild.sh, line 929:   Called src_compile
  mplayer-1.0.20060415.ebuild, line 492:   Called die

!!! Failed to build MPlayer!
!!! If you need support, post the topmost build error, and the call stack if relevant.


Here's my emerge --info:

|42| / $ emerge --info
Portage 2.1_pre7-r5 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.15-g 
entoo-r7 i686)
=================================================================
System uname: 2.6.15-gentoo-r7 i686 Intel(R) Pentium(R) 4 Mobile CPU 1.80GHz
Gentoo Base System version 1.12.0_pre17
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share 
/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kd 
e/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var 
/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/s 
plash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig digest distlocks fixpackages metadata-transfer sandbox sfpe 
rms strict"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://mirror.datapipe.net/gen 
too http://gentoo.mirrors.tds.net/gentoo http://gentoo.chem.wisc.edu/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 3ds X a52 aac abook acpi aim alsa apache2 apm arts athena avi berkdb bi 
di bitmap-fonts bittorrent bl bluetooth browserplugin bzip2 c++ cdparanoia cdrom 
 clamd cli cpudetection crypt cups debug dga directfb dri dts dv dvbplayer dvd d 
vdread edl eds emboss encode esd fbcon firefox flac foomaticdb fortran gdbm ggi  
gif gimp gimpprint gnome gpm gstreamer gtk gtk2 hostap imlib ipv6 irc isdnlog jp 
eg jpeg2k kde libclamav libg++ libwww live lm_sensors lzo mad matroska mikmod mm 
x mmxext motif mozilla mp3 mp4 mp4live mpe mpeg mpeg2 mplayer musepack mythtv nc 
urses nls nptl nptlonly ogg openal opengl oss pam pcmcia pcre pdflib perl png pp 
ds pppd python qt quicktime readline real reflection reiserfs scp sdl session sp 
amassassin spell spl sse sse-filters sse2 ssl svga svgz tcpd theora truetype tru 
etype-fonts type1-fonts udev vorbis wifi win32codecs x11vnc x264 xanim xml xmms  
xv xvid xvmc zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_ 
linux userland_GNU video_cards_ati video_cards_fbdev video_cards_vesa"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLA 
GS, LINGUAS

-Ricardo-
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-04-20 06:39:55 UTC
Again?! :S
Comment 2 Ricardo 2006-04-24 13:33:52 UTC
No, this is a different problem.  Bug 130600 is about how there are stray ebuilds on my system that are not purged by emerge --sync for whatever reason.  This bug is about mplayer itself failing during the compile.  That's why I committed 130600 and 130602 (this one) to different categories.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-04-24 13:37:02 UTC
(In reply to comment #2)

I was referring to (supposedly fixed) Bug 127901...
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-05-07 21:57:04 UTC
*** Bug 132643 has been marked as a duplicate of this bug. ***
Comment 5 Steve Dibb (RETIRED) gentoo-dev 2006-06-22 17:40:08 UTC
Roberto, is the bug still present in 1.0_pre8?