Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 130428 - media-libs/libmpeg3-1.5.2-r2 fails to compile
Summary: media-libs/libmpeg3-1.5.2-r2 fails to compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-18 22:29 UTC by kevin kricfalusi
Modified: 2006-04-19 20:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libmpeg3 1.5.2-r2 failed to compile (error.log,3.08 KB, text/x-log)
2006-04-19 14:48 UTC, James Georkas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kevin kricfalusi 2006-04-18 22:29:08 UTC
steps to reproduce:
emerge libmpeg3

Nothing is contained in /var/tmp/portage/libmpeg3-1.5.2-r2/work/libmpeg3-1.5.2/x86_64/ while make is being done. 

error message:
>>> Compiling source in /var/tmp/portage/libmpeg3-1.5.2-r2/work/libmpeg3-1.5.2 ...
/bin/sh: -c: line 1: syntax error: unexpected end of file
/bin/sh: x86_64/c_flags: No such file or directory
/bin/sh: x86_64/a52_flags: No such file or directory
/bin/sh: x86_64/objs: No such file or directory
x86_64-pc-linux-gnu-gcc -c `cat x86_64/c_flags`  audio/ac3.c -o x86_64/audio/ac3.o
cat: x86_64/c_flags: No such file or directory
audio/ac3.c:4:17: a52.h: No such file or directory
audio/ac3.c:5:26: mpeg3private.h: No such file or directory
audio/ac3.c:6:25: mpeg3protos.h: No such file or directory
audio/ac3.c:11: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3_new_ac3':
audio/ac3.c:13: error: `mpeg3_ac3_t' undeclared (first use in this function)
audio/ac3.c:13: error: (Each undeclared identifier is reported only once
audio/ac3.c:13: error: for each function it appears in.)
audio/ac3.c:13: error: `result' undeclared (first use in this function)
audio/ac3.c: At top level:
audio/ac3.c:20: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3_delete_ac3':
audio/ac3.c:22: error: `audio' undeclared (first use in this function)
audio/ac3.c: At top level:
audio/ac3.c:39: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3_ac3_header':
audio/ac3.c:42: error: `audio' undeclared (first use in this function)
audio/ac3.c:45: error: `header' undeclared (first use in this function)
audio/ac3.c:57: error: `A52_LFE' undeclared (first use in this function)
audio/ac3.c:59: error: `A52_CHANNEL_MASK' undeclared (first use in this function)
audio/ac3.c:61: error: `A52_CHANNEL' undeclared (first use in this function)
audio/ac3.c:64: error: `A52_MONO' undeclared (first use in this function)
audio/ac3.c:67: error: `A52_STEREO' undeclared (first use in this function)
audio/ac3.c:70: error: `A52_3F' undeclared (first use in this function)
audio/ac3.c:73: error: `A52_2F1R' undeclared (first use in this function)
audio/ac3.c:76: error: `A52_3F1R' undeclared (first use in this function)
audio/ac3.c:79: error: `A52_2F2R' undeclared (first use in this function)
audio/ac3.c:82: error: `A52_3F2R' undeclared (first use in this function)
audio/ac3.c:85: error: `A52_DOLBY' undeclared (first use in this function)
audio/ac3.c: At top level:
audio/ac3.c:98: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3audio_doac3':
audio/ac3.c:105: error: `sample_t' undeclared (first use in this function)
audio/ac3.c:105: error: syntax error before "level"
audio/ac3.c:109: error: `audio' undeclared (first use in this function)
audio/ac3.c:110: error: `frame' undeclared (first use in this function)
audio/ac3.c:112: error: `level' undeclared (first use in this function)
audio/ac3.c:122: error: `render' undeclared (first use in this function)
audio/ac3.c:128: error: `output' undeclared (first use in this function)
audio/ac3.c:128: error: syntax error before ')' token
make: *** [x86_64/audio/ac3.o] Error 1

!!! ERROR: media-libs/libmpeg3-1.5.2-r2 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_compile
  ebuild.sh, line 929:   Called src_compile
  libmpeg3-1.5.2-r2.ebuild, line 63:   Called die



Emerge Info:
Portage 2.1_pre7-r5 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.16-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3700+
Gentoo Base System version 1.12.0_pre17
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo/"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X aac aalib alsa apache2 asf avi berkdb bitmap-fonts cli crypt ctype cups dba dri dv dvd dvdr dvdread ecs eds emboss encode erama expat fastbuild ffmpeg foomaticdb force-cgi-redirect fortran ftp gd gif gnome gpm gstreamer gtk gtk2 gtkhtml id3 imlib ipv6 isdnlog jpeg lcd lirc lzw lzw-tiff memlimit mp3 mpeg mpeg2 ncurses nls nptl nptlonly nvidia ogg oggvorbis openal opengl pam pcre pda pdflib perl png posix pppd python quicktime readline sdl session simplexml soap sockets spell spl ssl svg tcpd theora tiff tokenizer truetype truetype-fonts type1-fonts usb v4l v4l2 vcd win32cod xin xinerama xml xmms xpm xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia video_cards_nv"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS


If you try compile from plain vanilla package of libmpeg3 and run make you get the same error.. if you run it right after that then compiles fine. not sure what to make of that.. 

thnx guys,
Comment 1 Oton V. Mahnič 2006-04-19 01:57:31 UTC
And here is my error... Wich is the same thing... Different cflags.

error:
gentoo libmpeg3-1.6 # emerge libmpeg3
Calculating dependencies... done!
>>> Emerging (1 of 1) media-libs/libmpeg3-1.5.2-r2 to /
>>> checksums files   ;-) libmpeg3-1.5.2-r2.ebuild
>>> checksums files   ;-) libmpeg3-1.5.2.ebuild
>>> checksums files   ;-) libmpeg3-1.5.2-r1.ebuild
>>> checksums files   ;-) files/digest-libmpeg3-1.5.2-r2
>>> checksums files   ;-) files/digest-libmpeg3-1.5.2
>>> checksums files   ;-) files/digest-libmpeg3-1.5.2-r1
>>> checksums src_uri ;-) libmpeg3-1.5.2-src.tar.bz2
>>> checksums src_uri ;-) libmpeg3-patches-3.tar.bz2
>>> Unpacking source...
>>> Unpacking libmpeg3-1.5.2-src.tar.bz2 to /var/tmp/portage/libmpeg3-1.5.2-r2/work
>>> Unpacking libmpeg3-patches-3.tar.bz2 to /var/tmp/portage/libmpeg3-1.5.2-r2/work
 * Applying various patches (bugfixes/updates) ...
 *   01_all_installheader.patch ...                                       [ ok ]
 *   02_all_mpeg3split.patch ...                                          [ ok ]
 *   03_all_pthread.patch ...                                             [ ok ]
 *   04_all_largefile.patch ...                                           [ ok ]
 *   05_all_proper-c.patch ...                                            [ ok ]
 *   06_all_no-nasm.patch ...                                             [ ok ]
 *   07_all_gentoo-multilib.patch ...                                     [ ok ]
 *   08_all_gcc34.patch ...                                               [ ok ]
 * Done with patching
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/libmpeg3-1.5.2-r2/work/libmpeg3-1.5.2 ...
/bin/sh: -c: line 1: syntax error: unexpected end of file
/bin/sh: x86_64/c_flags: No such file or directory
/bin/sh: x86_64/a52_flags: No such file or directory
/bin/sh: x86_64/objs: No such file or directory
x86_64-pc-linux-gnu-gcc -c `cat x86_64/c_flags`  audio/ac3.c -o x86_64/audio/ac3.o
cat: x86_64/c_flags: No such file or directory
audio/ac3.c:4:17: a52.h: No such file or directory
audio/ac3.c:5:26: mpeg3private.h: No such file or directory
audio/ac3.c:6:25: mpeg3protos.h: No such file or directory
audio/ac3.c:11: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3_new_ac3':
audio/ac3.c:13: error: `mpeg3_ac3_t' undeclared (first use in this function)
audio/ac3.c:13: error: (Each undeclared identifier is reported only once
audio/ac3.c:13: error: for each function it appears in.)
audio/ac3.c:13: error: `result' undeclared (first use in this function)
audio/ac3.c: At top level:
audio/ac3.c:20: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3_delete_ac3':
audio/ac3.c:22: error: `audio' undeclared (first use in this function)
audio/ac3.c: At top level:
audio/ac3.c:39: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3_ac3_header':
audio/ac3.c:42: error: `audio' undeclared (first use in this function)
audio/ac3.c:45: error: `header' undeclared (first use in this function)
audio/ac3.c:57: error: `A52_LFE' undeclared (first use in this function)
audio/ac3.c:59: error: `A52_CHANNEL_MASK' undeclared (first use in this function)
audio/ac3.c:61: error: `A52_CHANNEL' undeclared (first use in this function)
audio/ac3.c:64: error: `A52_MONO' undeclared (first use in this function)
audio/ac3.c:67: error: `A52_STEREO' undeclared (first use in this function)
audio/ac3.c:70: error: `A52_3F' undeclared (first use in this function)
audio/ac3.c:73: error: `A52_2F1R' undeclared (first use in this function)
audio/ac3.c:76: error: `A52_3F1R' undeclared (first use in this function)
audio/ac3.c:79: error: `A52_2F2R' undeclared (first use in this function)
audio/ac3.c:82: error: `A52_3F2R' undeclared (first use in this function)
audio/ac3.c:85: error: `A52_DOLBY' undeclared (first use in this function)
audio/ac3.c: At top level:
audio/ac3.c:98: error: syntax error before '*' token
audio/ac3.c: In function `mpeg3audio_doac3':
audio/ac3.c:105: error: `sample_t' undeclared (first use in this function)
audio/ac3.c:105: error: syntax error before "level"
audio/ac3.c:109: error: `audio' undeclared (first use in this function)
audio/ac3.c:110: error: `frame' undeclared (first use in this function)
audio/ac3.c:112: error: `level' undeclared (first use in this function)
audio/ac3.c:122: error: `render' undeclared (first use in this function)
audio/ac3.c:128: error: `output' undeclared (first use in this function)
audio/ac3.c:128: error: syntax error before ')' token
make: *** [x86_64/audio/ac3.o] Error 1

!!! ERROR: media-libs/libmpeg3-1.5.2-r2 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_compile
  ebuild.sh, line 929:   Called src_compile
  libmpeg3-1.5.2-r2.ebuild, line 63:   Called die

!!! Failed libmpeg3.a
!!! If you need support, post the topmost build error, and the call stack if relevant.

emerge info:
Portage 2.1_pre7-r5 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.16-gentoo-r2-amd64 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r2-amd64 x86_64 AMD Athlon(tm) 64 Processor 3700+
Gentoo Base System version 1.12.0_pre17
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -ffast-math -fomit-frame-pointer -pipe -funroll-loops -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=k8 -ffast-math -fomit-frame-pointer -pipe -funroll-loops -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.mirrored.ca/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac alsa apache2 avi berkdb bitmap-fonts bzip2 cdinstall cdparanoia cdr cli crypt ctype cups dba dri dts dvd dvdr eds emboss encode expat fastbuild ffmpeg firefox flac foomaticdb force-cgi-redirect fortran ftp gd gif gpm gstreamer gtk gtk2 hal imagemagick imlib isdnlog java jpeg jpeg2k kde lm_sensors lzw lzw-tiff matroska memlimit mime mp3 mpeg msn ncurses nls nptl nptlonly nsplugin nvidia offensive ogg opengl pam pcre pdf pdflib perl pic png posix pppd python qt quicktime readline samba sdl session simplexml soap sockets spell spl ssl tcpd theora tiff tokenizer truetype truetype-fonts type1-fonts usb videos vorbis xine xml xpm xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia video_cards_vesa"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS

The same thing happens with manual ./configure (wich does nothing btw, wierd thing) and make. I can't emerge k3b because of this, help! the only error in ~amd64 I got!
Comment 2 James Georkas 2006-04-19 14:48:58 UTC
Created attachment 84981 [details]
libmpeg3 1.5.2-r2 failed to compile 

gcc 3.4.6 
amd 64
gentoo 64 bit system
Comment 3 James Georkas 2006-04-19 14:54:38 UTC
Comment on attachment 84981 [details]
libmpeg3 1.5.2-r2 failed to compile 

Well I can't recompile my system because of that... might be because I have upgraded my gcc for 3.4.5 to 4.5.6 ???? any solutions??? any suggestions???
Comment 4 Dave Massey 2006-04-19 15:55:08 UTC
I can confirm this problem too.

emerge --info:
Portage 2.1_pre7-r5 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.16-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.0_pre17
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirror.datapipe.net/gentoo http://mirrors.tds.net/gentoo ftp://mir.zyrianes.net/gentoo/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X a52 alsa arts avi berkdb bitmap-fonts bzip2 cddb cdinstall cdparanoia cdrom chroot cli crypt cups divx4linux dri dv dvd dvdr dvdread dxr3 eds emboss encode ffmpeg foomaticdb fortran gif gimp gimpprint gpm gstreamer gtk gtk2 icq imagemagick imlib isdnlog jpeg kde lm_sensors lzw lzw-tiff mjpeg mozilla mp3 mpeg mpeg4 mplayer msn multislot ncurses nls nptl nptlonly nsplugin nvidia ogg opengl pam pcre pdf pdflib perl png pppd python qt quicktime readline reflection sdl session softmmu spell spl ssl tcpd tiff transcode truetype truetype-fonts type1-fonts unicode usb v4l v4l2 wxwindows xine xinerama xml xmms xpm xscreensaver xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia video_cards_vga video_cards_nv"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-04-19 20:36:08 UTC
Okay I've tried to get something decently working in -r3, now it does build, it's still the worse makefile I ever seen in my life.