Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 129793 - Keyboard stop responding sometimes with modular Xorg (xorg-x11-7.0-r1)
Summary: Keyboard stop responding sometimes with modular Xorg (xorg-x11-7.0-r1)
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-13 04:48 UTC by Patrick ALLAERT
Modified: 2010-04-16 10:55 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg log file (Xorg.0.log) (Xorg.0.log,23.08 KB, text/plain)
2006-04-13 04:50 UTC, Patrick ALLAERT
Details
emerge --info (einfo,3.57 KB, text/plain)
2006-07-03 02:10 UTC, Nico Mahlo
Details
Output of 'emerge --info' (ei.txt,3.21 KB, text/plain)
2006-07-04 05:47 UTC, Darren Charette
Details
Xorg.0.log (Xorg.0.log,31.96 KB, text/plain)
2006-07-04 05:48 UTC, Darren Charette
Details
Xorg log for Coment #44 (Xorg.0.log.old,27.34 KB, text/plain)
2006-10-12 19:00 UTC, Kevin Bowling
Details
Xorg conf for coment #44 (xorg.conf,5.82 KB, text/plain)
2006-10-12 19:01 UTC, Kevin Bowling
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick ALLAERT 2006-04-13 04:48:25 UTC
Sometimes, when I press a combination of keys like ALT+F2, ALT+TAB or simply F12 to show yakuake, my keyboard completely stop responding, even the capslock/numlock light does not switch state by pressing the corresponding key.

In few cases, the keyboard respond again after some time, but what I pressed during this time is not buffered.

What I also remark when it happens: my mouse's behavior change, clicking a window and moving the mouse move the window, like ALT+move mouse was used. This let me unable to click on buttons like OK | CANCEL but well on decoration buttons. Also my mouse wheel scroll from page to page in place of by few lines.

If I move to a TTY login (I am forced to use KDE menu > Switch user > ...) the keyboard works perfectly, coming back (ALT+F7) to X does not solve the problem, the keyboard is still completely locked.

When it happens, I am forced to quit my session. When I come to the KDM login screen and re-login, everything is working again until...

After moving to modular xorg I completely re-emerged all kde applications since I am using xinerama and thought it was related...

For info, I am using:
- nvidia-glx-1.0.8756
- nvidia-kernel-1.0.8756

Xorg.0.log in attach in a couple of minutes!

I hope the description is complete enough, just ask for more information if needed.

My emerge --info is:

==========%<==========
Portage 2.1_pre7-r5 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.5-r3, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.20GHz
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://mirror.ovh.net/gentoo-distfiles/"
LDFLAGS="-Wl,-O1"
LINGUAS="en fr eo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.2/gentoo-portage"
USE="x86 3dfx 3dnow X Xaw3d aac acpi alsa apache2 apm arts audiofile avi bash-completion berkdb bitmap-fonts browserplugin bzip2 cli crypt ctype cups curl dba directfb dri dvd emboss encode esd expat fastbuild ffmpeg foomaticdb force-cgi-redirect fortran ftp gd gdbm gif gimpprint gpm gstreamer gtk2 hal idn ieee1394 imagemagick imlib innodb isdnlog java javascript jpeg kde kdeenablefinal lcms ldap libg++ libwww mad matroska memlimit mikmod mmx mmxext mng motif mozdevelop mozilla mp3 mpeg mplayer msn mysql mysqli ncurses nls nptl nsplugin nvidia ogg oggvorbis opengl oss pam pcmcia pcre pdflib perl php pic png posix ppds pppd python qt quicktime readline samba sdl session simplexml soap sockets spell spl sqlite sse sse2 ssl svg tcpd tetex tidy tiff tokenizer truetype truetype-fonts type1-fonts udev unicode usb utf8 vhosts vim-with-x vorbis win32codecs wmf xcomposite xine xinerama xml xml2 xmms xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en linguas_fr linguas_eo userland_GNU video_cards_nv video_cards_nvidia video_cards_vesa"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL
==========%<==========
Comment 1 Patrick ALLAERT 2006-04-13 04:50:27 UTC
Created attachment 84554 [details]
Xorg log file (Xorg.0.log)
Comment 2 Joshua Baergen (RETIRED) gentoo-dev 2006-04-16 15:06:25 UTC
Are you using xkbdata or xkeyboard-config?  What version of the respective package are you running?

In any case, you could try the newest version of xkeyboard-config.  You'll have to unmerge xkbdata first if you have it installed.  Although I kind of doubt this will fix anything, it's worth a try.
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2006-04-16 16:21:43 UTC
Please reproduce this using the "nv" driver as well, nvidia does something funky with input.
Comment 4 Patrick ALLAERT 2006-04-17 02:16:00 UTC
(In reply to comment #2)
> Are you using xkbdata or xkeyboard-config?  What version of the respective
> package are you running?

I'am currently running x11-misc/xkeyboard-config-0.7-r2 but I am currently emerging v0.8 since it has been updated in portage

I will keep you in touch
Comment 5 Patrick ALLAERT 2006-04-17 05:21:05 UTC
(In reply to comment #2)
> In any case, you could try the newest version of xkeyboard-config.  You'll have
> to unmerge xkbdata first if you have it installed.  Although I kind of doubt
> this will fix anything, it's worth a try.

Using x11-misc/xkeyboard-config-0.8 doesn't solve the problem :(
Comment 6 Patrick ALLAERT 2006-04-17 05:27:07 UTC
(In reply to comment #3)
> Please reproduce this using the "nv" driver as well, nvidia does something
> funky with input.

I switched as you said:

Section "Device"
#        Driver  "nvidia"
        Driver  "nv" # test bug #129793
        VendorName  "nVidia Corporation"
        BoardName   "NV17 [GeForce4 440 Go]"

But it didn't solve my problem :(
Comment 7 Patrick ALLAERT 2006-04-17 07:39:46 UTC
Ok, I've got the problem, Donnie Berkholz was right, the new nvidia drivers caused this problem and I think that the modular Xorg has nothing to do with it!

I switched back from
- nvidia-glx-1.0.8756
- nvidia-kernel-1.0.8756
to
- nvidia-glx-1.0.8178-r1
- nvidia-kernel-1.0.8178-r3

And I can't reproduce the bug anymore!
Comment 8 Patrick ALLAERT 2006-04-18 02:38:58 UTC
(In reply to comment #7)
> Ok, I've got the problem, Donnie Berkholz was right, the new nvidia drivers
> caused this problem and I think that the modular Xorg has nothing to do with
> it!
> 
> I switched back from
> - nvidia-glx-1.0.8756
> - nvidia-kernel-1.0.8756
> to
> - nvidia-glx-1.0.8178-r1
> - nvidia-kernel-1.0.8178-r3
> 
> And I can't reproduce the bug anymore!

Damn it!

Two days that the bug was gone and it comes back :(
I thought it was related to nvidia-*-1.0.8756 so I downgraded to 8178, but the bug occurred again. I rebooted and now I can't reproduced it.

I really don't know in which direction to go, is this related to xkb*, nvidia drivers, a combination of these ?
Comment 9 Patrick ALLAERT 2006-04-19 01:30:57 UTC
UPDATE:
This bug has nothing to do with the nvidia drivers as it is perfectly reproducible without the module "nvidia" loaded and using exclusively the "nv" driver.
Comment 10 Patrick ALLAERT 2006-04-19 13:03:55 UTC
(In reply to comment #2)
> Are you using xkbdata or xkeyboard-config?  What version of the respective
> package are you running?

I tried both and can reproduce it with both xkbdata and xkeyboard-config

By the way, could someone reassign this to x11@gentoo.org as it is not related to nvidia as I thought ! Thanks.
Comment 11 Patrick ALLAERT 2006-04-20 05:46:14 UTC
Maybe related to #130590 ? (presence of /usr/X11R6/lib/X11/xkb)

I can't reproduce it right now, but it is not sure it is gone as I had no problems during two days...
Comment 12 Patrick ALLAERT 2006-04-21 02:19:40 UTC
(In reply to comment #11)
> Maybe related to #130590 ? (presence of /usr/X11R6/lib/X11/xkb)
> 
> I can't reproduce it right now, but it is not sure it is gone as I had no
> problems during two days...

Unfortunately, removing /usr/X11R6/lib/X11/xkb did not resolve this problem :(
Comment 13 Joshua Baergen (RETIRED) gentoo-dev 2006-04-21 22:13:06 UTC
Please try reproducing this with the 'vesa' driver.
Comment 14 Patrick ALLAERT 2006-04-25 11:57:45 UTC
(In reply to comment #13)
> Please try reproducing this with the 'vesa' driver.

I switched to driver "vesa" in place of "nvidia" and could sucessfully reproduce the bug :(

I only have to press 2-3 times a CTRL+F{1,2,3,4} and my keyboard is completely blocked

Confirmed using drivers: nvidia, nv and vesa
Comment 15 Fyodor Kupchik 2006-05-01 01:04:38 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Please try reproducing this with the 'vesa' driver.
> 
> I switched to driver "vesa" in place of "nvidia" and could sucessfully
> reproduce the bug :(
> 
> I only have to press 2-3 times a CTRL+F{1,2,3,4} and my keyboard is completely
> blocked
> 
> Confirmed using drivers: nvidia, nv and vesa
> 

2 days ago I got the same bug
try this:
emerge xorg-x11 xorg-server -Du
that solves this trouble for me but second bug appears
it described (no by me) here http://forums.gentoo.org/posting.php?mode=quote&p=3279128
Comment 16 Patrick ALLAERT 2006-05-02 11:31:46 UTC
(In reply to comment #15)
> 2 days ago I got the same bug
> try this:
> emerge xorg-x11 xorg-server -Du
> that solves this trouble for me but second bug appears
> it described (no by me) here
> http://forums.gentoo.org/posting.php?mode=quote&p=3279128

I updated to the newer version of the Xorg components as you suggested but it didn't help, I still have this problem :(

What is very strange, is that I could use my PC a whole day, without having this problem... and sometimes, it happens only the 2nd or 3rd time I press a CTRL+F[1-4]
In fact, the first thing I do once i am logged, is to switch fast pressing several times these keys, if fails, I have to close and reopen the session (using the mouse of course) if it does not fail, I know that I can use my session without any problems... In short, if my keyboard has to freeze, it will freeze early (from 1st use to 20th use of a key combination) or never...
Comment 17 Patrick ALLAERT 2006-05-05 07:30:22 UTC
This bug has been somewhat reported upstream... in October 2001 !!!

http://bugs.kde.org/show_bug.cgi?id=33548

First comment describe well what occurs.
Comment 18 Patrick ALLAERT 2006-05-05 08:56:04 UTC
When the keyboard hangs, terminating kwin with signal 15 does not give the keyboard back, *HOWEVER* after kwin has been terminated, running kwin again using a konsole (and mouse's middle button to paste "kwin &" as I don't have the keyboard...) causes the keyboard to respond again!
Comment 19 Herve.Roussain 2006-05-24 05:44:17 UTC
It seems that disabling DRI in /etc/X11/xorg.conf helped me resolved the bug, but I'm still in a test phase.

I'm using modular X.org (xorg-server-1.0.2-r4), KDE 3.5.2 (kwin-3.5.2-r2), and Linux 2.6.16 (gentoo-sources-2.6.16-r1), on a Dell workstation with an ATI Radeon (xf86-video-ati-6.5.8.0).

 # emerge --info
Portage 2.1_rc2-r2 (default-linux/x86/2006.0, gcc-4.0.3, glibc-2.4-r3, 2.6.16-gentoo-r1 i686)
=================================================================
System uname: 2.6.16-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.0
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="fr en"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 apm arts avi berkdb bitmap-fonts cli crypt cups dri eds emboss encode esd foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 isdnlog jpeg kde libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls nptl ogg opengl oss pam pcre pdflib perl png pppd python qt quicktime readline reflection sdl session spell spl sse sse2 ssl tcpd truetype truetype-fonts type1-fonts udev unicode vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_fr linguas_en userland_GNU video_cards_r128 video_cards_fbdev video_cards_vesa video_cards_vga"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS
Comment 20 Herve.Roussain 2006-05-24 07:23:54 UTC
Sadly, after some tests I still encounter the problem.

I tried killing kwin and running it again, it doesn't help much...

I'm going to try out if using Xorg 7.1 helps me.
Comment 21 Herve.Roussain 2006-05-29 06:34:37 UTC
Actually, my problem was different: my keyboard was responding but very slowly (I have to press the keys during a few seconds).

I managed to draw the problem back by modifying "accessibility" properties with the KDE's control center.

Cheers,
Comment 22 Joshua Baergen (RETIRED) gentoo-dev 2006-06-11 08:36:28 UTC
This sounds like a KDE problem, then.
Comment 23 Bram Schoenmakers 2006-06-11 09:30:03 UTC
See http://bugs.kde.org/show_bug.cgi?id=109322

The reporter is a Gentoo user, and I believe it's the same problem as I experience. So I suspect it's still something to do with Gentoo.
Comment 24 Patrick ALLAERT 2006-06-12 05:38:06 UTC
(In reply to comment #23)
> See http://bugs.kde.org/show_bug.cgi?id=109322
> 
> The reporter is a Gentoo user, and I believe it's the same problem as I
> experience. So I suspect it's still something to do with Gentoo.

I confirm that the description available on the link you provided is EXACTLY what I have...
Comment 25 Mivz 2006-06-16 04:15:35 UTC
I have sort of the same problem.

When my desktop manager boots from default runlevel, only a few keys do some thing.
When I start hitting my keyboard (every key the same time), the password field at first fils up with stars, then with characters like a square or circle.
After that X crashed, and restart it self and every thing works fine, except for the fact that or I lost all of my consols; there just blank. Or sometimes they stay, but than the second console is full of strange characters.

If I do not run my desktop manager form default runlevel, but login and run /etc/init.d/xdm start every thing works just fine, not a problem at al.

I use e17 with entranced, but with kde tools.
I have xorg 7.0, because I use the ati fglrx drivers.
I converted my system to unicode.

Portage 2.1_rc4-r3 (selinux/2005.1/x86, gcc-3.4.6, glibc-2.3.6-r3, 2.6.14-hardened-r8-SPine-0.1 i686)
=================================================================
System uname: 2.6.14-hardened-r8-SPine-0.1 i686 Intel(R) Pentium(R) M processor 1.86GHz
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer -fforce-addr -falign-functions=4 -fprefetch-loop-arrays"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer -fforce-addr -falign-functions=4 -fprefetch-loop-arrays"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks loadpolicy metadata-transfer sandbox selinux sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="nl_NL.UTF-8"
LC_ALL="nl_NL.UTF-8"
LINGUAS="nl en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi aim alsa apache2 audiofile avi bash-completion berkdb bitmap-fonts bluetooth bzip2 bzlib calendar caps cdr cjk clamav crypt cups curl dba dga dio directfb divx4linux doc dri dts dvd dvdread encode ethereal exif ffmpeg firefox flac ftp gcj gd gif glut gpm gstreamer icq ieee1394 imagemagick imap imlib ipv6 jabber java javascript jpeg jpeg2k kde kerberos ldap libcaca lm_sensors logrotate mad maildir mcal mime mmap mmx mng motif mozilla mp3 mpeg msn ncurses nls nptl nptlonly nsplugin offensive ogg openal opengl oss pam pcmcia pcre pda pdf perl png pnp posix postgres python qt readline samba sasl sdl selinux slang snmp sockets socks5 spell spl sse sse2 ssl svg symlink sysfs threads tiff truetype unicode usb v4l v4l2 vcd vhosts videos vorbis wifi win32codecs x86 xine xinerama xml xmms xorg xosd xpm xv xvid zlib elibc_glibc input_devices_mouse input_devices_keyboard kernel_linux linguas_nl linguas_en userland_GNU video_cards_radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 26 Christian Schlotter 2006-07-03 01:17:15 UTC
Hi!

I can report a similiar issue.  After upgrading from X.org 6.8 to X.org 7.0 I get the following strange behaviour:  Everywhere in X (that means on the login manager and on the window manager) no key has an effect, only if I hit the number keys on the keyboard multiple times some numbers will be printed (about 3).  If this is the case, other keypresses besides the number keys have an effect, but only for about 3 times.  But sometimes in this situation it happens, that the key pressed last "hangs" and prints characters infinitely on the screen.  This can be interrupted by pressing some number keys as described above.

If I repeat this procedure for about half a minute (pressing some number keys, then typing on some other keys until this does not work anymore, then pressing some number keys again, and so on...) I can use the keyboard.  But if I do not touch it for about a minute, the whole problem occurs again.

I use wdm as login manager and Window Maker as window manager.  Upgrading to X.org 7.1 did not solve the problem.  But -- as already mentioned by comment #25 -- if I remove xdm from the default runlevel and start it by hand from the console, the problem vanishes.

Here's the relevant excerpt of my xorg.conf:
Section "InputDevice"
    Identifier   "Keyboard1"
    Driver   "kbd"
#    Driver   "keyboard" # <-- this does change nothing
    Option "AutoRepeat" "500 30"
    Option "XkbModel"   "ltcd" # <-- also changed to other logitech models and to generic pc-105, but this showed the same behaviour
    Option "XkbLayout"   "de"
EndSection

Here's the output of emerge --info (please not that I use INPUT_DEVICES="keyboard mouse" and VIDEO_CARDS="nv vga"):
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r9 i686)
=================================================================
System uname: 2.6.16-gentoo-r9 i686 Pentium III (Katmai)
Gentoo Base System version 1.6.15
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
LINGUAS="en"
MAKEOPTS="-j 2 -l 2.3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X alsa apm avi berkdb bitmap-fonts cli crypt cups divx4linux dlloader dri eds emacs emboss encode fam foomaticdb fortran gdbm gif gstreamer gtk gtk2 imlib isdnlog jpeg libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nptl nptlonly ogg pam pcre pdflib png ppds pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl sse ssl truetype truetype-fonts type1-fonts udev vorbis xml xmms xorg xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en userland_GNU video_cards_nv video_cards_vga"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS

I also started a thread on the forums where two other people with similar problems reported: http://forums.gentoo.org/viewtopic-p-3418210.html

Best regards
Christian
Comment 27 Nico Mahlo 2006-07-03 02:10:03 UTC
Created attachment 90752 [details]
emerge --info
Comment 28 Nico Mahlo 2006-07-03 02:11:19 UTC
Hi!
After I upgraded to the modular X.org the keyboard hangs on high load situations (load 3..6). If you write normal text meanwhile sometimes it is as you would have sticky keys. Thhhis iiiis looooking likeeee thiiiiiis. ;) 
 
I do not know, whether this problem can be solved by giving a higher priority to a specific process, or what else to do. 
 
(my keyboard is a PS/2 by Cherry) 
 
HTH
 
P.S.: I did not yet try this with manually starting xdm (which uses gdm on my system). If I did, I'll drop some lines.
Comment 29 Rainer Findenig 2006-07-03 02:31:21 UTC
I'm experiencing the same problem as described in comments #25 and #26. Keyboard input does not work correctly (exactly as described in comment #25, except that X does not crash on me afterwards) if xdm is in the default runlevel, everything is fine if I start xdm by hand.

I'm also running entranced and e17 with KDE tools and x11-drivers/ati-drivers-8.25.18 with x11-apps/ati-drivers-extra-8.23.7.

The keyboard is the builtin keyboard on a Dell Inspiron 8600c notebook.

interesting stuff from make.conf:
---------------------------------
INPUT_DEVICES="keyboard mouse synaptics evdev"
VIDEO_CARDS="fglrx"

section from xorg.conf:
-----------------------
Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "keyboard"
    Option      "AutoRepeat" "500 30"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "de"
    Option      "XkbVariant" "nodeadkeys"
EndSection

Using Driver "kbd" instead of keyboard does not make any difference, as well as commenting out the "AutoRepeat" option.


emerge --info:
--------------
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r9 i686)
=================================================================
System uname: 2.6.16-gentoo-r9 i686 Intel(R) Pentium(R) M processor 1.70GHz
Gentoo Base System version 1.6.15
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe -funroll-loops -mmmx -msse -msse2 -fomit-frame-pointer -momit-leaf-frame-pointer -fno-ident"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe -funroll-loops -mmmx -msse -msse2 -fomit-frame-pointer -momit-leaf-frame-pointer -fno-ident -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy ccache confcache distcc distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://linux.fh-hagenberg.at/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acpi alsa arts avi berkdb bitmap-fonts cairo cdr cli crypt cups dlloader dri dvd dvdr eds emboss foomaticdb gdbm gif gpm gstreamer gtk gtk2 imlib ipv6 isdnlog jpeg kde kdeenablefinal libg++ libwww logitech-mouse mad mikmod mmx mmx2 motif mozsvg mp3 mpeg ncurses nls nptl ogg opengl oss pam pcre pdflib perl png ppds pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl tcpd theora truetype truetype-fonts type1-fonts udev vorbis win32codecs xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_synaptics input_devices_evdev kernel_linux userland_GNU video_cards_fglrx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 30 Matteo Azzali (RETIRED) gentoo-dev 2006-07-03 04:31:13 UTC
I had a similar issue when playing games using shift key in kde.
My solution was disabling anything in:
kcontrol-> Regional and Easier Access-> Accessibility-> Activation Gestures

not much sure it's related, but try that if you're in KDE.
Comment 31 Darren Charette 2006-07-04 05:46:08 UTC
I don't think this is a KDE-specific problem. I've experienced this problem twice under GNOME, with some additional weirdness:

1) In one case, the mouse gravitated towards the bottom of the screen.  It could be moved freely, but would be dragged down as soon as movement stopped.  I don't remember whether or not this happened the other time.

2) In that same case, the desktop would occasionally be pushed upwards by some brightly coloured stuff (which looked like an ultra-enlarged version of a site I was viewing with firefox).  I could make it go away temporarily by hurling the mouse towards the top of the screen.  This did not happen the other time.

As a side note, both instances occured during heavy Portage activity.

Here are some selections from xorg.conf:

Section "Module"
#	Load  "nvidia"
	Load  "freetype"
	Load  "xtt"
	Load  "extmod"
	Load  "glx"
#	Load  "dri"
	Load  "dbe"
	Load  "record"
	Load  "xtrap"
	Load  "type1"
#	Load  "speedo"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc101"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "Auto"
	Option	    "ZAxisMapping" "4 5"
EndSection

'emerge --info' and Xorg.0.log will be attached momentarily.
Comment 32 Darren Charette 2006-07-04 05:47:50 UTC
Created attachment 90844 [details]
Output of 'emerge --info'
Comment 33 Darren Charette 2006-07-04 05:48:50 UTC
Created attachment 90845 [details]
Xorg.0.log
Comment 34 Christian Schlotter 2006-08-06 06:55:34 UTC
I don't know if all reports in this thread are related, but my report is definately not a KDE-problem, as I do not use KDE.  Shouldn't this bug better be assigned to the X.org-team?
Comment 35 Patrick ALLAERT 2006-08-08 02:04:06 UTC
(In reply to comment #34)
> I don't know if all reports in this thread are related, but my report is
> definately not a KDE-problem, as I do not use KDE.  Shouldn't this bug better
> be assigned to the X.org-team?

I looked at your description and your problem does not seem to be related to KDE, but does not seem to be related to this (my) bug either !

This bug is extremely well described in KDE's bugzilla:
http://bugs.kde.org/show_bug.cgi?id=109322

So it is maybe an upstream bug... if it is confirmed to be from KDE side...
If the above URL does not seem to describe your bug, please, fill in another one.
Comment 36 Patrick ALLAERT 2006-08-08 06:43:09 UTC
Comments #25 -> #34 does not seem to be related to this problem, if you find a similar problem, please, fill another new bug.
Comment 37 Carsten Lohrke (RETIRED) gentoo-dev 2006-08-24 08:12:26 UTC
Patrick, do you have the top left checkbox in `kcmshell keyboard_layout` enabled? If so, do you experience the same problems, after disabling it?
Comment 38 Patrick ALLAERT 2006-08-24 09:38:41 UTC
(In reply to comment #37)
> Patrick, do you have the top left checkbox in `kcmshell keyboard_layout`
> enabled? If so, do you experience the same problems, after disabling it?

Carsten,

Yes, the checkbox that activate keyboard layouts is checked because I am using Belgium (be) and American (us) layouts.

This bug occurs very randomly, for example, I just tried a lot of key combinations that is known (by my experience) to let my keyboard stop responding.
* ALT+Tab (switching tabs)
* CTRL+Fx (switching desktops)
* ALT+Fx (K Menu, Run command,...)
... and I was unable to reproduce the bug (I mention that I did NOT disable the checkbox).

I know I can have 2 days without any problems, and another day I will have it everytime.

This is what I will do:

1
Comment 39 Patrick ALLAERT 2006-08-24 09:38:41 UTC
(In reply to comment #37)
> Patrick, do you have the top left checkbox in `kcmshell keyboard_layout`
> enabled? If so, do you experience the same problems, after disabling it?

Carsten,

Yes, the checkbox that activate keyboard layouts is checked because I am using Belgium (be) and American (us) layouts.

This bug occurs very randomly, for example, I just tried a lot of key combinations that is known (by my experience) to let my keyboard stop responding.
* ALT+Tab (switching tabs)
* CTRL+Fx (switching desktops)
* ALT+Fx (K Menu, Run command,...)
... and I was unable to reproduce the bug (I mention that I did NOT disable the checkbox).

I know I can have 2 days without any problems, and another day I will have it everytime.

This is what I will do:

1° I will use all these shortcuts back (yes, I use none of the above since it results in loss of work -- unable to save -- when it happens!!!) to be sure the bug is still present WITH the keyboard layouts activated.

2° If the bug occurs again, I will disable this checkbox and still try to reproduce the bug.

3° I will keep you informed of my testings.

Anyway, thanks a lot Carsten for your investigations! You can't imagine how restrictive it is to not use these shortcuts and I have this problem from a long time now!
Comment 40 Carsten Lohrke (RETIRED) gentoo-dev 2006-08-26 08:38:03 UTC
(In reply to comment #38)
> Yes, the checkbox that activate keyboard layouts is checked because I am using
> Belgium (be) and American (us) layouts.

Well, the point is that it's for sure not an X problem, when it only happens when you use kxkb and I'd bet this is the case. Having it enabled and switching layuots breaks e.g. my khotkey actions.

> Anyway, thanks a lot Carsten for your investigations! You can't imagine how
> restrictive it is to not use these shortcuts and I have this problem from a
> long time now!
> 

Oh, I didn't really do much, but looking for similar reports. :) But I'm pretty sure that this is a KDE problem and not a Gentoo one. Your problem may e.g. relate to this
Comment 41 Carsten Lohrke (RETIRED) gentoo-dev 2006-08-26 08:38:03 UTC
(In reply to comment #38)
> Yes, the checkbox that activate keyboard layouts is checked because I am using
> Belgium (be) and American (us) layouts.

Well, the point is that it's for sure not an X problem, when it only happens when you use kxkb and I'd bet this is the case. Having it enabled and switching layuots breaks e.g. my khotkey actions.

> Anyway, thanks a lot Carsten for your investigations! You can't imagine how
> restrictive it is to not use these shortcuts and I have this problem from a
> long time now!
> 

Oh, I didn't really do much, but looking for similar reports. :) But I'm pretty sure that this is a KDE problem and not a Gentoo one. Your problem may e.g. relate to this¹ bug, which has been reported here as well a longer while ago. Unfortunately nothing happened. Anyways, I'd say take your problem upstream (and crossreference the bug here, then). kde.org is maintaining the code base and we're simply too understaffed to dig into the code a lot.

[1] https://bugs.kde.org/show_bug.cgi?id=74714
Comment 42 Patrick ALLAERT 2006-08-30 01:02:16 UTC
(In reply to comment #39)
> Well, the point is that it's for sure not an X problem, when it only happens
> when you use kxkb and I'd bet this is the case. Having it enabled and switching
> layouts breaks e.g. my khotkey actions.

OK, here is the result, I still can reproduce this bug by having kxkb enabled (keyboard layout checkbox ON) but disabling it does not resolve the problem.

I have restarted the machine with kxkb disabled before the restart and I am still able to reproduce it.

This is definitely not a kxkb problem and for sure, not related to [1] :-S

> [1] https://bugs.kde.org/show_bug.cgi?id=74714
Comment 43 Patrick ALLAERT 2006-08-31 06:56:32 UTC
My bug is well explained here by another Gentooist:
http://forums.gentoo.org/viewtopic-t-333750.html

Seems to be related to 'Sticky Keys' but I don't use them...

Filled upstream by someone else: http://bugs.kde.org/show_bug.cgi?id=109322
Comment 44 Bram Schoenmakers 2006-09-23 10:40:52 UTC
After having this problem, I saw the following lines in my Xorg.0.log:

SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
(II) 3rd Button detected: disabling emulate3Button
SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
Comment 45 Christian Schlotter 2006-09-23 12:51:40 UTC
@all non-KDE users:
The fix to our problem can be found in bug #139284 and bug #130916:
Set XSTATICVT="no" in /etc/conf.d/xdm.
Comment 46 Kevin Bowling 2006-10-12 18:49:43 UTC
I have a similar bug, please let me know if it is related.

Sometimes when typing X keyboard input completely stops.  I can still switch to a text console and input is just fine there.  I can only remember this happening while typing emails in Mozilla Thunderbird.  It is somewhat infrequent, but started happening when I moved to modular Xorg.  

When this happens, the following is appended to Xorg.0.log:
SetClientVersion: 0 9
SetGrabKeysState - disabled

Using:
nvidia-drivers-1.0.8774

Attaching emerge --info, Xorg.0.log and xorg.conf.
Comment 47 Kevin Bowling 2006-10-12 19:00:15 UTC
Created attachment 99498 [details]
Xorg log for Coment #44

Please ignore the server error at the end, it occurred when I killed kdm.
Comment 48 Kevin Bowling 2006-10-12 19:01:20 UTC
Created attachment 99499 [details]
Xorg conf for coment #44
Comment 49 Piotrek 2007-01-10 16:41:50 UTC
It seems i have similar problem http://bugs.gentoo.org/show_bug.cgi?id=156307
Comment 50 Jonathan Adamczewski 2007-03-15 13:03:45 UTC
Appears to be a dupe of 139284
Comment 51 C. 2007-03-15 13:38:58 UTC
I traced this for some time and was able to stop the lock-ups with commenting this line of my xorg.conf

#       Option "XkbModel"       "inspiron""
Comment 52 Kevin Bowling 2007-03-15 15:55:32 UTC
Something along the way fixed my lock up, though I don't know exactly what it was.  Xorg 7.1 had the sane problems, while Xorg 7.2 has not so far.  I don't know exactly what fixed it (could just as easily be kernel 2.6.20 or freetype or some other component), so I hope it doesn't regress in the future.  Will post here if anything else happens.
Comment 53 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-04-02 19:16:44 UTC
Patrick,

are you still experiencing this errors? Have you tried xorg-7.2?
Comment 54 Patrick ALLAERT 2007-04-03 09:33:30 UTC
(In reply to comment #53)
> Patrick,
> 
> are you still experiencing this errors? Have you tried xorg-7.2?
> 

Jorge, I don't have my old laptop anymore so I can't test anymore. I don't have this problem with my new one, but I didn't close this bug because I guess "changing computer" isn't the "right solution" ;)

For me, this bug may be closed, the main reason is that it is clear that LOTS of comments in this one are clearly different bugs than my original one!

Regards
Comment 55 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-04-03 15:49:47 UTC
I'm closing the bug as Patrick no longer can reproduce this, many comments are related to other bugs and there have been no new "unresolved" reports.
If someone else has the original problem, feel free to open this again. Please update the system to the latest versions and provide all relevant info.
Comment 56 Paul Osmialowski 2010-04-16 10:48:55 UTC
I can reproduce this. Recently I have installed two nvidia cards (PCI and AGP) on my desktop PC and this started avalanche of problems:
1. using alt-tab frequently makes keyboard dead
2. xdm crashes immediately after log out
3. ..so I have to reboot each time keyboard is dead
4. ..and I have to reboot twice, as this AGP card not operated by BIOS cannot be waken up after first reboot (fortunately, it wakes up after second reboot)
5. xinerama regression bug 291620 caused I had to replace my displays, right after I got used to previous placement. What makes me laugh about it, is that moving monitors was the only working solution given there! (someone suggested to revert previous code but no one can say if and when it can happen)
6. at first I didn't plan to use xinerama, as I wanted to have multiseat computer (so I connected two monitors, two keyboards, two mice). Unfortunately, well-known-and-never-fixed-as-no-one-cares-since-you-have-to-use-hal-instead-of-evdev-directly bug in evdev driver causes well known memory leak that shifts image on second (as listed in xorg.conf) display. I have no idea how to configure hal for multiseat! Xephyr is not an option as it disables OpenGL hardware acceleration.
My cards are:
1. nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] - quite ancient PCI card so it cannot be operated by nvidia driver, so I'm using nv driver for it. It cannot wake up by itself so I configured in BIOS setup that PCI card is started first, therefore this is BIOS operated card.
2. nVidia Corporation NV44A [GeForce 6200] (rev a1) - less ancient AGP card operated by nvidia driver, started by XDM

As I am using KDE4 I've found a suggestion that this problem may be caused by KDE keymaps. So I turned them off completely. Soon I realised that this is not solving the problem with Alt+TAB. This nvidia-related bug seem to be more likely the reason for my problems.
Comment 57 Paul Osmialowski 2010-04-16 10:55:31 UTC
Oh, I have completely forgotten about giving versions of drivers:
[ebuild   R   ] x11-base/xorg-server-1.7.6  USE="hal ipv6 kdrive nptl sdl xorg -debug -dmx -minimal -tslib" 0 kB
[ebuild   R   ] x11-drivers/nvidia-drivers-195.36.15  USE="acpi gtk -custom-cflags (-multilib)" 0 kB
[ebuild   R   ] x11-base/xorg-drivers-1.7  INPUT_DEVICES="evdev joystick keyboard mouse -acecad -aiptek -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="dummy intel mach64 nv nvidia r128 v4l vesa -apm -ark -ast -chips -cirrus -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -mga -neomagic (-newport) -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -via -virtualbox -vmware (-voodoo) -xgi" 0 kB
[ebuild   R   ] media-video/nvidia-settings-195.36.15  0 kB

This is plain 32-bit x86 desktop with Pentium 4 HT 3.0GHz CPU and 2GB RAM.