Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 12902 - new rsync package doesn't reconfigure rsyncd.conf location
Summary: new rsync package doesn't reconfigure rsyncd.conf location
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Maik Schreiber
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-12-29 05:33 UTC by Chris Russell (RETIRED)
Modified: 2002-12-29 13:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Russell (RETIRED) gentoo-dev 2002-12-29 05:33:28 UTC
by default previous versions of rsync (rsync-2.5.5-r1 and earlier) looked for
/etc/rsync/rsyncd.conf
with rsync-2.5.6_pre20021105 it now looks for /etc/rsyncd.conf even though the
ebuild tries to alter the sysconfdir as with previous versions.

this causes the rsync server to stop accepting conections until the config file
is moved or a symlink created.

The cause is that the RSYNCD_CONF variable in rsyncd.h has changed to RSYNCD_SYSCONF

FIX; change line 22 of the ebuild to:
 	sed -e 's:RSYNCD_SYSCONF "/etc/rsyncd.conf":RSYNCD_SYSCONF
"/etc/rsync/rsyncd.conf":g' rsync.h.orig > rsync.h

tested here, working OK.
Comment 1 Maik Schreiber 2002-12-29 13:51:34 UTC
I've fixed that yesterday in rsync-2.5.6_pre20021105-r1.