Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 128340 - app-office/openoffice requires dev-java/sun-jdk but doesn't find it during ebuilding
Summary: app-office/openoffice requires dev-java/sun-jdk but doesn't find it during eb...
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 128341 128342 128343 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-31 23:39 UTC by Eugine V. Kosenko
Modified: 2006-04-01 04:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugine V. Kosenko 2006-03-31 23:39:43 UTC
$ emerge --info
Portage 2.0.54 (default-linux/amd64/2006.0, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.15-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.gentoo.org.ua/ http://gentoo.linux.kiev.ua/"
LANG="uk_UA.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org.ua/gentoo-portage"
USE="amd64 X alsa apache2 audiofile avi berkdb bitmap-fonts bzip2 cdr cli crypt ctype cups dba dri dvd eds emboss encode esd exif expat fam fastbuild ffmpeg foomaticdb force-cgi-redirect fortran ftp gd gdbm gif glut gnome gpm gstreamer gtk gtk2 gtkhtml idn imagemagick imlib ipv6 isdnlog java jpeg lcms ldap lua lzw lzw-tiff mad memlimit mng mozilla mp3 mpeg mysql ncurses nls nptl nvidia ogg opengl pam pcre pdflib perl png posix pppd python quicktime readline sdl session simplexml soap sockets spell spl ssl tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev usb vorbis xml xml2 xmms xpm xsl xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-03-31 23:46:59 UTC
not a portage bug
Comment 2 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-03-31 23:52:04 UTC
Need more info on what exactly the problem is.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 23:54:19 UTC
This is NOT keyworded amd64.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 23:55:58 UTC
*** Bug 128342 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 23:57:29 UTC
*** Bug 128343 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 23:58:26 UTC
*** Bug 128341 has been marked as a duplicate of this bug. ***
Comment 7 Eugine V. Kosenko 2006-04-01 00:33:42 UTC
(In reply to comment #3)
> This is NOT keyworded amd64.

Does it mean I must not report any problems on masked packages?

Certainly, I try to force OO emerging via "ebuild ... merge", but the process sequently stopped due to configuration errors in different dependent packages. I resolved the problems just for me thru manual emerging of such packages. I guessed the information would be useful for you.

Sorry.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-04-01 04:07:06 UTC
(In reply to comment #7)
> (In reply to comment #3)
> > This is NOT keyworded amd64.
> 
> Does it mean I must not report any problems on masked packages?

This is NOT masked. This is not keyworded at all, since it's known to NOT compile on amd64.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-04-01 04:25:03 UTC
Keyworded -amd64 now to make it pretty explicit that the thing will blow up in a horrible way.