Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 128337 - PerlQT-3.008-r1 fails to compile, generates "insecure RUNPATHs" QA notice
Summary: PerlQT-3.008-r1 fails to compile, generates "insecure RUNPATHs" QA notice
Status: VERIFIED DUPLICATE of bug 128331
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-31 23:11 UTC by trefoil
Modified: 2006-03-31 23:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description trefoil 2006-03-31 23:11:22 UTC
Fails to compile:

make[1]: Leaving directory `/var/tmp/portage/PerlQt-3.008-r1/work/PerlQt-3.008'
man:
gzipping man page: Qt.3pm
prepallstrip:
strip: i686-pc-linux-gnu-strip --strip-unneeded
   usr/bin/puic
   usr/lib/perl5/site_perl/5.8.7/i686-linux/auto/Qt/Qt.so
   usr/lib/libsmokeqt.so.1.2.1
making executable: /usr/lib/libsmokeqt.so.1.2.1

QA Notice: the following files contain insecure RUNPATH's
 Please file a bug about this at http://bugs.gentoo.org/
 For more information on this issue, kindly review:
 http://bugs.gentoo.org/81745
/usr/qt/3/lib:/var/tmp/portage/PerlQt-3.008-r1/image/usr/lib:/usr/lib usr/bin/puic
/var/tmp/portage/PerlQt-3.008-r1/image/usr/lib:/usr/qt/3/lib usr/lib/perl5/site_perl/5.8.7/i686-linux/auto/Qt/Qt.so
/usr/qt/3/lib:/usr/lib/gcc/i686-pc-linux-gnu/3.4.5:/var/tmp/portage/PerlQt-3.008-r1/image/usr/lib:/usr/lib usr/lib/libsmokeqt.so.1.2.1


!!! ERROR: dev-perl/PerlQt-3.008-r1 failed.
!!! Function dyn_install, Line 1057, Exitcode 0
!!! Insecure binaries detected
!!! If you need support, post the topmost build error, NOT this status message.


Emerge info as follows:

Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.5-r3, 2.6.15-gentoo-r7 i686)
=================================================================
System uname: 2.6.15-gentoo-r7 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/ http://cudlug.cudenver.edu/gentoo/ http://gentoo.mirrors.pair.com/ http://mirrors.acm.cs.rpi.edu/gentoo/ http://gentoo.cs.lewisu.edu/gentoo/ http://prometheus.cs.wmich.edu/gentoo http://mirror.usu.edu/mirrors/gentoo/ http://mirror.phy.olemiss.edu/mirror/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X a52 aac acpi alsa apm arts asf audiofile avi berkdb bitmap-fonts bzip2 cairo cdparanoia cdr cgi cli crypt css cups curl dba dri dvd dvdr dvdread eds emboss encode exif expat fam ffmpeg flac foomaticdb fortran gd gdbm gif glut gnome gpm gstreamer gtk gtk2 gtkhtml guile idn imagemagick imap imlib ipv6 isdnlog joystick jpeg kde kdeenablefinal kdexdeltas lcms libg++ libwww lua mad mikmod mjpeg mmx mmxext mng motif mozilla mp3 mpeg musicbrainz ncurses nls nptl ogg oggvorbis openal opengl oss pam pcre pdflib perl php png pppd python qt quicktime readline real sdl sid sndfile sox speex spell sqlite sse ssl tcpd tidy tiff truetype truetype-fonts type1-fonts udev usb vcd vorbis win32codecs wxwindows xine xml xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LINGUAS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 23:46:19 UTC

*** This bug has been marked as a duplicate of 128331 ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 23:46:30 UTC
CLOSED