Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 128113 - sylpheed-2.2.4 fails to compile
Summary: sylpheed-2.2.4 fails to compile
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-30 08:20 UTC by Hugo
Modified: 2006-03-30 08:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,43.32 KB, text/plain)
2006-03-30 08:24 UTC, Hugo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hugo 2006-03-30 08:20:08 UTC
Sylpheed-2.2.4 when configuring for compilation checks for gtk+ and fails, it expects >= 2.4.0, I think it should be checking for gtk+-2.0

# pkg-config --modversion gtk+
1.2.10

# pkg-config --modversion gtk+-2.0
2.8.13



The error:
checking for GTK+ - version >= 2.4.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: Test for Gtk failed. See the 'INSTALL' for help.

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/sylpheed-2.2.4/work/sylpheed-2.2.4/config.log



System Information:
# emerge --info
Portage 2.1_pre7-r2 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.15-gentoo-r1-FoBoS i586)
=================================================================
System uname: 2.6.15-gentoo-r1-FoBoS i586 AMD-K6(tm) 3D+ Processor
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i586-pc-linux-gnu"
CFLAGS="-O2 -march=k6-3 -fomit-frame-pointer -pipe"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=k6-3 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://linuv.uv.es/mirror/gentoo/ http://ftp.rz.tu-bs.de/pub/mirror/ftp.gentoo.org/gentoo/ http://ftp.romnet.org/gentoo/"
LANG="es_ES@euro"
LC_ALL="es_ES@euro"
LINGUAS="es"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow GAPING_SECURITY_HOLE X acl alsa apm avi berkdb bitmap-fonts bzip2 bzlib cdr cli crypt cscope ctype cups dba dedicated dga directfb divx4linux doc dri dvi emboss encode esd ethereal expat fam fastbuild fbcon foomaticdb force-cgi-redirect ftp gd gdbm geoip gif gimp gimpprint gpm gps gstreamer gtk gtk2 hou imap imlib input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg libg++ libwww mad maildir memlimit mmx moznocompose moznoirc moznomail mp3 mpeg msn mysql ncurses nls nowin nptl nptlonly nsplugin nvidia ogg openal opengl pam pdf pdflib png posix ppds pppd python quicktime readline sasl scanner sdl session simplexml soap sockets sou spell spl ssl startup-notification stencil-buffer svga tcpd tetex tiff tokenizer truetype truetype-fonts type1-fonts udev usb userlocales video_cards_fbdev video_cards_nvidia video_cards_vesa videos vim-pager vim-with-x vorbis xml xosd xsl xv xvid zlib elibc_glibc kernel_linux linguas_es userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LDFLAGS, MAKEOPTS
Comment 1 Samuli Suominen gentoo-dev 2006-03-30 08:22:47 UTC
Umm, could you include config.log ?

*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured.

It's in /var/tmp/portage/sylpheed..
Comment 2 Hugo 2006-03-30 08:24:02 UTC
Created attachment 83438 [details]
config.log

The file requested in the error.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-30 08:28:57 UTC
/usr/lib/libfontconfig.so.1/usr/lib/gcc/i586-pc-linux-gnu/3.4.6/../../../../i586-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/lib/libfontconfig.so.1, not found (try using -rpath or -rpath-link)
/usr/lib/libfontconfig.so.1: undefined reference to `XML_SetElementHandler'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_SetDoctypeDeclHandler'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_ParserFree'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_SetCharacterDataHandler'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_ErrorString'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_ParseBuffer'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_ParserCreate'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_SetUserData'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_GetErrorCode'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_GetBuffer'
/usr/lib/libfontconfig.so.1: undefined reference to `XML_GetCurrentLineNumber'

You need to run revdep-rebuild, see the other bug.

*** This bug has been marked as a duplicate of 128069 ***