Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 127424 - tora crashes on startup
Summary: tora crashes on startup
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Highest critical (vote)
Assignee: Tobias Scherbaum (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-24 06:13 UTC by Florian Engelhardt
Modified: 2006-03-30 05:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Engelhardt 2006-03-24 06:13:31 UTC
flo@HAL2000 ~ $ tora
terminate called after throwing an instance of 'QString'
Aborted

I tried tora-1.3.21 and tora-1.3.18, both die with the same error.

HAL2000 ~ # emerge --info
Portage 2.1_pre6-r5 (default-linux/x86/2005.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.15.4 i686)
=================================================================
System uname: 2.6.15.4 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -Os -s -fomit-frame-pointer -pipe -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -Os -s -fomit-frame-pointer -pipe -funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo "
LANG="en_GB.utf8"
LC_ALL="en_GB.utf8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm avi berkdb bitmap-fonts cairo cpudetection crypt cups dillo dri dvd eds emboss encode firefox foomaticdb fortran gdbm gif gpm gstreamer gtk gtk2 imlib ipv6 jpeg libg++ libwww mad maildir mbox mikmod mmx moznoxft mp3 mpeg ncurses nls nntp nptl nptlonly ogg oggvorbis opengl oracle pam pcrei pdflib perl png python quicktime readline samba spell sse sse2 ssl tcpd theora truetype truetype-fonts type1-fonts unicode vorbis win32codecs xml2 xv xvid zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LDFLAGS, LINGUAS
Comment 1 Florian Engelhardt 2006-03-30 04:43:28 UTC
I solved the problem myself. I had to lower my C-Flags from "-march=pentium4 -Os -s -fomit-frame-pointer -pipe" to "-march=pentium4 -O2 -pipe"

You should filter those C-Flags
Comment 2 Tobias Scherbaum (RETIRED) gentoo-dev 2006-03-30 05:43:42 UTC
I did some testing using different CFLAG combinations during the last weekend but couldn't reproduce your problem. (Besides that I don't see the benefit of adding "-s" to your CFLAGS as portage strips your binarys anyway (if you're not using USE="debug")..). As it isn't definitively proven that "-s" causes this issue I won't filter that flag, though I consider this bug fixed then.

Thanks nevertheless, Florian!