Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 127197 - zope fails on pyexpat dependency
Summary: zope fails on pyexpat dependency
Status: RESOLVED DUPLICATE of bug 114376
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: net-zope (OBSOLETE)
Depends on:
Reported: 2006-03-22 09:07 UTC by Thijs Brobbel
Modified: 2006-04-16 04:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Thijs Brobbel 2006-03-22 09:07:04 UTC
I've just encountered problems (and solved) emerging net-zope/zope. This package is depending on the lib pyexpat in <python-root>/lib-dynload/. I'm guessing this lib will get build and installed if and only if the package dev-libs/expat is installed, because my python 2.4 had it, but 2.3 didn't. Since all ARCH zope ebuilds uses python 2.3, this fails.

There's no flag for this lib and remerging python 2.3 solved the problem. My guess is that either a flag or (complex) dependency solves this problem.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-22 09:37:59 UTC
There's really nothing we could about this, I'm afraid...
Comment 2 Radoslaw Stachowiak (RETIRED) gentoo-dev 2006-04-16 04:37:25 UTC
Unfortunately we can't fix it atn. The only viable solution is to manualy install python packages with python2.3

*** This bug has been marked as a duplicate of 114376 ***