Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 126969 - mono-1.1.13.4 ebuild fails. typo in
Summary: mono-1.1.13.4 ebuild fails. typo in
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-20 08:09 UTC by Aravind Srinivasan
Modified: 2006-03-20 21:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aravind Srinivasan 2006-03-20 08:09:48 UTC
----Emerge info-------------------------------------------------- 
# emerge --info
Portage 2.1_pre6-r5 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.4-r1, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.12.0_pre16
ccache version 2.4 [disabled]
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -pipe -funroll-loops -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe -funroll-loops -fomit-frame-pointer"
DISTDIR="/usr/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.gentoo.or.kr/ http://mirror.gentoo.gr.jp http://194.149.10.102/ http://195.56.77.10/ http://gentoo.chem.wisc.edu/ http://gentoo.osuosl.org/ http://adelie.polymtl.ca/"
LC_ALL="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups dri dvd eds emboss encode foomatic foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml imlib jikes jpeg junit kde libg++ libwww mad mikmod mmx mmx2 mono mozsvg mp3 mpeg ncurses nis nls nomotif nptl nptlonly ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell sse sse2 ssl svg tcpd truetype truetype-fonts type1-fonts unicode vorbis xml2 xmms xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LDFLAGS, LINGUAS

---emerge -pv mono----------------------------------------------------------
# emerge -pv mono

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   N   ] dev-lang/mono-1.1.13.4  USE="X nptl" 0 kB


---Problem in mono ---------------------------------------------------------
# emerge mono  
...
MONO_PATH="../../class/lib/default:$MONO_PATH" /var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/runtime/mono-wrapper  ../../class/lib/default/mcs.exe /codepage:28591   -d:NET_1_1 -d:ONLY_1_1 -debug /noconfig -nowarn:649 -nowarn:169 -nowarn:219 -nowarn:168 -nowarn:1595 -unsafe -r:mscorlib.dll -r:../../class/lib/default/System.dll -r:System.Xml.dll  -r:System.EnterpriseServices.dll -r:Mono.Data.Tds.dll  -target:library -out:../../class/lib/default/System.Data.dll Mono.Data.SqlExpressions/Parser.cs @System.Data.dll.sources
Mono.Data.SqlExpressions/Parser.cs(285,5): warning CS0162: Unreachable code detected
System.Data/MergeManager.cs(157,8): error CS0103: The name `missingScheoaAction' does not exist in the context of `System.Data.MergeManager'Compilation failed: 1 error(s), 1 warnings
make[8]: *** [../../class/lib/default/System.Data.dll] Error 1
make[8]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs/class/System.Data'
make[7]: *** [do-all] Error 2
make[7]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs/class/System.Data'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs/class'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs'
make[4]: *** [profile-do--default--all] Error 2
make[4]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs'
make[3]: *** [profiles-do--all] Error 2
make[3]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs'
make[2]: *** [all-local] Error 2
make[2]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/runtime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4'
make: *** [all] Error 2

!!! ERROR: dev-lang/mono-1.1.13.4 failed.
Call stack:
  ebuild.sh, line 1565:   Called dyn_compile
  ebuild.sh, line 974:   Called src_compile

!!! MONO compilation failure
!!! If you need support, post the topmost build error, and the call stack if relevant.

---- Quick fix -----------------------------------------------------
After the failure 
#cd /var/tmp/portage/mono-1.1.13.4/work/mono-1.1.13.4/mcs/class/System.Data
edit System.Data/MergeManager.cs 
in line 157 change missingScheoaAction to missingSchemaAction

then do
# ebuild $PORTAGE_DIR/dev-lang/mono/mono-1.1.13.4.ebuild compile install qmerge
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2006-03-20 08:56:05 UTC
That typo definitely did not exist here in my tarball. Did you get a corrupt tarball, then just do ebuild mono-1.1.13.4.ebuild digest to fix it? Can you please remove your mono-1.1.13.4.tar.gz from /usr/portage/distfiles and try again? Thanks.
Comment 2 Aravind Srinivasan 2006-03-20 21:32:06 UTC
removed the tar and emerged as suggested. Works fine. Something wrong at my end.

Weird !! Haven't touched the portage since last time. So if the tar was corrupt emerge should have caught it :( 

Comment 3 Aravind Srinivasan 2006-03-20 21:33:48 UTC
Closing.