Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 126597 - trickle-1.06 +gcc-4.1.0
Summary: trickle-1.06 +gcc-4.1.0
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Please assign to toolchain
Depends on:
Reported: 2006-03-17 14:14 UTC by Matteo Azzali (RETIRED)
Modified: 2006-04-25 09:49 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

trickle-1.06-r1.ebuild (trickle-1.06-r1.ebuild,764 bytes, text/plain)
2006-04-03 07:42 UTC, Rumen Yotov
trickle-1.06-linux-fix.patch (trickle-1.06-linux-fix.patch,1.95 KB, patch)
2006-04-03 07:44 UTC, Rumen Yotov
Details | Diff (,1.46 KB, patch)
2006-04-11 19:56 UTC, Alexandre Rostovtsev (RETIRED)
Details | Diff
another trickle-1.06-r1.ebuild (for the patch) (trickle-1.06-r1.ebuild,739 bytes, text/plain)
2006-04-11 19:57 UTC, Alexandre Rostovtsev (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Azzali (RETIRED) gentoo-dev 2006-03-17 14:14:53 UTC
In file included from trickled.c:33:
/usr/include/netinet/in.h:136: error: two or more data types in declaration specifiers
/usr/include/netinet/in.h:136: error: two or more data types in declaration specifiers
make: *** [trickled.o] Error 1 

Emerge info:
Portage 2.1_pre6-r3 (default-linux/x86/2005.0, gcc-4.1.0, glibc-2.4-r1, 2.6.15-gentoo-r7 i686)
System uname: 2.6.15-gentoo-r7 i686 AMD Sempron(tm) Processor 3100+
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
USE="x86 3dnow 3dnowex 3dnowext X aalib acl acpi acpi4linux alsa apm audiofile avi berkdb bitmap-fonts bzip2 crypt cups curl divx4linux dri dts dvb dvd dvdr dvdread eds emboss encode esd exif expat ffmpeg flac foomaticdb fortran gdbm gif gimp glut gnome gphoto2 gpm gstreamer gtk gtk2 guile hal idn imagemagick imlib java joystick jpeg kde lcms libg++ libwww lirc live lm_sensors mad matroska mikmod mmx mmx2 mmxext mng motif mp3 mpeg ncurses nls nptl nptlonly nsplugin nvidia offensive ogg oggvorbis ogre opengl oss pam pcre pdflib perl png python qt quicktime readline real scanner sdl spell sse sse-filters sse2 ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vorbis win32codecs wxgtk1 xcomposite xine xml2 xmms xscreensaver xv xvid xvmc zlib zvbi elibc_glibc input_devices_mouse input_devices_keyboard input_devices_wacom kernel_linux linguas_it userland_GNU video_cards_nvidia video_cards_nv video_cards_vesa video_cards_vga"
Comment 1 Mark Loeser (RETIRED) gentoo-dev 2006-03-19 11:41:37 UTC
This package seems somewhat unmaintained.

Going out on a limb here...would anyone in netmon be interested in maintaining this?  

It looks like the configure script needs to be reworked, and I'd like to know it is going to be maintained if I try to fix it :)  Otherwise I say we mask it.  upstream hasn't put out a release since 2003.
Comment 2 Mark Loeser (RETIRED) gentoo-dev 2006-03-29 21:43:06 UTC
Masked, and sent out the email to g-dev.  I'll be removing it in 30 days.
Comment 3 Colin Macdonald 2006-03-29 22:02:17 UTC
I found trickle useful to throttle programs sometimes...  But not useful enough that I'd want to maintain it!  Anyway, just thought I'd point out that at least one person uses it (if that has any bearing on whether or not it stays or goes).
Comment 4 Rumen Yotov 2006-04-03 07:40:36 UTC
Got interested (reading a post recommneding it on 'gentoo-user IIRC) and tried it.
Same error messages, then just edited some source file (4-5) and it compiled ;)
If anyone interested will attach revised ebuild & patch (which compile). GCC-4.0.3
Later will try running/working-with it and report any new findings.
PS: next attaching ebuild+patch
Comment 5 Rumen Yotov 2006-04-03 07:42:50 UTC
Created attachment 83813 [details]
Comment 6 Rumen Yotov 2006-04-03 07:44:03 UTC
Created attachment 83814 [details, diff]
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2006-04-11 18:37:40 UTC
Rumen: your patch is brutish, linux-specific (Gentoo runs on fbsd and osx nowadays), and misses the point. The source of the problem is that trickle's assumes that in_addr_t is not defined in netinet/in.h; and fixing the configure script is slightly non-trivial because it uses obsolete autoconf 2.13 syntax.

I think I might have a go at modernizing the
Comment 8 Alexandre Rostovtsev (RETIRED) gentoo-dev 2006-04-11 19:56:20 UTC
Created attachment 84479 [details, diff]
Comment 9 Alexandre Rostovtsev (RETIRED) gentoo-dev 2006-04-11 19:57:57 UTC
Created attachment 84480 [details]
another trickle-1.06-r1.ebuild (for the patch)

This works with the above patch; installs fine on my system, and ought to be portable.
Comment 10 Alexandre Rostovtsev (RETIRED) gentoo-dev 2006-04-11 20:05:30 UTC
Please please don't remove trickle!

I am on a slow DSL line which I share with a bunch of housemates. I use trickle all the time when I am downloading large files, otherwise no-one else in the house has net access. I am sure there are other people in the same situation.

If no Gentoo dev wants to maintain an autoconf script from 2003, I am completely willing to keep on patching it. Is there anything one can do so that trickle would not get removed from the tree?
Comment 11 Amith Varghese 2006-04-23 10:21:12 UTC
Please leave trickle in portage unless another package can be identified that replaces trickle's functionality.

Comment 12 Colin Macdonald 2006-04-23 11:02:03 UTC
There seems to be a 1.07 release not mentioned on the homepage but is in debian.  Perhaps they have already fixed our problem:
Comment 13 Rumen Yotov 2006-04-25 09:49:44 UTC
Completely agree with Alex, comment#7 but i just wanted to show that the problem is minor (even my hackish/brutal way made it compile). Thanks Alex.
Beside this want to report that trickle-1.06-r1 compiles OK on hardened Gentoo.
Another one, just downloaded 1.07 from Debian, here's an URL to get 1.07: (IIRC this is it's homepage)
PS: net-misc/trickle still masked, being unmaintained
PS:# Has not had a release in almost 3 years, and is unmaintained; see bug #126597