Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 126014 - sys-apps/pam-login (is blocking sys-apps/shadow-4.0.14-r2)
Summary: sys-apps/pam-login (is blocking sys-apps/shadow-4.0.14-r2)
Status: RESOLVED DUPLICATE of bug 79606
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: PAM Gentoo Team (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 126290 126610 128276 134958 135022 135025 135059 135170 135240 135299 135311 135334 135335 140741 141011 144039 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-12 20:56 UTC by Jean-Francois Chevrette
Modified: 2006-08-15 13:52 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Chevrette 2006-03-12 20:56:15 UTC
Synched today and updating world gives me this block:

sys-apps/pam-login (is blocking sys-apps/shadow-4.0.14-r2)

Seems like sys-apps/pam-login depends on sys-apps/shadow, but the later blocks sys-apps/pam-login

-- sys-apps/pam-login-4.0.14.ebuild --
DEPEND="virtual/libc
    sys-libs/pam
    >=sys-apps/shadow-4.0.11.1-r1
    skey? ( app-admin/skey )
    selinux? ( sys-libs/libselinux )"
--

-- sys-apps/shadow-4.0.14-r2.ebuild --
RDEPEND=">=sys-libs/cracklib-2.7-r3
    pam? ( virtual/pam )
    !sys-apps/pam-login
    skey? ( app-admin/skey )
    selinux? ( >=sys-libs/libselinux-1.28 )
    nls? ( virtual/libintl )"
--
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-03-12 23:52:55 UTC
No, pam-login is now merged back into shadow package, so just unmerge pam-login and then update shadow.
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-03-13 01:55:10 UTC

*** This bug has been marked as a duplicate of 79606 ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-15 05:00:23 UTC
*** Bug 126290 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-03-17 17:35:08 UTC
*** Bug 126610 has been marked as a duplicate of this bug. ***
Comment 5 Vladimir G. Ivanovic 2006-03-17 17:57:02 UTC
(In reply to comment #1)
> No, pam-login is now merged back into shadow package, so just unmerge pam-login
> and then update shadow.
> 

This worked for me.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 10:16:55 UTC
*** Bug 128276 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-05-30 14:00:34 UTC
*** Bug 134958 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 03:42:06 UTC
*** Bug 135022 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 04:26:01 UTC
*** Bug 135025 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 10:27:38 UTC
*** Bug 135059 has been marked as a duplicate of this bug. ***
Comment 11 Alon Bar-Lev gentoo-dev 2006-06-01 00:20:30 UTC
Shouldn't there be a away to inform users about that kind of changes?
For example have pam-login-9999 that does not install anything but only print a message to the user to unmerge pam-login since the shadow package replaces it?
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-06-01 08:24:02 UTC
*** Bug 135170 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2006-06-02 02:19:00 UTC
*** Bug 135240 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2006-06-02 11:16:27 UTC
*** Bug 135299 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2006-06-02 12:29:42 UTC
*** Bug 135311 has been marked as a duplicate of this bug. ***
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2006-06-03 00:03:45 UTC
*** Bug 135335 has been marked as a duplicate of this bug. ***
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2006-06-03 00:04:30 UTC
*** Bug 135334 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 02:00:43 UTC
*** Bug 140741 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2006-07-19 01:15:51 UTC
*** Bug 141011 has been marked as a duplicate of this bug. ***
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-08-15 13:52:12 UTC
*** Bug 144039 has been marked as a duplicate of this bug. ***