Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 125912 - glibc 2.4 does not build with gcc 3.3.6
Summary: glibc 2.4 does not build with gcc 3.3.6
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 130294 146814 147188 147740 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-12 03:25 UTC by Tobias Klausmann
Modified: 2006-09-15 15:35 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
glibc build log (glibc.log,17.02 KB, text/plain)
2006-03-12 03:26 UTC, Tobias Klausmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann gentoo-dev 2006-03-12 03:25:14 UTC
I tried to update to glibc 2.4 but glibc refuses to compile with:

checking for sed... sed
checking version of sed... 4.1.4, ok
checking for autoconf... autoconf
checking whether autoconf works... yes
configure: error:
*** These critical programs are missing or too old: gcc
*** Check the INSTALL file for required versions.

!!! ERROR: sys-libs/glibc-2.4 failed.
Call stack:
  ebuild.sh, line 1557:   Called dyn_compile
  ebuild.sh, line 966:   Called src_compile
  glibc-2.4.ebuild, line 1259:   Called toolchain-glibc_src_compile
  glibc-2.4.ebuild, line 257:   Called glibc_do_configure 'nptl'

!!! failed to configure glibc
!!! If you need support, post the topmost build error, and the call stack if relevant.

emerge info:
# emerge --info
Portage 2.1_pre6 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.6-r3, 2.6.15 i686)
=================================================================
System uname: 2.6.15 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig digest distlocks metadata-transfer sandbox sfperms strict userpriv"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://gentoo.mirror.solnet.ch"
LANG="en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync5.de.gentoo.org/gentoo-portage"
USE="x86 3dnow acl acpi alsa apache2 apm avi bash-completion bcmath berkdb bitmap-fonts bzip2 caps claendar clamav crypt cscope cups curl dio dri emboss en
code ethereal exif foomaticdb fortran ftp gd gdbm gif gmp gnutls gpm gstreamer gtk gtk2 imagemagick imap imlib jabber jpeg kdeenablefinal libg++ libwww mad maildir mbox mikmod mmap mmx mng mp3 mpeg mpi mysql mysqli ncurses nls nptl nptlonly offensive ogg oggvorbis opengl oss pam pcre pdflib perl php png posix python qt quicktime readline recide sasl sdl sockets spell sse ssl svg tcpd truetype truetype-fonts type1-fonts unicode vhosts vorbis xml2 xmms xv zlib elibc_glibc kernel_linux userland_GNU"                                                                                                                       Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Tobias Klausmann gentoo-dev 2006-03-12 03:26:20 UTC
Created attachment 81966 [details]
glibc build log

Created with emerge -u glibc | tee glibc.log
Comment 2 Tobias Klausmann gentoo-dev 2006-03-12 03:31:08 UTC
Oh, nevermind me, I just found out that I *do* have the choice of using gcc 3.4.

Sorry for the buzz.
Comment 3 Tobias Klausmann gentoo-dev 2006-03-12 03:31:38 UTC
Closing.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-03-12 03:33:24 UTC
glibc-2.4 now depends on >=sys-devel/gcc-3.4.4
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-04-17 13:22:11 UTC
*** Bug 130294 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-09-08 03:01:16 UTC
*** Bug 146814 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-09-11 07:20:28 UTC
*** Bug 147188 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-09-15 15:35:42 UTC
*** Bug 147740 has been marked as a duplicate of this bug. ***