Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 125791 - Insecure RPATH: dev-ruby/ruby-gtk2-0.14.1
Summary: Insecure RPATH: dev-ruby/ruby-gtk2-0.14.1
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Runpath Issues (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Ruby Team
Depends on:
Blocks: 81745
  Show dependency tree
Reported: 2006-03-10 22:39 UTC by Craig Andrews
Modified: 2006-10-01 18:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Craig Andrews gentoo-dev 2006-03-10 22:39:15 UTC
Merging dev-ruby/ruby-gtk2-0.14.1 failed with the following:
QA Notice: the following files contain insecure RUNPATH's
 Please file a bug about this at
 For more information on this issue, kindly review:
/var/tmp/portage/ruby-gtk2-0.14.1/image//usr/lib usr/lib/ruby/site_ruby/1.8/i686-linux/

!!! ERROR: dev-ruby/ruby-gtk2-0.14.1 failed.
Call stack:, line 1933:   Called dyn_install

!!! Aborting due to serious QA concerns with RUNPATH/RPATH
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-09-21 03:52:10 UTC
No longer a security issue with current stable portage (see Bug 124962), re-assigning to maintainer.
Comment 2 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2006-09-30 12:16:56 UTC
I can't reproduce this. Could you please post your 'emerge --info' along with version numbers of ruby and rubygems?
Comment 3 Craig Andrews gentoo-dev 2006-10-01 18:59:40 UTC
I haven't tried to emerge this package again until now, and now it works. I have no idea what changed, or what fixed it, but this error no longer occurs.

Thanks bug trackers for looking into this, though.