Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 125402 - Pluging audio jack doesn't mute HP sound on ICH7/Intel HDA (82801G)
Summary: Pluging audio jack doesn't mute HP sound on ICH7/Intel HDA (82801G)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-07 14:07 UTC by Vince C.
Modified: 2006-04-22 05:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince C. 2006-03-07 14:07:40 UTC
Hi.

I've installed Gentoo Linux using Live CD 2005.1 on a Dell Inspiron 9400. The latter has an Intel ICH7-M chipset with Intel High-Definition Audio. When I plug my headphones jack into line output the sound from the PC's speakers doesn't mute. I'm using kernel built-in alsa driver module, snd-hda-intel.

lspci: 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

Kernel sources:
[I--] [  ] sys-kernel/gentoo-sources-2.6.15-r7 (2.6.15-r7)

ALSA Packages:
[I--] [  ] media-libs/alsa-lib-1.0.10 (0)
[I--] [  ] media-libs/alsa-oss-1.0.10-r1 (0)
[I--] [  ] media-sound/alsa-headers-1.0.10 (0)
[I--] [  ] media-sound/alsa-utils-1.0.10 (0.9)

If I boot into Windows the problem doesn't happen, i.e. the sound from the PC's HP is muted as soon as I plug the jack in. So it must be a driver problem.

Thanks.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-04-18 11:17:53 UTC
Please try to reproduce with alsa-driver 1.0.11_rc5 and if it's still an issue reopen this bug.
Comment 2 Vince C. 2006-04-22 05:27:15 UTC
Looks like it works for me :-) . Thanks.

Now there is still a problem with the microphone - I haven't tested it with the new release of Alsa Driver. The problem is exhibited when using Skype, for instance; I speak but the other person doesn't hear anything. Should I file a new bug report about that if it doesn't work? Or is this new release a complete solution?

BTW will this release be included in a (vanilla, gentoo) kernel tree? If yes with what kernel version?