Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 125364 - media-video/mplayer: Win32 LoadLibrary failed to load: avisynth.dll
Summary: media-video/mplayer: Win32 LoadLibrary failed to load: avisynth.dll
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-07 07:51 UTC by Martin Mokrejš
Modified: 2006-05-22 15:42 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2006-03-07 07:51:31 UTC
$ mplayer 8621.wmv 
MPlayer dev-CVS-060302-15:36-3.4.5 (C) 2000-2006 MPlayer Team
CPU: Intel Pentium 4/Celeron 4 Northwood; Pentium 4 EE/Xeon Prestonia,Gallatin (Family: 15, Stepping: 7)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.


91 audio & 206 video codecs
Playing 8621.wmv.
Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll

[...]

The file is really missing in /usr/lib/win32/. :(
Comment 1 Luca Barbato gentoo-dev 2006-03-07 14:45:11 UTC
Grr, it's just a file used on win32, so the warning has to be ignored, sorry for the misunderstatement.
Comment 2 Martin Mokrejš 2006-03-08 06:43:32 UTC
But mplayer exits, can you try to download and play this public film trailer from Czech Television?
http://www.ceskatelevize.cz/specialy/jedensvet/index.php?spotid=8621
Comment 3 Sebastian Siewior 2006-03-14 09:35:51 UTC
The problems 64bit specific. I merged

media-libs/win32codecs-20050412
media-video/mplayer-bin-1.0.20060217

for watching crappy wmv files on amd64. win32codes puts files in 
/usr/lib32/[real|win32/ what is correct. mplayer-bin is looking for them in
/usr/lib what points to lib64. 

A workaround might be:

# ln -sv /usr/lib32/win32/ /usr/lib
create symbolic link `/usr/lib/win32' to `/usr/lib32/win32/'
#

Please recompile mplayer-bin with correct path info.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-03-14 10:48:46 UTC
Difficult to be 64-bit specific as the first was run with "mplayer" and not "mplayer-bin".
Please open a different bug if mplayer-bin is having trouble.
Comment 5 Stefano 2006-03-18 05:32:45 UTC
Cough, I have the same issue on a 32-bit system, and that file is nowhere to be found, so it's probably missing at all from the win32codecs package...
Comment 6 Luca Barbato gentoo-dev 2006-03-19 02:32:01 UTC
To restate:

this message is due the fact on file unknown mplayer tries every possible codec, doesn't matter how silly is the guess. This message appears since one of the tests involves this dll that is _correctly_ missing.

If there are problems with files please upload on the upstream ftp and then ping me or upstream about testing them.

May I close this bug?
Comment 7 Martin Mokrejš 2006-03-22 04:48:49 UTC
Well, close it but first tell me how to get mplayer play the wmv files again, i.e. how should I get win32codecs realplayer installed right. ;-)
Comment 8 Luca Barbato gentoo-dev 2006-03-22 13:22:53 UTC
get me a sample and check the binary codecs are in the right places if you are on 32bit or please open another bug if it is related to amd64 mplayer-bin
Comment 9 Martin Mokrejš 2006-03-22 14:29:57 UTC
Get the sample from comment #2.

$ wget http://stream3b.visual.cz/ct/ukazky/jedensvet/8621.wmv
--23:28:32--  http://stream3b.visual.cz/ct/ukazky/jedensvet/8621.wmv
           => `8621.wmv'
Resolving stream3b.visual.cz... 212.67.79.17
Connecting to stream3b.visual.cz|212.67.79.17|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 158 [video/x-ms-wvx]

100%[=================================================================================>] 158           --.--K/s             

23:28:32 (6.85 MB/s) - `8621.wmv' saved [158/158]

mokrejs@vrapenec$ mplayer 8621.wmv 
MPlayer dev-CVS-060302-15:36-3.4.5 (C) 2000-2006 MPlayer Team
CPU: Intel Pentium 4/Celeron 4 Northwood; Pentium 4 EE/Xeon Prestonia,Gallatin (Family: 15, Stepping: 7)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.


91 audio & 206 video codecs
Playing 8621.wmv.
Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
XMMS: found plugin: libxmms-flac.so (Reference FLAC Player v1.1.2)
XMMS: found plugin: libmikmod.so (MikMod Player 1.2.10)
XMMS: found plugin: libvorbis.so (Ogg Vorbis Player 1.2.10)
XMMS: found plugin: libxmmsmad.so (MAD MPEG Decoder plugin 0.8)
XMMS: found plugin: libmpg123.so (MPEG Layer 1/2/3 Player 1.2.10)
XMMS: Closing plugin /usr/lib/xmms/Input/libmpg123.so
XMMS: Closing plugin /usr/lib/xmms/Input/libxmmsmad.so
XMMS: Closing plugin /usr/lib/xmms/Input/libvorbis.so
XMMS: Closing plugin /usr/lib/xmms/Input/libmikmod.so
XMMS: Closing plugin /usr/lib/xmms/Input/libxmms-flac.so


Exiting... (End of file)
$
Comment 10 Martin 2006-03-28 06:29:15 UTC
First of all, the stream seems to have moved. I could not download and so could not test anything.

Second: There *is* a solution to the avisynth.dll, but I could not find any within Gentoo. By googling I found the "Avisynth rev. 2" project on www.sourceforge.net. In the "Files section" of version 2.0.5 you can find a "avisynth_205_dll.zip". Seems to be somewhat outdated, I know.

Copying the dll from the .zip-File to /usr/lib/win32/ I solved the dependancy.
The error "avisynth could not be loaded" vanished, BUT my own videos could not be played anyway. (This may be an issue of my videos. As I said earlier, I could not test the Czech television any more.)

In http://www.ureader.de/message/1621446.aspx (German, I'm sorry) someone states, that he assumes incorrect handling of MPEG2-transport-streams in 1.0pre7try2. So he suggests using 1.0pre5.
Comment 11 Luca Barbato gentoo-dev 2006-03-31 03:02:46 UTC
about comment 10:
 Martin could you please read my reply? This isn't the problem

about comment 9
 VIDEO:  [WMV3]  320x240  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: Ztracen
Comment 12 Luca Barbato gentoo-dev 2006-03-31 03:02:46 UTC
about comment 10:
 Martin could you please read my reply? This isn't the problem

about comment 9
 VIDEO:  [WMV3]  320x240  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: Ztracené di
 author: Oliver Stoltz, Ali Samandi Ahadi
 copyright:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 1 ch, s16le, 48.0 kbit/6.81% (ratio: 6003->88200)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
==========================================================================
Requested video codec family [wmv9dmo] (vfm=dmo) not available.
Enable it at compilation.
Requested video codec family [wmvdmo] (vfm=dmo) not available.
Enable it at compilation.
Cannot find codec matching selected -vo and video format 0x33564D57.
Read DOCS/HTML/en/codecs.html!


Works as should. (using the latest snapshot in portage at least)
Comment 13 t35t0r 2006-05-19 23:59:58 UTC
I'm running media-video/mplayer-1.0.20060415 and I get this error when trying to play this Elephan Dream movie that's been getting alot of publicity lately:

http://public.www.planetmirror.com/pub/blender/ED/ED_1024.avi
Comment 14 t35t0r 2006-05-20 00:01:24 UTC
oops, sorry it only happens if I try to stream it, not if i download it.
Comment 15 Luca Barbato gentoo-dev 2006-05-22 15:41:13 UTC
Please DO NOT OPEN THIS BUG again, read the comments and if the issue is another one, please fill another one.
Comment 16 Luca Barbato gentoo-dev 2006-05-22 15:42:12 UTC
Verified that is just a cosmetic lure causing lot's of people fill false positives and ill diagnosed bug here.