Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 124851 - quodlibet 0.19 version bump request
Summary: quodlibet 0.19 version bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: InVCS
: 128483 (view as bug list)
Depends on: 128482
Blocks:
  Show dependency tree
 
Reported: 2006-03-03 12:41 UTC by Andrew D. Keyser (aka Legoguy)
Modified: 2006-04-02 18:39 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed ebuild for quodlibet-0.18 (quodlibet-0.18.ebuild,1.56 KB, text/plain)
2006-03-18 11:38 UTC, Kai Huuhko
Details
Proposed ebuild for quodlibet-0.18, checked with repoman (quodlibet-0.18.ebuild,1.58 KB, text/plain)
2006-03-18 12:55 UTC, Kai Huuhko
Details
Proposed ebuild for quodlibet-0.18 (quodlibet-0.18.ebuild,1.58 KB, text/plain)
2006-03-20 10:59 UTC, Kai Huuhko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew D. Keyser (aka Legoguy) 2006-03-03 12:41:58 UTC
New version of quodlibet is out.
Comment 1 Luis Medinas (RETIRED) gentoo-dev 2006-03-03 19:19:36 UTC
Yes we noticed but looks like this version only uses gst 0.10... can you test it a bit and report any issues to us ?
Comment 2 Andrew D. Keyser (aka Legoguy) 2006-03-03 19:41:03 UTC
Yes, I bumped the ebuild, but note that it now needs gst-plugins-good  (maybe gst-plugins-bad|ugly too) and it works fine. Still gives sandbox error (see the other bug #124852 comment #2 for a patch against 0.18).

Comment 3 Milosz Kosobucki 2006-03-04 00:34:45 UTC
I got it running with bumped version from bugzilla 0.17.1 ebuild. Program works fine but it shows following error while starting:

Handled formats: flac, mp3, mpc, oggvorbis
Media library loaded.
Opening audio device.
ERROR (0x81a3af0 - 0:00:00.462520000)         GST_PIPELINE(16945) ./grammar.y(578):_gst_parse__yyparse: no element "gconfaudiosink"
ERROR (0x81a3af0 - 0:00:00.472202000)         GST_PIPELINE(16945) ./grammar.y(837):_gst_parse_launch: Unrecoverable syntax error while parsing pipeline gconfaudiosink

-----------------------
Text in english may differ because i have polish locales and I had to translate them.
Comment 4 Fabian Neumann 2006-03-04 04:46:22 UTC
(In reply to comment #3)
> I got it running with bumped version from bugzilla 0.17.1 ebuild. Program works
> fine but it shows following error while starting:
> 
> Handled formats: flac, mp3, mpc, oggvorbis
> Media library loaded.
> Opening audio device.
> ERROR (0x81a3af0 - 0:00:00.462520000)         GST_PIPELINE(16945)
> ./grammar.y(578):_gst_parse__yyparse: no element "gconfaudiosink"
> ERROR (0x81a3af0 - 0:00:00.472202000)         GST_PIPELINE(16945)
> ./grammar.y(837):_gst_parse_launch: Unrecoverable syntax error while parsing
> pipeline gconfaudiosink

I killed this error msg by emerging gst-plugins-alsa-0.10.3.

But I got a different problem: QL doesn't recognize my music library anymore. It loads fine, but all playlists are empty, no songs can be found or added and after closing the app, it resets my old ~/.quodlibet/songs :(
Comment 5 Fabian Neumann 2006-03-04 05:46:30 UTC
(In reply to comment #4)
> But I got a different problem: QL doesn't recognize my music library anymore.
> It loads fine, but all playlists are empty, no songs can be found or added and
> after closing the app, it resets my old ~/.quodlibet/songs :(

OK, solved this. Forgot to update gst-plugins-[mad|ogg|vorbis] to 0.10.*. 

Comment 6 Daniel Schobel 2006-03-04 19:17:03 UTC
I'm getting: 

Opening audio device.
ERROR (0x819bfb0 - 0:00:00.111056000)         GST_PIPELINE(21647) ./grammar.y(578):_gst_parse__yyparse: no element "gconfaudiosink"
ERROR (0x819bfb0 - 0:00:00.111359000)         GST_PIPELINE(21647) ./grammar.y(837):_gst_parse_launch: Unrecoverable syntax error while parsing pipeline gconfaudiosink

as Fabian did but an emerge (and then re-emerge) of gst-plugins-alsa-0.10.3 did not resolve the problem as it did for him.
Comment 7 Dimas 2006-03-07 10:58:46 UTC
Just an observation about "quodlibet-0.17.1-r2.ebuild": by requiring ">=dev-python/gst-python-0.8.2", and that being unstable, users end up putting "dev-python/gst-python ~x86" in their "package.keywords" file, resulting in "dev-python/gst-python-0.10.2", "media-libs/gst-plugins-base-0.10.3", and "media-libs/gstreamer-0.10.3", instead of their 0.8.* versions.

But I thing this is not going to be a problem with quodlibet 0.18. At least until we get new gstreamer versions, like 0.12... 
Comment 8 Thomas Cort (RETIRED) gentoo-dev 2006-03-07 16:47:53 UTC
I worked on a quodlibet-0.18 ebuild and ran into some problems. The two main problems were the dependencies and build system. Can someone post an exact list of dependencies, or verify what I have? Many different places have different package versions. For instance, the website says PyGSt >=0.10.2, check.py says PyGSt >=0.10.1, and the README says PyGSt >=0.10. Based on everything I read here is what I came up with for DEPEND...

DEPEND=">=virtual/python-2.3
        >=dev-python/pygtk-2.8
        >=media-libs/gstreamer-0.10.3
        >=dev-python/gst-python-0.10.2
        mad? ( dev-python/pymad
        >=media-plugins/gst-plugins-mad-0.10.2 )
        vorbis? ( dev-python/pyvorbis
        >=media-plugins/gst-plugins-vorbis-0.10.3
        >=media-plugins/gst-plugins-ogg-0.10.3 )
        flac? ( dev-python/ctypes
        >=media-plugins/gst-plugins-flac-0.10.2 )
        aac? ( dev-python/ctypes
        media-libs/libmp4v2
        >=media-plugins/gst-plugins-faad-0.10.0 )
        musepack? ( dev-python/ctypes
        >=media-libs/libmpcdec
        >=media-plugins/gst-plugins-musepack-0.10.0 )
        alsa? ( >=media-plugins/gst-plugins-alsa-0.10.3 )
        oss? ( >=media-plugins/gst-plugins-oss-0.10.2 )
        esd? ( >=media-plugins/gst-plugins-esd-0.10.2 )
        gnome? ( dev-python/gnome-python-extras
        >=media-plugins/gst-plugins-gnomevfs-0.10.3
        dev-python/feedparser )"

I would also like to know how to get AAC support to build/work. I have all of the required deps AFAIK plus ctypes, libmp4v2 and gst-plugins-faad. Any hints?

I too get this error when starting quodlibet-0.18...

ERROR (0x81a3af0 - 0:00:00.462520000)         GST_PIPELINE(16945)
./grammar.y(578):_gst_parse__yyparse: no element "gconfaudiosink"
ERROR (0x81a3af0 - 0:00:00.472202000)         GST_PIPELINE(16945)
./grammar.y(837):_gst_parse_launch: Unrecoverable syntax error while parsing
pipeline gconfaudiosink

I'm using oss, so emerge'ing gst-plugins-alsa-0.10.3 won't help. I'm also experiencing some bugs. Hopefully that is just because I don't have the proper DEPENDs.

When I click the [X] in the upper right corner of the window to close the program the GUI vanishes, but the program continues. Using File->Quit or Ctrl+Q solves this problem, but requires typing/more clicking. BTW, I'm using fluxbox if that matters.

Sometimes when I move the slider to skip to certain parts of an MP3 the slider jumps back and the music stops, but the time keeps advancing. Hitting play repeatedly doesn't fix it. The only way to fix it is to change songs.

topcat ~ # emerge --info

Portage 2.1_pre5-r4 (default-linux/alpha/no-nptl/2.4, gcc-3.4.4, glibc-2.3.5-r3, 2.4.32 alpha)
=================================================================
System uname: 2.4.32 alpha EV56
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.4.26-r1
ACCEPT_KEYWORDS="alpha ~alpha"
AUTOCLEAN="yes"
CBUILD="alpha-unknown-linux-gnu"
CFLAGS="-mieee -pipe -O2 -mcpu=ev56"
CHOST="alpha-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mieee -pipe -O2 -mcpu=ev56"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig collision-protect distlocks maketest sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.seren.com/gentoo http://gentoo.chem.wisc.edu/gentoo/ http://cudlug.cudenver.edu/gentoo/ http://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.netnitco.net http://mirror.espri.arizona.edu/gentoo/ http://mirrors.acm.cs.rpi.edu/gentoo/ http://gentoo.arcticnetwork.ca/ http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.llarian.net/ http://gentoo.binarycompass.org http://gentoo.mirrored.ca/ http://mirror.datapipe.net/gentoo http://gentoo.cs.lewisu.edu/gentoo/ http://prometheus.cs.wmich.edu/gentoo http://modzer0.cs.uaf.edu/public/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ http://mirror.phy.olemiss.edu/mirror/gentoo http://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.clarkson.edu/pub/distributions/gentoo/ http://cdot.senecac.on.ca/software/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="alpha X aac aalib aim alsa apache2 artworkextra async audacious audiofile bash-completion berkdb binfilter bitmap-fonts bittorrent bl bonjour c++ cairo calendar cdinstall cdparanoia cdr cdrom chroot cli config_wizard cracklib crypt cscope csv ctype cups curl curlwrappers cvs cvsgraph dhcp dillo editor eds elf encode epiphany escreen esd ethereal extraicons extras ffmpeg fftw figlet firefox flac ftp gdb gdbm gif glep gnome gnutls gpm grammar gsl gstreamer gtalk gtk gtk2 gtkspell gvim gzip html icq id3 imlib ipod ipv6 jabber javascript jpeg justify ladspa lame libg++ libsexy libwww lite lj logrotate lua mad mapeditor md5sum mikmod motif moznoirc moznomail moznoroaming mozsha1 mp3 mpeg mpeg2 mplayer msn msnextras music ncurses net nethack nls offensive ogg oggvorbis opengl openssh openssl oscar oss pam pdflib perl png python quicktime quotes readline real recode reiserfs scp screen sdl sftp skins sndfile sockets sounds sox speech spell ssl subversion symlink syslog tcpd threads truetype truetype-fonts type1-fonts udev userlocales vcd videos vim vim-with-x vorbis wma wma123 xml xml2 xmlreader xmms xv xvid yahoo zip zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 9 Andrew D. Keyser (aka Legoguy) 2006-03-07 17:12:13 UTC
"When I click the [X] in the upper right corner of the window to close the
program the GUI vanishes, but the program continues. Using File->Quit or Ctrl+Q
solves this problem, but requires typing/more clicking. BTW, I'm using fluxbox
if that matters."

Check your tray. It leaves an icon running there. That's about the only problem I have an answer for; try re-merging all of the gst-* things, because at first I had a problem with the sound too, but then I upgraded some gst- packages (don't remember which ones, they were part of a world update) and it was fixed.

Make sure the "pipeline = " line in your ~/.quodlibet/config is "pipeline = osssink" if you're using oss. Ideally, you should switch to ALSA, but that's not what this bug was intended to address..
Comment 10 Thomas Cort (RETIRED) gentoo-dev 2006-03-07 18:14:42 UTC
(In reply to comment #9)
> Check your tray. It leaves an icon running there.
Yes, there is an icon in the tray that I can click on to get the GUI back. Thanks for pointing that out, I must have missed it.

> Make sure the "pipeline = " line in your ~/.quodlibet/config is "pipeline =
> osssink" if you're using oss.
That worked. Thanks again, you've been very helpful.
Comment 11 Kai Huuhko 2006-03-18 11:38:54 UTC
Created attachment 82481 [details]
Proposed ebuild for quodlibet-0.18
Comment 12 Kai Huuhko 2006-03-18 12:55:29 UTC
Created attachment 82482 [details]
Proposed ebuild for quodlibet-0.18, checked with repoman

Sorry, it's my first ebuild. Checked with repoman, amd64 doesn't have ctypes-0.9.6 which is required for mpc/aac/flac support (ctypes-0.9.9.3 doesn't work with this version of quod libet), made them x86 only.
Comment 13 Kai Huuhko 2006-03-18 13:30:27 UTC
Fiddling around more, I realised that the actual "make" process only checks for required libraries, so we could just skip it and go ahead with "make extensions" and "make install". This way the whole installation process stays inside the sandbox and we can get rid of the workarounds for it.
Comment 14 Sebastian Raterman 2006-03-20 08:36:08 UTC

(In reply to comment #12)
> Created an attachment (id=82482) [edit]
> Proposed ebuild for quodlibet-0.18, checked with repoman
> 
> Sorry, it's my first ebuild. Checked with repoman, amd64 doesn't have
> ctypes-0.9.6 which is required for mpc/aac/flac support (ctypes-0.9.9.3 doesn't
> work with this version of quod libet), made them x86 only.
> 

I'm on amd64 running the ctypes 0.9.6 ebuild with ~x86, and don't seem to have any problems. At least the python-musicbrainz stuff isn't complaining any longer as it was with 0.9.9.3, and actually works. Not sure if it breaks other compatibility though... I have no problems with flac files, but it might be breaking sometimes because of mpc files. Not sure if related...

Thanks for working on an ebuild. (=
Comment 15 Kai Huuhko 2006-03-20 10:59:53 UTC
Created attachment 82687 [details]
Proposed ebuild for quodlibet-0.18

This ebuild skips the (unneeded) library checks, and has proper support for multilib.
Comment 16 Kai Huuhko 2006-03-30 00:43:20 UTC
Quod Libet 0.19 is due to be released in a couple of days, I'll start working on an ebuild once it's out.

> 
> ... I have no problems with flac files, but it might be
> breaking sometimes because of mpc files. Not sure if related...
> 

The gstreamer mpc-decoder is known to be buggy/broken (http://bugzilla.gnome.org/show_bug.cgi?id=332390), we'll just have to wait for them to fix it.
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2006-04-02 01:58:22 UTC
*** Bug 128483 has been marked as a duplicate of this bug. ***
Comment 18 Opera 2006-04-02 03:56:53 UTC
This ebuild works fine, but it doesn't support wavpack files. How come ?
Comment 19 Kai Huuhko 2006-04-02 08:30:33 UTC
I am not quite sure where to find the support for wavpack, according to http://gstreamer.freedesktop.org/documentation/plugins.html there is no plug-in for the format in gstreamer, and installing only libwavpack doesn't enable the support in Quod Libet.
Comment 20 Thomas Cort (RETIRED) gentoo-dev 2006-04-02 18:39:10 UTC
Kia, thanks for the ebuild. I commited it to CVS, slightly modified.