Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 124427 - Hotplug still creates /usr/lib/hotplug/firmware
Summary: Hotplug still creates /usr/lib/hotplug/firmware
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Greg Kroah-Hartman (RETIRED)
Depends on: 145809
  Show dependency tree
Reported: 2006-02-28 08:36 UTC by Robert Kruus
Modified: 2007-09-04 00:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Edited ebuild 20030805-r2 (hotplug-20030805-r2.ebuild,1.83 KB, text/plain)
2006-02-28 08:45 UTC, Robert Kruus
hotplug-20030805-r2.ebuild (hotplug-20030805-r2.ebuild,1.83 KB, text/plain)
2006-02-28 08:45 UTC, Robert Kruus
hotplug-20030805-r3.ebuild (hotplug-20030805-r3.ebuild,1.87 KB, text/plain)
2006-02-28 08:46 UTC, Robert Kruus
hotplug-20040105.ebuild (hotplug-20040105.ebuild,1.67 KB, text/plain)
2006-02-28 08:47 UTC, Robert Kruus
hotplug-20040401.ebuild (hotplug-20040401.ebuild,1.47 KB, text/plain)
2006-02-28 08:48 UTC, Robert Kruus
hotplug-20040920.ebuild (hotplug-20040920.ebuild,1.78 KB, text/plain)
2006-02-28 08:48 UTC, Robert Kruus
hotplug-20040923.ebuild (hotplug-20040923.ebuild,2.16 KB, text/plain)
2006-02-28 08:49 UTC, Robert Kruus
hotplug-20040923-r1.ebuild (hotplug-20040923-r1.ebuild,2.17 KB, text/plain)
2006-02-28 08:50 UTC, Robert Kruus

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Kruus 2006-02-28 08:36:45 UTC
Well, since the hotplug now looks in /lib/firmware, shouldn't the ebuilds now "dodir /lib/hotpug" instead of "dodir /usr/lib/hotplug/firmware" in src_install?
Comment 1 Robert Kruus 2006-02-28 08:38:37 UTC
Oop, I meant "dodir /lib/hotplug" 
Comment 2 Robert Kruus 2006-02-28 08:45:13 UTC
Created attachment 80931 [details]
Edited ebuild 20030805-r2
Comment 3 Robert Kruus 2006-02-28 08:45:51 UTC
Created attachment 80932 [details]

Passed through sed....
Comment 4 Robert Kruus 2006-02-28 08:46:56 UTC
Created attachment 80933 [details]

sed output...
Comment 5 Robert Kruus 2006-02-28 08:47:31 UTC
Created attachment 80934 [details]

more sed output....
Comment 6 Robert Kruus 2006-02-28 08:48:16 UTC
Created attachment 80935 [details]

again with the sed...
Comment 7 Robert Kruus 2006-02-28 08:48:56 UTC
Created attachment 80936 [details]

you get the point...
Comment 8 Robert Kruus 2006-02-28 08:49:53 UTC
Created attachment 80937 [details]

Comment 9 Robert Kruus 2006-02-28 08:50:23 UTC
Created attachment 80938 [details]

last one.
Comment 10 Chris Xe 2006-04-23 20:33:45 UTC
This about drove me crazy until at last I figured it out. Since there are tons of HOWTOs telling you to 
do things to /usr/lib/hotplug/firmware, it might be a good idea for the ebuild to
make a sym link for a while.
Comment 11 Andy Boff 2006-12-05 08:56:09 UTC
I'd second Chris Xe's suggestion. I found my server didn't load some firmware on boot, checked /etc/hotplug/firmware.agent (which seemed to still say /usr/lib/hotplug/firmware), and tried /lib/hotplug on an off chance, and it worked, so headed over here to look for bug reports.

It was /etc/hotplug/firmware.agent that threw me... mine reads:

# directory of the firmware files

which kind of throws you if you're diagnosing.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-12-14 05:04:24 UTC
All our ebuilds install firmware into /lib/firmware; the directory installed by hotplug is thus completely useless (moreover gets unmerged completely on re-emerging hotplug, as there's no keepdir in the ebuild).

As an added bonus, having hotplug installed actually kills firmware loading w/ >=udev-096 - see Bug 147006. I kinda miss the reason why we still have hotplug, causes more harm than good.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-09-04 00:04:38 UTC
sys-apps/hotplug is useless with any recent udev version, and 2.4 kernels are no longer supported. Unmerge it and move on.