Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 124404 - app-misc/mc hangs after closing its parent terminal in x
Summary: app-misc/mc hangs after closing its parent terminal in x
Status: VERIFIED DUPLICATE of bug 137408
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 125270 (view as bug list)
Depends on:
Blocks: 122768
  Show dependency tree
 
Reported: 2006-02-28 06:09 UTC by attila fazekas
Modified: 2009-08-05 11:30 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description attila fazekas 2006-02-28 06:09:58 UTC
X--> terminal-->su-->mc-->close terminal whitout closing mc--> mc hangs and eats up all processor resources.

I tried on x86, amd64, xfce, fluxbox
And now on 2006.0 amd64 install (clean install)
I noticed this problem more than a year ago. (aroud release 2004.2)
Comment 1 Jeffrey Forman (RETIRED) gentoo-dev 2006-02-28 06:11:51 UTC
let's see this gets over to the right product/component next time. the 'bugzilla' category is NOT for application issues.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-05-03 07:02:36 UTC
*** Bug 125270 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-05-03 07:03:51 UTC
Still a problem w/ 4.6.1 :(
Comment 4 Victor Nawothnig 2006-05-03 12:51:00 UTC
Since I build it myself (grabbed source and compiled it) it is working fine, and closing the terminal mc is running is also stops mc properly.
So problem might be portage/gentoo related.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-05-04 12:10:34 UTC
(In reply to comment #4)
> Since I build it myself (grabbed source and compiled it) it is working fine,
> and closing the terminal mc is running is also stops mc properly.
> So problem might be portage/gentoo related.

Try with USE="-ncurses slang", "fixed" it here... well, not really since current slang version is not much unicode friendly. :/
 

Comment 6 spiralvoice 2006-08-09 09:07:18 UTC
Fixed here, too. What about making "slang -ncurses" the default for mc?
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-08-09 09:10:13 UTC
(In reply to comment #6)
> Fixed here, too. What about making "slang -ncurses" the default for mc?

Err, we certainly can't until Bug 61732 is fixed. ;)
Comment 8 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2007-01-23 03:34:48 UTC
this is the last mc bug open, so LETS take a look ;)
Comment 9 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2007-01-24 04:04:01 UTC
I can't reproduce that here.

You need to be root? or a normal user.

And this is with ncurses and slang in use?
Comment 10 Victor Nawothnig 2007-01-24 12:38:27 UTC
I'd say this is a duplicate of this bug: http://bugs.gentoo.org/show_bug.cgi?id=137408
Comment 11 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2007-01-24 16:29:12 UTC
Ahhh, I agree ;)

*** This bug has been marked as a duplicate of bug 137408 ***