Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 124333 - Weird browsers' freezing
Summary: Weird browsers' freezing
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-02-27 17:36 UTC by Paulo
Modified: 2006-03-16 09:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paulo 2006-02-27 17:36:44 UTC
I have an amd64 system, built from stage 1 based on the 2005.1 profile. I have some ~amd64 packages, but not too many, basically KDE and Firefox.
I have a problem regarding Firefox and Opera (most times with Firefox), and I wasn't able to reproduce it on Konqueror, and neither on other distributions, even using the same browsers. Just Opera and Firefox. I have an ATI 9600XT VGA, with portage's 8.18.8-r2 (stable) drivers.  Sometimes, when I'm browsing the Web, my computer will freeze, and my mouse will only move horizontally, on a completely distorted window, and then my computer will reset. On some websites, it'll be easily reproducible, but on some others, it'll be fully randomic. It'll only happen on these browsers (at least, that I'm aware of). I have extensively tried Konqueror, and it'll not have it. One website that certainly causes the bug is, that is the Brazilian version of eBay. It'll be a matter of openning two or more tabs of links from the site on firefox, and it'll freeze. I have even tried installing Firefox by downloading from mozilla's site, but it'll still happen, but not on other distros.
Here's my emerge info:
Portage 2.1_pre5-r1 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-gentoo-r5 x86_64)
System uname: 2.6.14-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon64 -pipe -O2 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -pipe -O2 -fomit-frame-pointer"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="amd64 16bit X acpi alsa amarok apm arts artswrappersuid asf audiofile avi bash-completion berkdb bitmap-fonts bzip2 cddb cdinstall cdrom cpudetection css cups dbus dri dvd dvdr dvdread emul-linux-x86 encode epson fat fbcon ffmpeg firefox foomaticdb fortran fuse gdbm gif gimpprint glut glx gmail gpm gstreamer gtk2 hal id3 imagemagick imlib insecure-savers java jpeg kde kqemu lame lcms libvisual linguas_pt_BR lm_sensors logrotate mad mmext moznocompose moznoirc moznomail mozsvg mp3 mpeg mpeg2 mplayer msn msnextras musicbrainz ncurses nfs nls no-old-linux nocd nogg nptl nptlonly ntfs offensive ogg opengl pam pascal pda pdf pdflib perl png pnp ppds python qt quicktime readline real reiser4 reiserfs samba sblive scp sdl spell sse-filters ssl subtitles swat tcpd tiff transcode truetype truetype-fonts trusted type1-fonts unicode usb userlocales v4l v4l2 vcd vcdimager visualization vorbis wifi wma wma123 xcomposite xine xmms xpm xprint xscreensaver xv xvid zip zlib elibc_glibc kernel_linux userland_GNU"

If I forgot anything, please post it here or e-mail me.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-10 11:37:05 UTC
Not really something we could fix with the information available. Check your hardware.
Comment 2 Paulo 2006-03-10 12:42:40 UTC
It is not a hardware problem...
I have tried Ubuntu and Debian, both 32 bits, and tried surfing on the same sites, for testing the distros, and they wouldn't have the problem at all. What information do you need I give you in order to isolate the problem?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-10 14:09:03 UTC
Try without proprietary ATI drivers, otherwise, no idea really.
Comment 4 Paulo 2006-03-16 09:19:37 UTC
Instead of testing without the proprietary drivers, I went for the ati-drivers-8.23.7, that is marked ~amd64, and It seems to be working now.