Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 123256 - app-cdr/cdrtools-2.01-r3 - mkisofs segfault
Summary: app-cdr/cdrtools-2.01-r3 - mkisofs segfault
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-18 05:20 UTC by Andreas Klauer
Modified: 2006-04-10 12:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
backtrace (backtrace,1.58 KB, text/plain)
2006-02-18 05:20 UTC, Andreas Klauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Klauer 2006-02-18 05:20:17 UTC
mkisofs segfaults on me sometimes. It happens only under certain circumstances, for example when piping mkisofs data into a buffer, piping buffer data to cd writer, and then only when mkisofsing a certain set of files. This is not random - the problem will always occur in this combination, but vanish as soon as I change the set of files or pipe into a file rather than burning on the fly. What makes it hard to reproduce is that you first have to find a set of files that makes the segfault happen.

I'll attach (part of) a backtrace of a coredump I got; I don't know if this is useful to anyone at all. I fear that optimized Gentoo systems are not exactly suited for useful debug information. If anyone wants to have a look at the problem though, I'll be happy to provide more detailed information about it.
Comment 1 Andreas Klauer 2006-02-18 05:20:55 UTC
Created attachment 80093 [details]
backtrace
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-02-18 07:23:28 UTC
Reopen with cdrtools version and emerge --info...
Comment 3 Andreas Klauer 2006-02-18 08:33:47 UTC
app-cdr/cdrtools-2.01-r3 [mkisofs 2.01 (i686-pc-linux-gnu)]

---- 8< ----
# emerge --info
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.15.3 i686)
=================================================================
System uname: 2.6.15.3 i686 AMD Athlon(tm) XP 2000+
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer -g"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer -g"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks nostrip sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,-z,now"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/root/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext 3ds X Xaw3d a52 aac acpi alsa anthy apic apm asf audiofile avi bash-completion berkdb bigger-fonts bitmap-fonts browserplugin bzip2 cdda cddb cdr cid cjk cmov crypt css cups curl custom-cflags cx8 de dga divx4linux doc dts dv dvd dvdr dvdread emboss encode exif expat fam fame ffmpeg firefox flac font-server foomaticdb fortran fpu freewnn ftp fxsr gcj gd gdb gdbm gif gimp gimpprint glut glx gmp gnutls gphoto2 gpm graphviz gs gstreamer gtk gtk2 guile idn ieee1394 imagemagick imlib ipv6 java jpeg lame latex lcms libg++ libwww logitech-mouse lua mad matroska mca mccp mce mikmod mime mjpeg mmx mmxext mng motif mp3 mpeg mplayer msr mtrr ncurses nls nsplugin nvidia ogg oggvorbis openal opengl oss pae pam pat pcre pdflib perl pge png pse pse36 python quicktime readline real reiserfs rtc ruby sblive scanner sdl sep sndfile sox speex spell sse ssl subtitles subversion syscall tcpd tetex theora tiff transcode truetype truetype-fonts tsc type1 type1-fonts udev unicode usb utf8 vcd vme vorbis win32codecs wxwindows x264 xfs xft xine xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LINGUAS
---- 8< ----
Comment 4 Luis Medinas (RETIRED) gentoo-dev 2006-02-18 09:35:20 UTC
and with cdrtools-2.01.01_alpha01 ?
Comment 5 Andreas Klauer 2006-02-18 09:57:10 UTC
mkisofs seems to be identical for cdrtools-2.01.01_alpha01 - it reports the same version number "mkisofs 2.01 (i686-pc-linux-gnu)" and segfaults in the same situation.
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2006-03-11 06:21:10 UTC
UTF-8 filesystem with Umlaute-files?
Comment 7 Lars Weiler (RETIRED) gentoo-dev 2006-04-10 12:01:44 UTC
No answer within a month.  Closing.