Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 122218 - Remove sys-apps/hwdata-knoppix dependency from sys-libs/libkudzu
Summary: Remove sys-apps/hwdata-knoppix dependency from sys-libs/libkudzu
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo LiveCD Package Maintainers
Depends on:
Reported: 2006-02-09 01:32 UTC by Robert Golding
Modified: 2006-02-11 08:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Robert Golding 2006-02-09 01:32:35 UTC
I ran "emerge --synce" and then tried a world update only to get the following:

start ----------------------------------------------------------------
rob rob # emerge -auvD world

These are the packages that I would merge, in order:

Calculating world dependencies \
emerge: there are no ebuilds to satisfy "sys-apps/hwdata-knoppix".
(dependency required by "sys-libs/libkudzu-1.1.62-r1" [ebuild])

!!! Problem resolving dependencies for sys-libs/libkudzu
!!! Depgraph creation failed.
end ------------------------------------------------------------------

I have only recently upgraded to gcc-3.4.4, but everything went well with no problems.  Completely re-emerged the system and world to the new gcc and the entire process ran without incident.

Here is my emerge --info
start ----------------------------------------------------------------
rob rob # emerge --info
Portage 2.1_pre4-r1 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.6-r2, 2.6.15
-gentoo-r3 i686)
System uname: 2.6.15-gentoo-r3 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.12.0_pre15
ccache version 2.3 [disabled]
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=athlon-xp -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share
/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kd
e/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/default
s/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 3dnow X alsa apm arts avi bash-completion berkdb bitmap-fonts bluetooth
 bonobo bzlib cdr crypt cups dvd dvdr eds emboss encode esd foomaticdb fortran f
reetype gdbm gif gnome gpm gstreamer gtk gtk2 hal imlib ipv6 java javascript jpe
g kde libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls nvidia ogg oggvorb
is opengl oss pam pdflib perl png ppds python qt quicktime readline scanner sdl 
spell sse ssl tcpd tiff truetype truetype-fonts type1-fonts vorbis xml2 xmms xv 
zlib elibc_glibc kernel_linux userland_GNU"
end ------------------------------------------------------------------
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-02-09 01:41:10 UTC
@Robert - emerge sys-apps/hwdata-gentoo

@livecd - please, drop the bogus alternative dep... ;)

@portage - eh?

        || ( sys-apps/hwdata-gentoo
                sys-apps/hwdata )"

Why does portage default to non-existent ebuild?
Comment 2 Robert Golding 2006-02-09 05:21:03 UTC
(In reply to comment #1)
> @Robert - emerge sys-apps/hwdata-gentoo

# emerge -C sys-apps/hwdata-knoppix && emerge sys-apps/hwdata-gentoo
fixed it. (knoppix was blocking gentoo)

Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-02-09 05:52:50 UTC
(In reply to comment #2)
> # emerge -C sys-apps/hwdata-knoppix && emerge sys-apps/hwdata-gentoo
> fixed it. (knoppix was blocking gentoo)

Ah, you had it installed before it's been removed from portage. Not a portage fault then.
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2006-02-09 06:26:42 UTC
Why in the world do you even *have* any of this junk installed?  You shouldn't have *any* of hwdata-* or libkudzu on *any* installed machine.  They're only useful for an InstallCD/LiveCD the way they're built.

At any rate, removing the dependency wouldn't have resolved your blocker.  I've removed it from portage now, but you might seriously want to look at what you have installed on your system.  I'm willing to bet that you have at least one package requiring libkudzu that is extremely broken on your system.
Comment 5 Robert Golding 2006-02-09 15:02:54 UTC
All I can assume is they are left over from my original install from the live-cd. I did not add it myself.

Kudzu did come in handy when I was playing around with various different addon cards, a year ago, but now it just sits.  
Any help on what I can remove? 
Is libkudzu required for anything else?

Is this a bug in the live-cd install?  I thought the install would not add anything that isn't required :-)
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2006-02-10 06:57:47 UTC
Likely you added either mkxf86config or hwsetup to your machine.  You can find out what is requesting it by simply removing libkudzu, then running "emerge -Dt world"
Comment 7 Robert Golding 2006-02-10 17:19:06 UTC
(In reply to comment #6)
> Likely you added either mkxf86config or hwsetup to your machine.  You can find
> out what is requesting it by simply removing libkudzu, then running "emerge -Dt
> world"

OK, this is officially weird.  This is what happened:
rob rob # emerge -Dt world
>>> --tree implies --pretend... adding --pretend to options.

These are the packages that I would merge, in reverse order:

Calculating world dependencies ...done!
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2006-02-11 08:22:45 UTC
Try throwing a "u" in there for upgrade.  Anyway, I would say to just look through your world and see what you have.  There shouldn't be anything other than hwsetup/mkxf86config that actually have libkudzu in their *DEPEND.