Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 122164 - Mozilla Thunderbird closes on its own (assertion)
Summary: Mozilla Thunderbird closes on its own (assertion)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Mozilla Gentoo Team
Depends on:
Reported: 2006-02-08 12:21 UTC by Jure Repinc
Modified: 2006-02-25 05:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2006-02-08 12:21:27 UTC
If I leave Mozilla Thunderbird running it just closes itself after some time. I think it is at the time it automatically checks and downloads new mail. If I run it from konzole this is the last message I get:

No running windows found
Warning: unrecognized command line flag -mail
Assertion failure: tm.tm_month > -1 && tm.tm_mday > 0 && tm.tm_hour > -1 && tm.tm_min > -1 && tm.tm_sec > -1, at ../../../../mozilla/nsprpub/pr/src/misc/prtime.c:1558
/usr/libexec/mozilla-launcher: line 119:  9881 Aborted                 "$mozbin" "$@"
thunderbird-bin exited with non-zero status (134)


emerge info
Portage 2.1_pre4-r1 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r2, 2.6.15-gentoo-r3 i686)
System uname: 2.6.15-gentoo-r3 i686 AMD Turion(tm) 64 Mobile ML-28
Gentoo Base System version 1.12.0_pre15
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
FEATURES="autoconfig distlocks sandbox sfperms strict"
LINGUAS="sl en"
USE="x86 3dnow X a52 aac acl acpi alsa apache2 apm arts audiofile avi bash-completition berkdb bitmap-fonts bluetooth bzip2 cairo calendar cdparanoia cdr crypt cups curl dbus dri dts dvd dvdr dvdread eds emboss encode exif fam ffmpeg flac foomaticdb fortran ftp gdbm geoip gif gmp gphoto2 gpm gstreamer gtk gtk2 hal icq idn ieee1394 imagemagick imlib ipv6 jabber jpeg kde lcms libg++ libwww lm_sensors mad matroska mcal mikmod mime mmx mng motif mp3 mpeg mysql ncurses nls nptl nptlonly nsplugin offensive ogg oggvorbis openal opengl oscar oss pam pcmcia pdf pdflib perl php png ppds python qt quicktime readline recode samba scanner sdl smartcard sndfile speex spell sqlite sse ssl svg svga tcpd tetex theora tidy tiff truetype truetype-fonts type1-fonts unicode usb videos vorbis wifi win32codecs wmf xcomposite xine xinerama xml xml2 xpm xprint xscreensaver xv xvid zlib elibc_glibc kernel_linux linguas_sl linguas_en userland_GNU"
Comment 1 Andreas Prieß 2006-02-13 05:25:33 UTC
I can confirm this problem. Thunderbird (with automatic mail checking enabled) always aborts directly after startup while checking for new mail. So there is no chance to do anything.

I get the same message except for one line that is different:
/usr/libexec/mozilla-launcher: line 119:  3944 Aborted   "$mozbin" "$@"

And on the log screen it says
grsec: signal 6 sent to [/path/to/thunderbird]

Same version of thunderbird, but happens with
dev-libs/nspr-4.6.1-r1 and

emerge info:

Portage 2.0.54 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-hardened-r5 i686)
System uname: 2.6.14-hardened-r5 i686 AMD Athlon(tm) prosussor
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [disabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
LINGUAS="de en"
USE="x86 3dnow 3dnowext X aac aalib alsa apache2 apm audiofile avi bash-completion berkdb bitmap-fonts bonobo bzip2 bzlib cdparanoia cdr crypt cups curl dga dv dvd dvdr eds emboss encode exif expat fam ffmpeg flac foomaticdb fortran gd gdbm gif glut gmp gpm gtk gtk2 gtkhtml guile idn imagemagick imlib innodb java javamail jpeg jpeg2k junit kde kdeenablefinal lcms libg++ libwww lua mad matrox mikmod mmx mmxext mng motif mozilla mp3 mpeg mysql ncurses nls nptl nptlonly ogg oggvorbis opengl pam pcre pdflib perl php pic png postgres ppds python qt quicktime readline scanner sdl slang spell sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb vhosts vorbis wmf xine xml xml2 xmms xv xvid zlib video_cards_matrox linguas_de linguas_en userland_GNU kernel_linux elibc_glibc"
Comment 2 Jure Repinc 2006-02-19 04:41:49 UTC
Has anyone checked this problem out? This is getting very irritating. Almost impossible to use TB. I even disabled automatic checking for mail but it looks like it doesn't help. I came back after a week and had a lot of mail waiting and TB just closed after a couple of minutes while downloading the mail.
Comment 3 Jory A. Pratt 2006-02-19 05:31:11 UTC
Have ya tested with a clean profile yet?
Comment 4 Jure Repinc 2006-02-19 06:43:48 UTC
No, I haven't tested with a clean profile. I'll do this later. But today I recompiled nspr and TB with debug and tried to get some more info about the crash. This is what I get:

Assertion failure: tm.tm_month > -1 && tm.tm_mday > 0 && tm.tm_hour > -1 && tm.tm_min > -1 && tm.tm_sec > -1, at ../../../../mozilla/nsprpub/pr/src/misc/prtime.c:1558

Program /usr/lib/mozilla-thunderbird/thunderbird-bin (pid = 15195) received signal 6.
UNKNOWN [/usr/lib/mozilla-thunderbird/thunderbird-bin +0x0001B2C4]
__kernel_sigreturn+0x00000000 [ +0x00000420]
abort+0x000000ED [/lib/ +0x00029E4D]
UNKNOWN [/usr/lib/nspr/ +0x0000ED48]
PR_ParseTimeString+0x00001341 [/usr/lib/nspr/ +0x00021E61]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0016EA3A]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0016F0FD]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0016CCCD]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x00048CC9]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x00048EA0]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0016B62B]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0016D5CF]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x00174294]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x001748D7]
nsMsgProtocol::OnDataAvailable(nsIRequest*, nsISupports*, nsIInputStream*, unsigned int, unsigned int)+0x0000005E [/usr/lib/mozilla-thunderbird/components/ +0x0008A2FE]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0002C804]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x0002CDBD]
UNKNOWN [/usr/lib/mozilla-thunderbird/ +0x00076AA5]
PL_HandleEvent+0x0000004B [/usr/lib/mozilla-thunderbird/ +0x0009625B]
PL_ProcessPendingEvents+0x00000080 [/usr/lib/mozilla-thunderbird/ +0x00096CE0]
UNKNOWN [/usr/lib/mozilla-thunderbird/ +0x000994FD]
UNKNOWN [/usr/lib/mozilla-thunderbird/components/ +0x00019665]
Sleeping for 5 minutes.
Type 'gdb /usr/lib/mozilla-thunderbird/thunderbird-bin 15195' to attach your debugger to this thread.

(gdb) bt
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb75aef56 in nanosleep () from /lib/
#2  0xb75aed60 in sleep () from /lib/
#3  0x0806230e in ah_crap_handler (signum=-1218203660) at nsSigHandlers.cpp:132
#4  0x080632c4 in nsProfileLock::FatalSignalHandler (signo=6) at nsProfileLock.cpp:210
#5  <signal handler called>
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb754f431 in raise () from /lib/
#8  0xb7550e4d in abort () from /lib/
#9  0xb7d9dd48 in PR_Assert (s=0xb7dc4520 "tm.tm_month > -1 && tm.tm_mday > 0 && tm.tm_hour > -1 && tm.tm_min > -1 && tm.tm_sec > -1",
    file=0xb7dc44ec "../../../../mozilla/nsprpub/pr/src/misc/prtime.c", ln=1558) at prlog.c:538
#10 0xb7db0e61 in PR_ParseTimeString (string=0x960872b "Mon, 9 Jan 2006 13: 7:39  0000", default_to_gmt=0, result=0xbfa88810) at prtime.c:1554
#11 0xb7106a3a in nsParseMailMessageState::FinalizeHeaders (this=0x95bcac4) at nsParseMailbox.cpp:1381
#12 0xb71070fd in nsParseMailMessageState::ParseFolderLine (this=0x95bcac4, line=0x0, lineLength=1) at nsParseMailbox.cpp:592
#13 0xb7104ccd in nsMsgMailboxParser::HandleLine (this=0x95bcac0,
    line=0x95df518 "\n-UID: 2212\n", ' ' <repeats 17 times>, "\nVD_HELO, STRONG_BUY\nired=4.0 tests=BAYES_50,\>\n\n3]\noft SMTPSVC(6.0.3790.211);\n src=3D width="..., lineLength=1) at nsParseMailbox.cpp:452
#14 0xb6fe0cc9 in nsMsgLineBuffer::ConvertAndSendBuffer (this=0x95bcbc8) at nsMsgLineBuffer.cpp:268
#15 0xb6fe0ea0 in nsMsgLineBuffer::BufferInput (this=0x95bcbc8,
    net_buffer=0x95d3756 "\nDark Dynamite Inc. (DKDY OTCBB) Announces Huge Contract To Increase\nTheme Park Visitors and Annual Revenues.\nFriday January 6, 11:30 am ET\n\n\nSymbol: DKDY\nPrevious: $1.61\nFridays High: $2.00\nLast Trad"..., net_buffer_size=690) at nsMsgLineBuffer.cpp:205
#16 0xb710362b in nsMsgMailboxParser::ProcessMailboxInputStream (this=0x95bcac0, aURL=0x95ba5a4, aIStream=0x950e23c, aLength=4096) at nsParseMailbox.cpp:309
#17 0xb71055cf in nsMsgMailboxParser::OnDataAvailable (this=0x95bcac0, request=0x0, ctxt=0x0, aIStream=0x6, sourceOffset=2068480, aLength=6)
    at nsParseMailbox.cpp:105
#18 0xb710c294 in nsMailboxProtocol::ReadFolderResponse (this=0x950de98, inputStream=0x6, sourceOffset=6, length=4096) at nsMailboxProtocol.cpp:569
#19 0xb710c8d7 in nsMailboxProtocol::ProcessProtocolState (this=0x950de98, url=0x95ba5a4, inputStream=0x950e23c, offset=2068480, length=4096)
    at nsMailboxProtocol.cpp:704
#20 0xb70222fe in nsMsgProtocol::OnDataAvailable (this=0x950de98, request=0x95a17c0, ctxt=0x0, inStr=0x6, sourceOffset=6, count=6) at nsMsgProtocol.cpp:350
#21 0xb6d18804 in nsInputStreamPump::OnStateTransfer (this=0x95a17c0) at nsInputStreamPump.cpp:437
#22 0xb6d18dbd in nsInputStreamPump::OnInputStreamReady (this=0x95a17c0, stream=0x950e23c) at nsInputStreamPump.cpp:340
#23 0xb7e48aa5 in nsInputStreamReadyEvent::EventHandler (plevent=0x0) at nsStreamUtils.cpp:119
#24 0xb7e6825b in PL_HandleEvent (self=0x9607f94) at plevent.c:688
#25 0xb7e68ce0 in PL_ProcessPendingEvents (self=0x8130998) at plevent.c:623
#26 0xb7e6b4fd in nsEventQueueImpl::ProcessPendingEvents (this=0x8136110) at nsEventQueue.cpp:417
#27 0xb6307665 in event_processor_callback (source=0x833e388, condition=G_IO_IN, data=0x6) at nsAppShell.cpp:67
#28 0xb78a91b0 in g_vasprintf () from /usr/lib/
#29 0x0833e388 in ?? ()
#30 0x00000001 in ?? ()
#31 0x08136110 in ?? ()
#32 0x00000000 in ?? ()
Comment 5 Jure Repinc 2006-02-19 06:54:16 UTC
I think this is the bug from Mozilla Bugzilla:
Comment 6 Jory A. Pratt 2006-02-23 10:34:54 UTC
I hae just bumped nspr-4.6.1 to revision 3, update to it and recompile thunderbird to see if problem is solved for you please.
Comment 7 Jure Repinc 2006-02-25 05:43:13 UTC
It looks that r3 fixed the problem. I have TB open for a few hours now and no crash so far. All messages also downloaded just fine. Thanks!
Comment 8 Jory A. Pratt 2006-02-25 05:50:10 UTC
It it reappears please feel free to reopen the bug. Closing for now.