Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 121902 - x11-misc/pcmanfm ebuild request
Summary: x11-misc/pcmanfm ebuild request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Ben de Groot (RETIRED)
URL: http://pcmanfm.sourceforge.net/
Whiteboard:
Keywords: EBUILD
: 122899 123228 150332 211275 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-06 16:18 UTC by Fabio Bonfante
Modified: 2008-08-31 18:09 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
pcmanfm ebuild. v.1.0 (pcmanfm-0.1.9.6.ebuild,787 bytes, text/plain)
2006-02-06 16:25 UTC, Fabio Bonfante
Details
x11-misc/pcman-0.1.9.6.ebuild (pcmanfm-0.1.9.6.ebuild,678 bytes, text/plain)
2006-02-07 18:27 UTC, Congtat Cia
Details
Ebuild for pcmanfm-0.1.9.8 (pcmanfm-0.1.9.8.ebuild,678 bytes, text/plain)
2006-02-09 00:57 UTC, Balazs Varkonyi
Details
x11-misc/pcmanfm-0.1.9.8.ebuild (pcmanfm-0.1.9.8.ebuild,678 bytes, text/plain)
2006-02-09 01:00 UTC, Balazs Varkonyi
Details
x11-misc/pcmanfm-0.1.9.8.ebuild (pcmanfm-0.1.9.8.ebuild,687 bytes, text/plain)
2006-02-09 14:11 UTC, Fabio Bonfante
Details
x11-misc/pcmanfm-0.1.9.8.ebuild (pcmanfm-0.1.9.8.ebuild,709 bytes, text/plain)
2006-02-09 14:17 UTC, Fabio Bonfante
Details
app-misc/pcmanfm-0.2.1 (pcmanfm-0.2.1.ebuild,1.18 KB, text/plain)
2006-02-19 12:52 UTC, Victor Tseng
Details
PCMan File Manager 0.2.2 (pcmanfm-0.2.2.ebuild,1.31 KB, text/plain)
2006-03-15 07:34 UTC, Paweł Kilian
Details
app-misc/pcmanfm-0.2.3 (pcmanfm-0.2.3.ebuild,1.31 KB, text/plain)
2006-03-30 16:39 UTC, Paweł Kilian
Details
app-misc/pcmanfm (pcmanfm-0.2.4.ebuild,1.31 KB, text/plain)
2006-04-07 22:33 UTC, Paweł Kilian
Details
add-misc/pcmanfm-0.2.4 (ebuild) (pcmanfm-0.2.4.ebuild,1007 bytes, text/plain)
2006-06-26 14:09 UTC, David Shakaryan (RETIRED)
Details
app-misc/pcmanfm-9999.ebuild (SVN version) (pcmanfm-9999.ebuild,1.31 KB, text/plain)
2006-08-08 23:09 UTC, Mangué Nicolas
Details
pcmanfm-0.2.4.ebuild (pcmanfm-0.2.4.ebuild,988 bytes, text/plain)
2006-08-10 13:49 UTC, Jakub Moc (RETIRED)
Details
version bump to 0.3.0.2 (pcmanfm-0.3.0.2.ebuild,933 bytes, text/plain)
2006-08-21 12:07 UTC, Andreas Bager
Details
app-misc/pcmanfm-0.3.1_beta2 (ebuild) (pcmanfm-0.3.1_beta2.ebuild,1007 bytes, text/plain)
2006-09-01 02:07 UTC, David Shakaryan (RETIRED)
Details
pcmanfm-0.3.2_rc1.ebuild (pcmanfm-0.3.2_rc1.ebuild,1.12 KB, text/plain)
2006-10-04 16:02 UTC, Ryan
Details
pcmanfm-0.3.2.1.ebuild (pcmanfm-0.3.2.1.ebuild,1.36 KB, text/plain)
2006-10-05 09:20 UTC, Paul Bredbury
Details
pcmanfm-0.3.2.ebuild (pcmanfm-0.3.2.ebuild,978 bytes, text/plain)
2006-10-25 02:41 UTC, Fabio Bonfante
Details
pcmanfm-0.3.2.2.ebuild (pcmanfm-0.3.2.2.ebuild,1.36 KB, text/plain)
2006-11-12 06:31 UTC, Paul Bredbury
Details
pcmanfm-0.3.5.9.ebuild (pcmanfm-0.3.5.9.ebuild,1.54 KB, text/plain)
2008-02-13 15:55 UTC, Volker Eckert
Details
pcmanfm-0.4.0.ebuild (pcmanfm-0.4.0.ebuild,1.26 KB, text/plain)
2008-05-04 16:10 UTC, Ryoichiro Suzuki
Details
pcmanfm-0.4.1.1.ebuild (pcmanfm-0.4.1.1.ebuild,1.28 KB, text/plain)
2008-05-27 14:55 UTC, Ryoichiro Suzuki
Details
app-misc/pcmanfm-0.4.3 (pcmanfm-0.4.3.ebuild,1.30 KB, text/plain)
2008-06-20 13:11 UTC, Ivan Dives
Details
app-misc/pcmanfm-0.4.5 (pcmanfm-0.4.5.ebuild,1.30 KB, text/plain)
2008-06-29 22:29 UTC, Ivan Dives
Details
see the comment about this attachment (pcmanfm-9999.ebuild,1.67 KB, text/plain)
2008-07-14 14:37 UTC, Tim
Details
app-misc/pcmanfm-0.5.ebuild (pcmanfm-0.5.ebuild,1.33 KB, text/plain)
2008-07-16 15:02 UTC, Benjamin Franzke
Details
app-misc/pcmanfm-0.5.ebuild (pcmanfm-0.5.ebuild,1.33 KB, text/plain)
2008-07-16 15:09 UTC, Benjamin Franzke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Bonfante 2006-02-06 16:18:33 UTC
An extremly fast and lightweight file manager which features tabbed browsing and user-friendly interface.... i've found this simple file manager and made the ebuild (it's my first ebuild... please help me! ;-)
Comment 1 Fabio Bonfante 2006-02-06 16:25:23 UTC
Created attachment 79077 [details]
pcmanfm ebuild. v.1.0

the ebuild works but needs right dependecies... if someone with more xp than me has time... tnx!
Comment 2 Allen Brooker (AllenJB) 2006-02-06 16:40:23 UTC
Some suggestions to improve the ebuild:
Firstly, the naming conventions of ebuilds (as explained in the devleoeprs guide linked below) is: <package-name>-<package-version>[-<optional-ebuild-release>]
The optional-ebuild-release isn't there for the first version of an ebuild for a given package version. There after it becomes -r1, then -r2 and so on.

So your ebuild would correctly be named:
pcmanfm-0.1.9.6.ebuild

2 things regarding SRC_URI:
SRC_URI="http://mesh.dl.sourceforge.net/sourceforge/pcmanfm/pcmanfm-0.1.9.6.tar.gz"

Firstly, we have a mirrors system, which has all the sourceforge mirrors programmed in. To use this, change the URL to:
SRC_URI="mirror://sourceforge/pcmanfm/pcmanfm-0.1.9.6.tar.gz"

Also, it is recommended to use ${P}, ${PV} and ${PN} in SRC_URI. These make ebuild updates far quicker. These are "magic" variables taken off the filename. These are fully explained in the Developers handbook (http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml - there's also some other nice guides in the topic of #gentoo-dev-help on Freenode)

Using these, your SRC_URI would become:
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

Now as you can see ,if the package name or version changes, the source uri automatically gets updated when the filename changes.

You have a surplus newline and tab on your RDEPEND line. So this would become just:
RDEPEND=">=x11-libs/gtk+-2"

The newlines and tabs are just to make multiple dependencies easier to read.

Your src_install is also exaclty the same as the default (see /usr/protage/skel.ebuild), so it's not actually required to put it in.
Comment 3 Allen Brooker (AllenJB) 2006-02-06 16:43:11 UTC
/usr/protage/skel.ebuild should of course be /usr/portage/skel.ebuild in cas you hadn't guessed. That msut be one of my most common typos since starting using Gentoo.
Comment 4 Fabio Bonfante 2006-02-06 17:02:03 UTC
of course! don't worry u r not alone!
thanks for the tips... for the ebuild name i was confused by the "description" field when i sent the attachment, i'll change the ebuild tomorrow (reading the handbook more than for 5 min, i promise! ;-)...now it's quite late here... (damn! 2.01 AM again)!...tnx again


Comment 5 Congtat Cia 2006-02-07 18:27:17 UTC
Created attachment 79185 [details]
x11-misc/pcman-0.1.9.6.ebuild

Here is a modified ebuild with dependencies from the project homepage. Looking foward to its appearance in portage.
Comment 6 Balazs Varkonyi 2006-02-09 00:57:51 UTC
Created attachment 79304 [details]
Ebuild for pcmanfm-0.1.9.8

Version bump and package name correction.
Comment 7 Balazs Varkonyi 2006-02-09 01:00:44 UTC
Created attachment 79305 [details]
x11-misc/pcmanfm-0.1.9.8.ebuild

Version bump and package name correction.
Comment 8 Allen Brooker (AllenJB) 2006-02-09 01:48:54 UTC
(In reply to comment #7)

There's no need to re-submit an ebuild for version bumps when no change is required to the ebuild. Just mention that there's been a new release upstream and that the current ebuild works for it.

As for the attachment summary, that can be changed by editing the attachment. There's also no strict naming system for attachments - the filename can obviously be changed when you download the attachment.
Comment 9 Fabio Bonfante 2006-02-09 14:11:35 UTC
Created attachment 79376 [details]
x11-misc/pcmanfm-0.1.9.8.ebuild
Comment 10 Fabio Bonfante 2006-02-09 14:12:58 UTC
pcmanfm depends on gamin/fam apparently without any problem (configure itself check   what packages is installed), so i added "!fam? " in the app-admin/gamin RDEPEND.
Two questions...
1) if none of those packages are installed and the use flag "fam" is set (strange... but murphy can be always in right!) how can i introduce one of them?

2) x11-libs/gtk+-2.8 and app-admin/gamin (according the home page) are both required for compilation, so i moved them in DEPEND. right?
Comment 11 Fabio Bonfante 2006-02-09 14:17:50 UTC
Created attachment 79378 [details]
x11-misc/pcmanfm-0.1.9.8.ebuild

oops...forgotten "fam? (app-admin/fam)" in DEPEND...
Comment 12 Congtat Cia 2006-02-09 14:32:02 UTC
1. We still need gtk and gamin at runtime. So put them in RDEPEND and use DEPEND= $RDEPEND to share these items.
2. How about editting the ebuild directly? No need to submit a new one.
Comment 13 Congtat Cia 2006-02-09 14:43:57 UTC
gnome-icon-theme should be x11-themes/gnome-icon-theme. Sorry for that.
Comment 14 Fabio Bonfante 2006-02-09 15:29:35 UTC
Comment on attachment 79378 [details]
x11-misc/pcmanfm-0.1.9.8.ebuild

># Copyright 1999-2005 Gentoo Technologies, Inc.
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>
>inherit eutils
>
>DESCRIPTION="PCMan File Manager, an extremly fast and lightweight file manager with tabbed browsing"
>HOMEPAGE="http://pcmanfm.sourceforge.net/"
>SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
>
>LICENSE="GPL-2"
>SLOT="0"
>KEYWORDS="~x86"
>IUSE="nls fam"
>
>RDEPEND="!fam? (app-admin/gamin)
>	fam? (app-admin/fam)
>	>=x11-libs/gtk+-2.8
>	x11-themes/gnome-icon-theme
>	x11-misc/shared-mime-info"
>DEPEND="$RDEPEND
>	>=sys-devel/automake-1.9
>	sys-devel/autoconf
>	dev-util/pkgconfig
>	nls? ( sys-devel/gettext )"
>
>src_install() {
>	make DESTDIR=${D} install || die
>	dodoc AUTHORS COPYING 
>}
Comment 15 Fabio Bonfante 2006-02-09 15:37:36 UTC
i try edit...but it's not what i expected....hmmmmm
otherwise, now it's ok 4u?
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2006-02-15 03:56:03 UTC
*** Bug 122899 has been marked as a duplicate of this bug. ***
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2006-02-15 04:00:39 UTC
>RDEPEND="!fam? (app-admin/gamin)
>	fam? (app-admin/fam)

This is wrong, should be RDEPEND="virtual/fam" or RDEPEND="fam? ( virtual/fam )" (don't know whether it's optional or not).
Comment 18 Alex Zanetti de Lima 2006-02-15 04:11:55 UTC
(In reply to comment #17)
> >RDEPEND="!fam? (app-admin/gamin)
> >	fam? (app-admin/fam)
> 
> This is wrong, should be RDEPEND="virtual/fam" or RDEPEND="fam? ( virtual/fam
> )" (don't know whether it's optional or not).
> 

Pcman said that using gamin is better than usin fam, and I tried to compile it with fam, resulting in a segfault.

Why don't use just RDEPEND="app-admin/gamin ..." , this way we force gamin, right?
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2006-02-15 04:17:44 UTC
(In reply to comment #18)
> Why don't use just RDEPEND="app-admin/gamin ..." , this way we force gamin,
> right?

Because it won't work for people that have app-admin/fam installed. That's what virtuals are for.
Comment 20 Alex Zanetti de Lima 2006-02-15 04:20:58 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > Why don't use just RDEPEND="app-admin/gamin ..." , this way we force gamin,
> > right?
> 
> Because it won't work for people that have app-admin/fam installed. That's what
> virtuals are for.
> 

Ok, fam will block pcmanfm, until the user unemerge fam and start using gamin. A lot of packages does this in portage.
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2006-02-15 04:45:58 UTC
(In reply to comment #20)
> Ok, fam will block pcmanfm, until the user unemerge fam and start using gamin.
> A lot of packages does this in portage.

It's not up to you to force either of them on users if the package supports both.  As said, that's exactly why the virtual exists.

Comment 22 Alex Zanetti de Lima 2006-02-15 04:55:30 UTC
(In reply to comment #21)
> (In reply to comment #20)
> It's not up to you to force either of them on users if the package supports
> both.  As said, that's exactly why the virtual exists.
> 

Sure :)
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2006-02-18 01:51:44 UTC
*** Bug 123228 has been marked as a duplicate of this bug. ***
Comment 24 Victor Tseng 2006-02-19 12:52:57 UTC
Created attachment 80215 [details]
app-misc/pcmanfm-0.2.1

This is the first stable release of pcmanfm, a lot of bugs have been fixed.
tested on x86 and amd64, although i marked them as KEYWORDS="~x86 ~amd64"...

haven't see any problem for now.
Comment 25 Paweł Kilian 2006-03-15 07:34:13 UTC
Created attachment 82216 [details]
PCMan File Manager 0.2.2
Comment 26 nm (RETIRED) gentoo-dev 2006-03-30 13:49:32 UTC
(In reply to comment #24)
This compiles cleanly for me; no runtime errors as well. I like this . . . it still has a few bugs (Ctrl-H doesn't show hidden files like it should), but those are upstream issues. No compilation problems or code errors; it runs just fine from the commandline and from launchers in gnome/xfce-panel.

For the record, the 2.1 ebuild has better formatting/line breaks than the 2.2 ebuild. Not that it matters, as they both grab the same tarball, afaict.
Comment 27 Paweł Kilian 2006-03-30 16:39:36 UTC
Created attachment 83462 [details]
app-misc/pcmanfm-0.2.3

new ebuild for PCMan File Manager
Comment 28 Paweł Kilian 2006-04-07 22:33:31 UTC
Created attachment 84195 [details]
app-misc/pcmanfm

new ebuild for PCMan File Manager
Comment 29 David Shakaryan (RETIRED) gentoo-dev 2006-06-26 14:09:56 UTC
Created attachment 90211 [details]
add-misc/pcmanfm-0.2.4 (ebuild)

I cleaned up the ebuild quite a bit; not sure if I messed anything up, but it works fine here. I did simple things such as cleaning the dependencies.

I also committed it to the Project Sunrise overlay:
http://gentoo-sunrise.org/svn/reviewed/app-misc/pcmanfm/
Comment 30 Mikel Olasagasti 2006-07-29 04:33:09 UTC
As gtk+-2.8 depends on cairo, is not necessary pcmanfm rpedends on it.

Comment 31 Mangué Nicolas 2006-08-08 23:09:47 UTC
Created attachment 93822 [details]
app-misc/pcmanfm-9999.ebuild (SVN version)
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2006-08-10 13:49:36 UTC
Created attachment 93940 [details]
pcmanfm-0.2.4.ebuild

- updated ebuild (removed deps that are part of system, only display pkg_postinst when relevant, change to elog)
Comment 33 Andreas Bager 2006-08-21 12:07:55 UTC
Created attachment 94795 [details]
version bump to 0.3.0.2
Comment 34 Andreas Bager 2006-08-21 12:20:05 UTC
Comment on attachment 94795 [details]
version bump to 0.3.0.2

Probably not in mint condition, but it works for me.
Comment 35 Fabio Bonfante 2006-08-22 10:04:50 UTC
well... nobody can maintain this ebuild?... it seems becoming quite popular this little filemanger.. let's go! can someone insert it in the official portage tree?

ps.
looking at the last ebuild i saw the RDEPEND app-admin/gamin. According to the build istruction on website fam can be still used. (i didn't tested yet, but i trust the author ;-) I know gamin is better but (talking "all about choices") it would be better too use virtual/fam (like in 0.2.4).

Now i'm not on my linux-box sombody can make a try? tnx and "happy ebuilding to everyone"!
Comment 36 David Shakaryan (RETIRED) gentoo-dev 2006-09-01 02:07:13 UTC
Created attachment 95627 [details]
app-misc/pcmanfm-0.3.1_beta2 (ebuild)

Version bump to 0.3.1_beta2. I removed the gnome-icon-theme dependency as it is no longer needed.

http://gentoo-sunrise.org/svn/reviewed/app-misc/pcmanfm/
Comment 37 Pacho Ramos gentoo-dev 2006-10-04 13:00:28 UTC
Version bump!

PCMan File Manager 0.3.2 rc1 has been released :-)

Thanks a lot

http://sourceforge.net/project/showfiles.php?group_id=156956
Comment 38 Ryan 2006-10-04 15:45:14 UTC
2 things on the last beta2 ebuild.  It is missing the startup-notification dependency, and then there needs to be a hal use flag now.
Comment 39 Ryan 2006-10-04 16:02:35 UTC
Created attachment 98807 [details]
pcmanfm-0.3.2_rc1.ebuild

I think this should work ...
Comment 40 Paul Bredbury 2006-10-05 09:20:59 UTC
Created attachment 98854 [details]
pcmanfm-0.3.2.1.ebuild

Added debug & inotify USE flags.
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2006-10-07 01:14:08 UTC
*** Bug 150332 has been marked as a duplicate of this bug. ***
Comment 42 Fabio Bonfante 2006-10-25 02:39:19 UTC
version bump pcmanfm-0.3.2
Comment 43 Fabio Bonfante 2006-10-25 02:41:23 UTC
Created attachment 100446 [details]
pcmanfm-0.3.2.ebuild

removed "beta" and MY_P variable using only che cleaned package name
Comment 44 Csaba Biro 2006-11-02 18:34:07 UTC
The last ebuild (pcmanfm-0.3.2.ebuild) is a big step back from the previous one. No USE flags, no important dependencies. In particular it doesn't work because the startup-notification dependency is removed.
Comment 45 Paul Bredbury 2006-11-12 06:31:13 UTC
Created attachment 101735 [details]
pcmanfm-0.3.2.2.ebuild

Version bump.
Comment 46 Daniele C. 2008-02-03 20:47:12 UTC
I have tried emerging attachment #101735 [details] renamed as pcmanfm-0.3.5.7.ebuild but got:

-----
vfs/vfs-volume-hal.c: In function ���is_in_fstab���:
vfs/vfs-volume-hal.c:1735: error: expected ���;��� before ���)��� token
vfs/vfs-volume-hal.c:1735: error: expected statement before ���)��� token
vfs/vfs-volume-hal.c: In function ���vfs_volume_mount_by_udi���:
vfs/vfs-volume-hal.c:2760: warning: passing argument 1 of ��vfs_volume_hal_mount��� from incompatible pointer type
make[2]: *** [vfs-volume-hal.o] Error 1
-----

I have gnome-vfs-2.20.1-r1 installed, I guess that it's not compatible. Can somebody please update this ebuild and possibly put it on portage? The program is a valid alternative to Thunar, is efficient and lightweight.

Thanks
Comment 47 Volker Eckert 2008-02-13 15:46:16 UTC
> I have tried emerging attachment #101735 [details] [edit] renamed as pcmanfm-0.3.5.7.ebuild but
> got:
[...]
garbage ;-)


> I have gnome-vfs-2.20.1-r1 installed, I guess that it's not compatible.

It is compatible. But the pcmanfm-0.3.2.2-ebuild was not hacky enough for the 0.3.5.7-and-above-code.


> Can
> somebody please update this ebuild?

done.
Comment 48 Volker Eckert 2008-02-13 15:55:24 UTC
Created attachment 143428 [details]
pcmanfm-0.3.5.9.ebuild

I dropped the inotify-USE-flag because support for inotify in pcmanfm is currently borked upstream.
For getting the -debug-USE-flag back to work, I've added a bit of ugly code to catch g_debug-messages over two lines.
Comment 49 Jakub Moc (RETIRED) gentoo-dev 2008-02-24 16:41:58 UTC
*** Bug 211275 has been marked as a duplicate of this bug. ***
Comment 50 teidakankan 2008-03-04 23:22:34 UTC
Version 0.3.6.2 released.

Reference: http://www.gnomefiles.org/app.php/PCMan_File_Manager

Finally, we have a stable release. Cheers! :-)

Here are important changes since 0.3.2 released in 2006.

* The underlying mime-type system was completely re-designed and re-written from scratch. Now it's faster, more robust, and more standard compliant. The memory usage was reduced, too. By installing a xml file to the shared-mime-database, mime-type detection was enhanced.

* Completely re-written volume management, can mount/umount/eject volumes through HAL correctly now.

* Thumbnail support is re-written, and both the speed and stability are improved. Random crashes during thumbnail loading is already fixed.

* New shortcut keys are supported: Now both 'Alt+D' and 'Ctrl+L' can focus the path bar, and 'Backspace' brings you to parent folder.

* Left click on the text of path bar with 'Ctrl' key held down now brings you to parent folders quickly.
Here is a demo. on YouTube.
http://tw.youtube.com/watch?v=aGUOvSMWm6c

* Folder views are correctly updated when files get deleted or created. Some FAM-related bugs were fixed.

* Command line arguments handling was improved. Now you can open multiple files with pcmanfm through command line.

* Correctly handle desktop directory in the side pane. (Get the path of desktop directory from ~/.config/user-dirs.dirs. Hide the item if the directory didn't exist.)

* Config files were moved to ~/.config/pcmanfm to follow the new standard.

* Add drop down menu for "back" and "forward" buttons.

* Open dir in new tab when middle clicking on dir tree.

* Slightly improve path entry.

* Resolve paths with '~' and '.', '..' in command line arguments, if they are not expanded by shell.

* Create dialog UI using new lightweight PtkUIXml system and *.glade files "without" libglade.

* Decrease memory usage and size of executable file.

* Show icons of *.desktop files in every folder.

* Going to another folder when the loading of current folder is not finished works now.

* Add some new locales
Comment 51 Ryoichiro Suzuki 2008-05-04 16:10:42 UTC
Created attachment 151827 [details]
pcmanfm-0.4.0.ebuild

pcmanfm-0.4.0 released.
Comment 52 Fabio Bonfante 2008-05-25 00:30:28 UTC
After "some time" of stop seems that the project is back with a renewed productivity... imho it's time to insert it in portage
Comment 53 Ryoichiro Suzuki 2008-05-27 14:55:44 UTC
Created attachment 154477 [details]
pcmanfm-0.4.1.1.ebuild
Comment 54 Ivan Dives 2008-06-20 13:11:53 UTC
Created attachment 157735 [details]
app-misc/pcmanfm-0.4.3

http://www.gnomefiles.org/app.php?soft_id=1263

Inotify support is currently broken and disabled by default in configure, so I removed everything concerned from ebuild.

Nice fm!
Comment 55 Ivan Dives 2008-06-20 13:27:40 UTC
... and added "desktop-integration" flag. I belive it's self-explanatory.
Comment 56 Ivan Dives 2008-06-29 22:29:19 UTC
Created attachment 158899 [details]
app-misc/pcmanfm-0.4.5

cp pcmanfm-0.4.3.ebuild pcmanfm-0.4.5.ebuild
ebuild pcmanfm-0.4.5.ebuild digest
Comment 57 Tim 2008-07-14 14:37:25 UTC
Created attachment 160341 [details]
see the comment about this attachment

- fixed SVN repository
- added USE flags "hal" and "desktop-integration"
- added keywords "~amd64"
- added to inherit: "fdo-mime"
- added to DOCS: "README"
- added to RDEPEND: hal
- added to DEPEND: sys-devel/gettext
- added src_compile()
- fixed pkg_postinst()
Comment 58 Constrabus 2008-07-15 13:47:31 UTC
how about adding this one to partage....?
after two years of being here
Comment 59 Ira Snyder 2008-07-16 01:49:52 UTC
I'm pleased to report that pcmanfm-9999.ebuild worked perfectly on an otherwise stable amd64 system. I had both the hal and desktop-integration useflag enabled.
Comment 60 Benjamin Franzke 2008-07-16 15:02:37 UTC
Created attachment 160567 [details]
app-misc/pcmanfm-0.5.ebuild

new version + removed desktop-integration useflag (make fails if disabled)
Comment 61 Benjamin Franzke 2008-07-16 15:09:14 UTC
Created attachment 160569 [details]
app-misc/pcmanfm-0.5.ebuild
Comment 62 Ben de Groot (RETIRED) gentoo-dev 2008-08-31 18:09:31 UTC
x11-misc/pcmanfm-0.5 is now in CVS and should show up on your local rsync mirror shortly :)

Thanks everybody for contributing!